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VisualCron	-	Automation	Tool	For	Windows
VisualCron	is	an	advanced	Job/Task	scheduler	for	Windows.

About	VisualCron

VisualCron	is	a	tool/utility	that	runs	other	commands/programs/tools/utilities	at	predefined	time(s),	interval(s)	or	events.	VisualCron
is	designed	for	Windows	with	the	intention	to	simplify	scheduling	of	Windows	Tasks.

VisualCron	is	provided	by	the	NetCart	AB,	an	SMA	Technologies	company,	a	company	that	develops	applications	and	web
services.	Don't	hesitate	to	use	contact	web	page	for	improvement	suggestions,	problem	reports	or	business	proposals.

VisualCron	Documentation

This	is	the	VisualCron	documentation,	build	date	6/6/2024.

This	document	describes	VisualCron	8.

See	changes	from	VisualCron	4.x	to	5.x	here	and	5.x	to	6.x	here	and	6.x	to	7.x	here	and	7.x	to	8x	here.

This	documentation	is	provided	as	is,	please	check	visualcron.com	for	latest	documentation	and	support	information.	For	a	quick
introduction	in	VisualCron,	click	on	the	top	right	flash	Tutorial	area	in	the	VisualCron	Web	Site.	The	goal	is	to	have	a	tool	tip	to
every	enter	field,	label	and	combo	box	in	the	VisualCron	Client	application.	Hovering	the	mouse	over	a	field	is	an	easy	way	to	get
quick	information	and	what	to	enter.

NOTE

If	you	Download	help	file	from	visualcron.com,	don't	forget	to	"unblock"	the	file	before	opening.	Due	to	the	Windows	security
system,	the	help	chapters	might	show	an	"Illegal	address"	message	indicating	a	wrong	address	entered	in	an	internet	browser,
instead	of	the	help	text.	Right-click	on	the	downloaded	file	Properties	->	General	->	Unblock	(Windows	XP).
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VisualCron	End-User	License	Agreement
Last	updated:	November	2,	2023

This	VisualCron	End-User	License	Agreement	(this	"Agreement")	is	dated	as	of	the	date	specified	in	the	Sales	Order	(the	"Effective
Date")	by	and	between	You	("Licensee")	and	Unisoft	International,	Inc.,	dba	SMA	Technologies	("Licensor").

License	Grant

"We",	"us"	and	"our"	refer	to	the	SMA	Technologies	company	(with	its	initial	development	team	and	web	site,
http://www.visualcron.com.

We	hereby	grant	you	a	nonexclusive	license	to	use	one	copy	of	the	VisualCron	Server	on	any	single	computer,	provided	the	Server
software	is	in	use	only	on	one	computer	at	any	time.	The	"Software"	includes	the	VisualCron	Server,	the	VisualCron	Client,	and
other	software	components	downloaded	from	http://www.visualcron.com.	"Use"	means	to	download,	install,	access,	execute,	or
otherwise	benefit	from	the	Software.

This	is	a	license,	not	a	sales	agreement,	between	you,	the	end-user	and	Licensor.	"You"	and	"your"	refer	to	any	person	or	entity
acquiring	or	using	the	Software,	Documentation,	or	any	other	item	from	visualcron.com	("VisualCron	product")	under	the	terms	of
this	License	Agreement,	including	any	Affiliate,	where	"Affiliate"	means	any	corporation	or	other	legal	entity	that	controls,	is
controlled	by,	or	is	under	common	control	with	You.

You	may	copy	the	VisualCron	product	for	back-up,	disaster	recovery,	testing,	and	archival	purposes,	provided	that	the	original	and
each	copy	is	kept	in	your	possession	and	that	your	installation	and	use	of	the	VisualCron	product	does	not	exceed	what	is	allowed	by
this	License	Grant.

The	activation	code	delivered	to	you	is	personal	to	you	and	cannot	be	disclosed	to	any	other	person	other	than	as	a	transfer	of	all
your	rights	as	described	below.	The	use	of	your	activation	code	by	anyone	other	than	you	will	be	deemed	a	willful	violation	of	this
license.

Proprietary	Rights

The	VisualCron	product	is	intellectual	property	of	Licensor	and	is	protected	by	Swedish	copyright	and	patent	laws,	international
treaty	provisions,	and	applicable	laws	of	the	country	in	which	it	is	being	used.	You	agree	to	protect	all	copyright	and	other
ownership	interests	of	Licensor	for	all	items	in	the	VisualCron	product	supplied	under	this	License	Agreement.	You	agree	that	all
copies	of	the	items	in	the	VisualCron	product,	reproduced	for	any	reason	by	you,	contain	the	same	copyright	notices,	and	other
proprietary	notices	as	appropriate,	as	appear	on	or	in	the	original	items	delivered	by	SMA	Technologies	or	its	predecessor	NetCart
AB.

Licensor	retains	title	and	ownership	of	the	items	in	the	VisualCron	product,	and	all	previous	and	subsequent	copies,	regardless	of
the	form	or	media	in	or	on	which	the	original	and	other	copies	may	exist.	Except	as	stated	above,	this	License	Agreement	does	not
grant	you	any	rights	to	patents,	copyrights,	trade	secrets,	trademarks,	or	any	other	rights	in	respect	to	the	items	in	the	VisualCron
product.

Licensor	may	transfer	the	ownership	of	the	VisualCron	product	to	another	owner	without	prior	notice	at	any	time,	subject	to	the
terms	of	this	Agreement.

Licensor	guarantees	it	is	the	owner	of	the	VisualCron	product	and	has	the	legal	right	to	sell	it.

Distribution

This	VisualCron	product	may	be	freely	distributed	by	special	agreements	between	Licensor	and	other	parties.	Links	to	the
http://www.visualcron.com	website	are	welcome.

Things	You	May	Not	Do

1.Copy	the	VisualCron	product	except	to	make	archival,	disaster	recovery,	testing	or	backup	copies,	or	as	provided	above;	2.Modify
or	adapt	the	Software	or	merge	it	into	another	program;	3.Reverse-engineer,	disassemble,	decompile	or	make	any	attempt	to
discover	the	source	code	of	the	Software;	4.Sell,	sublicense,	rent,	lease,	or	lend	any	portion	of	the	VisualCron	product	to	any	third
party;	or	5.Transfer	the	license	to	anyone.
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Documentation

Documentation	is	provided	online	and	by	installation	in	PDF-format.	Use	Adobe	Acrobat	Reader	to	open	the	document.	The
Documentation	can	be	changed	anytime	and	therefore	we	highly	recommend	using	the	online	documentation.

Updates	of	the	online	Documentation	are	generally	done	with	a	new	software	release;	and	as	this	is	noted	to	our	customers	with	a
valid	license	and/or	registered	users,	this	also	indicates	that	the	Documentation	may	be	updated.	See	the	specific	release	note	for
areas	that	are	subject	to	the	update.

Trial	period

Each	VisualCron	product	has	a	trial	period	of	thirty	(30)	days.	The	trial	period	gives	you	a	chance	to	fully	test	the	software	free	of
charge.	After	the	trial	period	has	ended,	you	will	no	longer	be	able	to	control	the	VisualCron	Server	through	the	VisualCron	Client.

If	the	trial	period	has	ended,	there	is	no	way	of	using	future	upgrades	without	ordering	the	full	license.	See	Upgrade/Updates	below.

Support	limitations

•The	end-user	must	have	an	active	Maintenance	License	/	Subscription	that	is	in	good	standing.	•The	active	Maintenance	/
Subscription	License	is	required	on	the	Server	in	question	that	the	support	is	related	to.	•The	support	is	limited	to	the	employees	of
the	end-user.	Any	third	party,	i.e.,	external	or	third	party	support	or	developers	must	own	at	least	one	active	Maintenance	License	in
addition	to	the	active	Maintenance	/	Subscription	License(s)	for	the	end	user.

Perpetual	vs	Subscription	license

In	14th	of	February	2022	VisualCron	moved	from	Perpetual	license	model	to	Subscription	license	model.	Licenses	purchased	before
this	date	remain	perpetual	with	Support	limitations	described	above.	Using	Cloud	access	features	(mobile	app,	cloud	servers
functionality,	etc.)	requires	an	active	Maintenance	/	Subscription.	With	the	new	subscription	license,	the	renewal	of	the	subscription
is	mandatory	for	Jobs	to	execute	on	the	VisualCron	Server.

Version	-	End	of	life	support

Each	version	is	supported	for	one	(1)	year	after	the	release	date.	After	that,	upgrade	is	recommended	to	enable	all	the	technical
changes	that	occur	throughout	the	year.	Release	dates	can	be	found	here.

Activation	code

The	activation	key	will	lock	the	Software	to	the	computer	it	is	installed	on.	Once	the	activation	key	is	used,	the	code	is	consumed.
This	means	that	you	can	only	activate	one	time.	Under	limited	circumstances,	like	the	server	has	crashed,	the	activation	key	can	be
unlocked	and	consumed	again.	You	may	request	to	move	a	license	to	another	server.	These	operations	(reset/transfer/move)	require
a)	that	you	have	an	active	Maintenance	account	in	good	standing;	and	b)	that	the	operation	is	manually	approved	by	VisualCron
staff.

Notwithstanding	anything	herein,	we	represent	and	warrant	that	we	will	not	include	any	Trojan	horses,	worms,	or	other	codes
designed	to	disable	the	Software	once	installed	pursuant	to	a	full	license.

Activation	and	deactivation	of	a	license

The	process	of	deactivating	/	moving	a	license	requires	that	you	have	an	active	Maintenance	account	in	good	standing.

License	Types	and	Limitations

Single	server	licenses	-	can	be	installed	in	and	moved	but	may	not	be	used	on	more	than	one	server	at	the	same	time.	This	is
installation	purpose;	may	it	be	test,	development,	or	production	machine.

Site	license	-	allows	unlimited	server	installations	within	a	single	physical	location	(typically	a	data	center).

Country	license	-	allows	unlimited	server	installations	within	a	single	country.

World	license	-	allows	unlimited	server	installations	worldwide.

For	"unlimited"	cloud	installations,	it	is	up	to	discussion	depending	on	usage,	expected	quantity,	and	locations.	The	suggested
solution	may	result	in	a	specific	agreement	that	results	in	two	(2)	or	more	Site	licenses,	a	Country	license,	or	a	World	license.

Upgrades/Updates

Updates	with	new	functionality	and	bug	fixes	may	be	released	at	any	time.	A	Subscription	is	necessary	in	order	to	upgrade	to	a
newer	version	than	was	available	at	the	time	of	initial	purchase.	The	Subscription	also	gives	you	access	to	priority	support.



Reporting	of	Bugs

While	it	is	not	our	intent	that	you	should	find	bugs,	if	you	do	find	issues	with	our	product,	please	report	them	to	us	on	the	contact
web	page.

Lifetime	of	VisualCron

Support	Support	is	limited	to	the	way	the	Software	functions	included	in	the	VisualCron	download	were	intended	to	be	used.	No
products	or	commands,	outside	the	VisualCron	download,	are	supported.	In	addition,	Support	is	limited	to	the	product	life	cycle
described	in	Upgrades/Updates.

Term	and	Termination	This	License	Agreement	takes	effect	upon	your	downloading	or	acquisition	of	the	VisualCron	software	and
remains	effective	until	terminated.	You	may	terminate	this	Agreement	at	any	time	by	no	longer	using	VisualCron	and	destroying	all
copies	of	the	software	in	your	possession.	This	License	Agreement	will	terminate	upon	30	days	written	notice	if	you	fail	to	comply
with	any	of	its	terms	or	conditions.	At	which	time,	You	agree	to	destroy	all	copies	of	the	VisualCron	software	in	your	possession.

Product	lifetime	The	goal	is	to	keep	the	VisualCron	product	"alive"	and	online	as	long	as	possible.	The	VisualCron	product	may
cease	to	exist	anytime	without	notice.	All	VisualCron	product	services,	like	support,	upgrades	and	unlocking,	will	then	also	cease	to
exist.	Notwithstanding	anything	herein	to	the	contrary,	in	the	event	the	VisualCron	product	ceases	to	exist	with	respect	to	support	or
availability,	you	shall	retain	all	rights	to	use	the	product	pursuant	to	the	license	set	forth	herein,	except	for	the	right	to	receive
support,	Upgrades,	or	Updates.

No	Warranty

VisualCron	is	a	useful	but	also	powerful	tool.	Any	misuse	can	cause	loss	of	data.	The	VisualCron	product	has	no	warranty	of	fitness,
suitability	for	a	particular	purpose	or	satisfactory	quality.	The	VisualCron	product	is	provided	to	licensee	"as	is."	Licensor	is	not
responsible	for	any	damage	that	may	occur	through	any	use	of	the	VisualCron	product,	except	to	the	extent	caused	by	our	gross
negligence	or	intentional	misconduct.

General	Provisions

This	written	License	Agreement	is	the	exclusive	Agreement	between	you	and	us	concerning	the	VisualCron	product	and	supersedes
any	prior	communication,	advertising,	or	representation	concerning	the	VisualCron	product.

This	License	Agreement	may	be	modified	only	in	writing	and	signed	by	you	and	us.

In	the	event	of	litigation	between	you	and	us	concerning	the	VisualCron	product,	the	prevailing	party	in	the	litigation	will	be
entitled	to	recover	attorney	fees	and	expenses	from	the	other	party.

Downloading	and	installing	this	Software	indicates	your	acceptance	of	the	foregoing	agreement.	If	you	choose	to	decline	the
foregoing	agreement,	you	should	not	download	or	install	the	software.

This	Agreement	is	governed	by	the	laws	of	the	State	of	Texas,	United	States	of	America	(without	regard	to	conflicts	of	law
principles)	for	any	dispute	between	the	parties	or	relating	in	any	way	to	the	subject	matter	of	this	Agreement.	The	UN	Convention
on	Contracts	for	the	International	Sale	of	Goods	does	not	apply.	Any	suit	or	legal	proceeding	must	be	exclusively	brought	in	the	US
federal	or	state	courts	for	the	jurisdiction	of	the	main	address	of	the	defendant	in	such	proceedings,	and	each	party	submits	to	this
personal	jurisdiction	and	venue.
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Requirements

Operating	systems

VisualCron	is	designed	for	Windows	based	computers
VisualCron	works	on	the	following	operating	systems:	Windows	Server	2008	R2/2012/2016/2019/2022	and	Windows	8/10/11
VisualCron	works	on	both	32-bit	and	64-bit	processors
VisualCron	requires	.NET	4.8

Computer	requirements	(Server	only)

Operating	system	-	recommended	Windows	operating	system	is	Windows	Server	2008	R2/2012/2016/2019/2019/2022
Disk	space	-	please	reserve	1GB	to	4GB	depending	on	how	much	logging	you	need	to	store
CPU	-	2GHz	or	more,	quad	core	or	more
Memory	-	4GB	or	more

Computer	requirements	(Client	only)

Operating	system	-	recommended	Windows	operating	system	is	Windows	8/10/11
Disk	space	-	please	reserve	1GB
CPU	-	2GHz	or	more,	quad	core	or	more
Memory	-	4GB	or	more
Minimum	screen	resolution	1920*1080
Computer	requirements	(Client	and	Server)

Operating	system	-	recommended	Windows	operating	system	is	Windows	Server	2008
R2/2012/2016/2019/2022

Disk	space	-	please	reserve	1GB	to	4GB	depending	on	how	much	logging	you	need	to	store
CPU	-	2GHz	or	more,	quad	core	or	more
Memory	-	4GB	or	more
Minimum	screen	resolution	1920*1080
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Change	Log

11.1.4	[2024-05-02]

Features

✳	Client:	Server	SLA	and	Server	Health	moved	to	Subscription	tier	(VCPCM-850)

Bug	Fixes

✅	Client:	Main	screen	Grid	filter	improved	(VCPCM-1055)

✅	Client/Server:	Excel	Convert	Task	adjusted	on	processing	date(time)	values	(VCPCM-1054)

✅	Client/Server:	File	Sync	Task	Extend	Debug	logging	added	(VCPCM-1053)

✅	Client:	Job	and	Task	Log	screens	UX	improved	(VCPCM-1031)

✅	Client/Server:	Object	Replaces	for	User	Variables	processing	has	been	improved	(VCPCM-713)

✅	Client/Server:	Detailed	error	messages	fully	under	control	of	extended	debugging	flag	(VCPCM-1055)

11.1.1	[2024-03-12]

Features

✳	Client/Server:	Connections	management	is	now	available	in	WebClient	(VCPCM-471)

✳	Client/Server:	Add	the	capability	to	save	the	email	body	to	an	RPA	variable	within	the	Outlook	"Get	Message"	activity
(VCPCM-833)

✳	Client/Server:	Add	the	ability	to	handle	errors	in	Web	Macro	activities	using	the	TryCatch	activity	(VCPCM-763)

Bug	Fixes

✅	Client/Server:	Running	job	in	asyncronous	mode	behavior	improved	(VCPCM-858)

✅	Client/Server:	HTTP	triggers	now	present	full	certificate	chain	for	HTTPS	connections	(VCPCM-812)

✅	Client/Server:	NRE	fixed	when	flows	are	being	processed	(VCPCM-731)

✅	Client/Server:	"JSON	Encode"	Task	was	failing	generating	a	valid	array	out	of	the	text	file	(VCPCM-715)

✅	Client/Server:	Blank	file	with	just	the	header	line	results	an	empty	SQL	query	(VCPCM-689)

✅	Client/Server:	Archive	task	instances	are	now	isolated	by	using	different	temporary	folders	(VCPCM-679)

✅	Client/Server:	WebClient	refreshes	whenever	a	Job	gets	updated	on	server	(VCPCM-637)

✅	Client/Server:	Slack	event	trigger	fixed	when	listening	to	a	channel	(VCPCM-589)

✅	Client/Server:	Fixed	automatic	addition	of	a	user	certificate	with	a	private	key	to	the	Trusted	Root	Certificates	store	(VCPCM-
837)

11.0.0	[2024-01-29]

Features

✳	Client/Server:	Cookies	data	stored	in	Robot	Task	(VCPCM-660)
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✳	Client/Server:	Key	press	events	added	for	web	activities	(VCPCM-655)

✳	Client/Server:	OCR	Improvements	and	fixes	regarding	text	recognition	area,	UI	element	behavior,	noise	processing	and	OCR
activity	designer	(VCPCM-680)

Bug	Fixes

✅	Client/Server:	PGKKeyrings	operations	improved	when	manipulating	private	keys	(VCPCM-712)

✅	Client:	"Loop	Variables"	menu	improved	when	working	with	the	Loop	activity	designer	(VCPCM-698)

✅	Client/Server:	Iteraction	between	ContinueLoop	and	Loop	activities	improved	(VCPCM-691)

✅	Client/Server:	WebAPI	now	disregards	certificates	without	private	key	(VCPCM-686)

✅	Client/Server:	"Job	-	List"	Report	does	not	check	Theme	when	outputting	to	CSV	format	(VCPCM-656)

✅	Client/Server:	"Continue	with	next	Task"	is	added	back	into	flow	(VCPCM-650)

✅	Client/Server:	Job	variable	evaluation	fixed	in	Robot	Task	(VCPCM-648)

✅	Client/Server:	NullReferenceException	fixed	in	SharePoint	Download	task	(VCPCM-642)

✅	Client/Server:	WebMacro	Task	behavior	fix,	ensuring	stable	performance	during	the	concurrent	execution	of	multiple	instances
(VCPCM-641)

✅	Server:	WebAPI	UTF8	support	fixed	for	JSON	endpoints	(VCPCM-636)

✅	Client/Server:	Web	Macro	designer	fixed	when	a	task	is	disabled	(VCPCM-618)

✅	Client/Server:	WebAPI	Authentication	improved	on	token	management	(VCPCM-588)

✅	Client/Server:	SyncFiles	Task	fixed	when	operating	between	two	remote	file	shares	(VCPCM-565)

✅	Client/Server:	Azure	Connection	empty	file	upload	fixed	behavior	(VCPCM-402)

✅	Client/Server:	WebMacro	Show	Debugger	crash	fixed	(VCPCM-335)

✅	Client/Server:	Transport	security	protocols	updated	for	Azure	Cloud	connections	(VCPCM-334)

10.0.3	[2023-12-14]

Features

NOTES

Client/Server:	Eliminated	licensing	restrictions	for	the	MFT	feature	(VCPCM-599)

Client/Server:	Eliminated	licensing	restrictions	for	the	RemoteExecute	Task	(VCPCM-583)

✳	Client/Server:	Added	a	new	category	"User	input"	for	Robot	Task	(VCPCM-83)

✳	Client/Server:	Introduced	new	features	for	the	"PDF	-	add	header/footer"	task,	including	angle	of	rotation	(in	degrees)	and
opacity	settings,	along	with	updated	documentation	(VCPCM-544)

✳	WebClient:	Implemented	the	Tools->Gantt	chart	feature	(VCPCM-194)

Bug	Fixes

✅	Client/Server:	Removed	Debugger	detection	when	using	VisualCron	.NET	API	in	custom	.NET	projects	(VCPCM-619)

✅	Client/Server:	Resolved	the	issue	causing	service	crashes	in	certain	cases	when	completing	the	last	Task	(VCPCM-95)

✅	Client/Server:	Implemented	permission	checks	for	Read	and	Add	(or	Edit	for	ServerSettings)	permissions	in	the	Export	and
Import	forms.	If	certain	settings	are	not	available	for	export	or	import,	a	warning	message	is	displayed	to	the	user	(VCPCM-79)

✅	Client/Server:	Updated	the	vulnerable	"Apache	log4net"	file	(log4net.dll)	version	1.2.10.0	to	address	"CVE-2018-1285"
security	vulnerability,	ensuring	enhanced	security	on	Windows	Server	2019	(VCPCM-77)

✅	Client/Server:	Implemented	error	handling	for	the	"No	file(s)	found"	scenario	in	the	following	tasks:	Cloud	List	items,
WebDAV	List	items,	and	Sharepoint	List	files	(VCPCM-71)



✅	Client/Server:	Resolved	the	issue	of	system	crashes	occurring	when	attempting	to	stop	a	job	in	the	middle	of	executing	a	stored
procedure	in	SQL	Task	(VCPCM-61)

✅	Client/Server:	Refined	limitations	for	RobotTask	operations	during	Trial	period	(VCPCM-586)

[BUGFIX]	Client/Server:	Enhanced	ParseVariable()	error	reporting.	Fixed	FTP/SFTP/SCP	reconnection	process.	Fixed	event
skipping	in	the	File	Trigger	when	the	"Consolidate	changes"	timeout	is	specified	(VCPCM-585)

✅	Client/Server:	Excessive	locks	removed	when	processing	Task	Started/Completed	events	(VCPCM-584)

✅	Client/Server:	Corrected	handling	of	"List	Variable"	activities	to	ensure	proper	function	when	encountering	empty	items
(VCPCM-576)

✅	Client/Server:	Updated	job	termination	logic	to	ensure	the	status	is	set	to	"Failure"	when	a	job	is	forcibly	stopped,	correcting
the	previous	behavior	where	it	could	erroneously	report	"Success"	(VCPCM-573)

✅	Client/Server:	Introduced	functionality	to	regenerate	a	list	variable	in	the	"List	Variable	Load"	activity	(VCPCM-570)

✅	Client/Server:	Refined	impersonation	handling	and	enhanced	logging	details	for	Sync/Copy	file(s)	Tasks	(VCPCM-565)

✅	Client/Server:	Updated	SCP	transfer	tasks	with	an	enhanced	component	for	more	reliable	SCP	connections	(VCPCM-561)

✅	Client/Server:	End-User	License	Agreement	(EULA)	revised	(VCPCM-560)

✅	Client/Server:	Resolved	issue	with	auto-generation	of	default	Task	Flows	in	Import/Export	function	(VCPCM-559)

✅	Client/Server:	Added	a	column	selection	feature	to	the	"Historic	-	transfers"	tab	in	the	Log	section	(VCPCM-558)

✅	Client/Server:	Implemented	logging	for	user	impersonation	errors	prior	to	task	execution	(VCPCM-553)

✅	Client/Server:	Corrected	the	output	formatting	in	the	function	for	retrieving	values	from	a	"List	variable"	result	(VCPCM-548)

✅	Client/Server:	Resolved	the	issue	where	executing	Robot	Tasks	outside	of	test	mode	used	insufficient	"VisualCron	system
group"	permissions,	hindering	the	creation	of	new	variables	(VCPCM-546)

✅	Client/Server:	Enhanced	the	deactivation	process	for	Triggers	with	expiration	settings	to	function	correctly	(VCPCM-545)

✅	Client/Server:	Resolved	the	issue	where	the	VisualCron	server	was	unable	to	apply	a	self-signed	certificate	for	securing	a
WebAPI	endpoint	(VCPCM-542)

✅	Client/Server:	Enhanced	server	log	precision,	secured	XML	file	saving	with	locks,	and	improved	thread-safe	authorization	for
Box	Connections	(VCPCM-541)

✅	Client/Server:	Corrected	the	functionality	for	accurately	reporting	the	amount	of	available	RAM	in	Server	Monitor	(VCPCM-
524)

✅	Client/Server:	Introduced	features	for	customizing	text	recognition	area	and	added	notifications	with	guidance	on	selecting	an
OCR	area	(VCPCM-520)

✅	Client/Server:	Resolved	an	issue	where	headless	browser	became	unresponsive	after	completing	a	sequence	of	activities,	by
replacing	asynchronous	calls	with	synchronous	ones	based	on	investigation	findings	(VCPCM-517)

✅	WebClient:	Corrected	the	functionality	of	the	Install	and	Enable	buttons	for	IIS	and	IIS	Express	in	the	Server	Settings	form
(VCPCM-504)

✅	Client/Server:	Improved	documentation	for	RobotTask	(VCPCM-501)

✅	Client/Server:	Robot	Task:	Implemented	error	handling	settings,	including	the	addition	of	a	form	and	a	dialog	box	for
configuring	these	activity	parameters	(VCPCM-5)

✅	Client/Server:	Resolved	an	error	encountered	when	interacting	with	a	screenshot	that	was	previously	utilized	by	the	Scan
Document	(local)	task	(VCPCM-498)

✅	Client/Server:	Addressed	and	eliminated	memory	leaks	in	WebMacro	Tasks	during	extensive	usage	scenarios	(VCPCM-487)

✅	Client/Server:	Enhanced	SFTP	client	configuration	by	implementing	automatic	selection	of	all	supported	KEX,	PK,	EA,	MAC
algorithms	instead	of	just	the	one	last	reported	by	server	(VCPCM-477)

✅	Client/Server:	Restored	synchronization	block	for	SAP	to	manage	connection	opening	and	job	creation	more	effectively,	along
with	other	miscellaneous	fixes	(VCPCM-476)

✅	Client/Server:	Corrected	log	messages	related	to	the	user	login	process	for	clarity	and	accuracy	(VCPCM-469)



✅	Client/Server:	Added	support	for	LDAP	over	SSL	(LDAPS)	in	AD	authentication,	accommodating	ports	636	and	3269
(VCPCM-451)

✅	Client/Server:	Implemented	functionality	in	the	login	form	to	reset	an	invalid	Active	Directory	(AD)	token	if	required,	ensuring
proper	authentication	(VCPCM-41)

✅	Client/Server:	Enhanced	locking	mechanisms	and	exception	handling	for	Job	processes	to	prevent	instances	of	hanging	at	99%
completion	(VCPCM-385)

✅	Client:	Introduced	the	ability	to	reveal	job	folders	not	only	via	the	settings	form	but	also	through	manual	adjustment	of	the
splitter	(VCPCM-378)

✅	Client/Server:	Reduced	the	occurrence	of	application	crashes	attributed	to	resource	errors	when	operating	through	Citrix
(VCPCM-372)

✅	Client/Server:	Resolved	the	issue	of	reading	empty	stored	procedure	results	in	the	SQL	Task	(VCPCM-371)

✅	Client/Server:	Enhanced	the	SQL	Task	by	adding	additional	debug	logging	when	retrieving	a	list	of	stored	procedures	for
improved	debugging	and	error	tracking	(VCPCM-37)

✅	Client/Server:	Implemented	processor	affinity	in	the	task	to	optimize	the	configuration	of	thread	count	for	the	7-zip
compressor,	ensuring	more	accurate	performance	(VCPCM-368)

✅	Client/Server:	Enhanced	the	EventLog	Trigger	to	make	three	attempts	to	initiate	the	watcher	and	generate	a	Client	event	in	the
event	of	a	failure	(VCPCM-350)

✅	Client/Server:	In	the	Sharepoint	Upload	file(s)	Task,	when	uploading	files	with	recursive	subfolders,	the	corresponding
subfolders	are	now	automatically	generated	on	the	site	(VCPCM-347)

✅	Client/Server:	Enhanced	the	XML	validation	process	by	improving	the	method	for	obtaining	the	targetNamespace	from	XSD
files	(VCPCM-341)

✅	Client/Server:	Fixed	the	calculation	of	the	relative	destination	path	in	Cloud	Upload	files	when	the	Source	folder	in	the	File
filter	ends	with	a	path	separator,	ensuring	proper	functionality	(VCPCM-34)

✅	Client/Server:	Resolved	the	Task	form	crash	issue	that	occurred	when	selecting	the	Cloud	Copy/move	Task	type	on	the	Main
settings	tab	(VCPCM-333)

✅	Client/Server:	Implemented	auto-replacement	of	incorrect	characters	in	the	message	ID	when	generating	the	save	path	in	the
Email	function	(VCPCM-284)

✅	Client/Server:	Corrected	the	behavior	where	"User	name	not	found"	was	being	written	to	the	internal	cache	when	a	user	was
not	found	(VCPCM-182)

✅	Client/Server:	Implemented	changes	that	involve	checking	the	IsMSA	flag	when	connecting	to	the	remote	ManagementScope
and	logging	unhandled	exceptions	in	Task`s	Debugging	mode	for	improved	debugging	and	error	handling	(VCPCM-162)

✅	Client/Server:	Enhanced	the	configuration	of	Popups	by	adding	the	capability	to	save	previous	input	data	to	the	cache
(VCPCM-155)

✅	Client/Server:	Removed	duplicate	and	outdated	topics	from	the	CHM	help	documentation	(VCPCM-145)

✅	Client/Server:	Implemented	automatic	decoding	of	TNEF	(winmail.dat)	attachments	in	the	Email	functions	(VCPCM-123)

✅	Client/Server:	Added	missing	locks	when	accessing	the	collection	of	Jobs	(VCPCM-602)

✅	Client/Server:	Correct	DbConnection	disposal	after	testing	connection	settings	or	retrieving	SP	list	and	params	(VCPCM-526)

10.0.2	[2023-09-27]
NOTES

This	version	contains	new	license	changes.	Below	is	a	list	of	changes.	Please	contact	sales@visualcron.com	for	further
questions
The	following	features	require	an	active	maintenance:	Reports,	ROI,	Server	monitor,	Server	sync,	Windows	Failover	Cluster,
Job	Report	Task
The	following	features	require	a	license	of	Subscription	type:	MFT,	SLA,	Health,	Robot	Task
The	following	features	require	a	license	of	unlimited	type	(Site	or	greater):	Remote	Execute	Task

Features

mailto:sales@visualcron.com


✳	Client/Server:	New	Report->Server:	Overview	(VCP-312)

✳	Client/Server:	New	Report->Server:	SLA	(VCP-242,VCP-402,VCP-403)

✳	Client/Server:	New	Report->Server:	Computer	(VCP-295)

✳	Client/Server:	Added	SLA-stats	(uptime,	latency	and	outages)	(VCP-366,VCP-355,VCP-403)

✳	Client/Server:	Logs->New	Transfer	log	table	(VCPCM-445)

✳	Client/Server:	New	Report->Logs:	Transfer	log	(VCPCM-158,	VCPCM-443)

✳	Client:	Various	UI	updates	(VCP-354,VCP-326,VCP-389)

✳	WebClient:	Various	UI	updates	(VCP-351,VCP-352)

✳	Server:	Server	events->Logging	internal	events	in	the	EventLogs	table	(VCP-359)

✳	Client/Server:	Robot	Task->Added	Load	list	activity	(VCP-397)

✳	Client/Server:	Robot	Task->Added	ability	to	save	Excel	file	in	CSV	format	(VCP-392)

✳	Client/Server:	Web	macro	Task->Added	ability	to	use	local	URLs	(VCP-377)

✳	Client/Server:	Reports->Job	list	CSV	output,	Jobs	and	Groups	filters,	Job	and	Task	column	selection	(VCP-322,VCP-
391,VCP-405)

✳	Client/Server:	Cloud	transfer	Tasks->Proxy	settings	can	be	configured	for	Azure	Block	Blob	connection	type	(VCP-135)

Bug	Fixes

✅	Client:	SFTP	component	initialization	(VCPCM-449)

✅	Client:	Server:	Export	Settings	error	when	lacking	Permissions	(VCPCM-352)

✅	Client:	Server:	WebMacro->Not	saving	"Allow	to	ignore	the	element"	(VCPCM-356)

✅	Client:	Server:	WebMacro->Table	Extraction	Wizard	fixes	(VCPCM-444)

✅	Client:	Server:	WebMacro->TakeScreenshot	Page	mode	(VCPCM-442)

✅	Client:	Server:	Robot	Task->Mapping	mode	(VCPCM-92)

✅	Client:	Client:	Scan	documents(local)	bugfixes	(VCPCM-450,VCPCM-452)

✅	Client:	Server:	Email	move	Task	folder	bug	fixed	(VCP-328)

✅	Client:	Server:	Email	Get	messages	Task->Removing	sensitive	information	from	MailClient	event	log	messages	(VCPCM-43)

✅	Client:	Server:	Execute	script->Problem	using	multiple	arguments	in	combination	with	quotes	(VCP-314)

✅	Client:	Server:	Robot	Task->Fixed	related	actions	issue	(VCP-220)

✅	Client:	Server:	Robot	Task->Save	record	issue	(VCP-300)

✅	Client:	Server:	SFTP	CreateFolder	command	fix	(VCP-133)

✅	Client:	Server:	Enforce	HTTPS	for	amazon	SNS	(VCP-292)

✅	Client:	WebClient:	AD	authentication	fix	(VCP-344)

✅	Client:	Client/Server:	AD	authentication->	LDAP	over	SSL	(LDAPS)	support	added	for	ports	636,	3269	(VCPCM-451)

✅	Client:	Client/Server:	GroupOverride	not	working	in	connections	fix	(VCP-387)

✅	Client:	Client/Server:	Reports->Various	UI	feedback	(VCP-351,VCP-353,VCP-409)

✅	Client:	Client/Server:	Reports->Report	run	"forever"	issue	(VCP-327)

✅	Client:	Client/Server:	Job->Result	report	date	filter	issue	(VCP-231)

✅	Client:	Client:	Email	Move	Task->Fixed	issue	with	destination	folder	(VCP-398,VCP-328)



✅	Client:	Client/Server:	Reports	Task->Fixed	Credential	issue	(VCP-357)

✅	Client:	WebClient:	Fixed	issue	opening	Server	settings	(VCP-368)

✅	Client:	Client/Server:	Robot	Task->Added	missing	file	(fix	for	web	macro)	(VCP-408)

✅	Client:	Client/Server:	Robot	Task->Added	missing	icons	(VCP-407)

✅	Client:	Client/Server:	Robot	Task->Fix	for	possible	AccessViolationException	(VCP-282)

✅	Client:	Client/Server:	DB	logging->Retry	fixes	(VCP-304)

✅	Client:	Client/Server:	DB	logging->Access	of	multiple	VC	Servers	under	different	users	to	the	same	Oracle	database	(VCPCM-
80)

✅	Client:	Client/Server:	DB	logging->Added	re-impersonation	attempt	after	first	connection	failure	in	DBLogger	(VCPCM-360)

✅	Client:	Client/Server:	SFTP	SSH_MA_NONE	may	lead	to	NullReferenceException	(VCP-411)

✅	Client:	Server:	Web	macro->Show	steps	issue	(VCP-290)

✅	Client:	Client/Server:	Web	macro	Task->Fixed	video	output	issue	(VCP-416)

✅	Client:	Client/Server:	Web	macro	Task->Optimized	playback	performance	1000%	(VCP-376)

✅	Client:	Client/Server:	Web	macro	Task->Fixed	destroyed	webview	issue	(VCP-373)

✅	Client:	Client/Server:	Flow	chart->Various	fixes	(VCP-421,	VCP-422,	VCP-460,	VCPCM-338)

✅	Client:	Client/Server:	Reports->Better	form	initialization;	optimized	Server	log	report	generator	(VCP-409)

✅	Client:	Client:	Main	grid->Fixed	an	issue	with	Job	folder	rows	filtering	outside	of	GUI	thread	(VCPCM-354)

10.0.1	[2023-05-08]

Features

✳	Client/Server:	New	Report	Task	to	automate	any	of	the	existing	reports	(VCP-142)	✳	WebClient:	Added	Web	service	Task	to
web	client	(VCP-39)

✳	Client/Server:	Create/Set-cell	Excel	Task->Added	new	cell	type	Formula	(VCP-179)

✳	Client/Server:	AMQP	Connection->Certificate	authentication	mode	was	added	(VCP-149)

✳	Client/Server:	Triggers->New	PowerShell	Trigger	was	added	(VCP-53)

✳	Client/Server:	Triggers->New	.NET	code	execute	Trigger	was	added	(VCP-55)

✳	Client/Server:	Triggers->New	Variable	Trigger	was	added	(VCP-157)

✳	Client/Server:	Health->Default	Health	conditions	updated	to	include	both	VC	and	OS	CPU	(VCP-125)

✳	Client/Server:	Robot	Task->Added	Outlook	application	awareness	(VCP-116)

✳	Client/Server:	Variables->Added	folder	path	Variabels	(VCP-259)

✳	Client/Server:	SFTP->Implemented	better	auto	detect	of	encryption	algorithms	(VCP-260,VCP-270)

Bug	Fixes

✅	WebClient:	Updated	version	of	jQuery	for	security	(VCP-61)

✅	WebClient:	Fixed	issue	with	Popup	Task	(VCP-175)

✅	Server:	WebAPI->Fixed	background	checking	for	expired	user	tokens	(VCP-184)

✅	Client:	Create/Set-cell	Excel	Task->Fixed	renumbering	of	columns	when	items	are	deleted	(VCP-177)

✅	Client:	NullReferenceException	on	Server	Health	window	(VCP-229)

✅	Client/Server:	ExecuteScript	task	defaults	to	ScriptText	(VCP-238)



✅	Client/Server:	Desktop	Trigger->Fixed	various	issues	(VCP-163)

✅	Client/Server:	Robot	Task->Fixed	various	issues	(VCP-43,VCP-112,VCP-150,VCP-151)

✅	Client/Server:	Robot	Task->Added	error	handling	(VCP-113)

✅	Client/Server:	Google	Drive->Fixed	upload	issue	(VCP-48)

✅	Client/Server:	Exchange	EWS	refresh	Token	for	Email	tasks	(VCP-249)

✅	Server:	Cloud	File	Trigger	error	when	updating	statistics	(VCP-222)

✅	Server:	Box	file	download	issue	(VCP-277)

✅	Server:	List	folders	Task->Fixed	issue	exception	throwed	using	some	wildcards	(VCP-148)

✅	Server:	Jobs->Fixed	issue	with	file	getting	larged	because	of	statistics	stored	(VCP-83)

✅	Client:	Scan	document	Task->Fixed	admin	permission	requirements	issue	(VCP-275)

✅	Client:	Web	macro	Task->Fixed	admin	permission	requirements	issue	(VCP-283)

✅	Client:	Main	grid->Fixed	progress	update	issue	(VCP-285)

✅	Server:	HTTP	Rest	Trigger	status	code	evaluation	(VCP-289)

✅	Server:	Database	copy->SqlCeCommand	timeout	error	(VCP-287)

10.0.0	[2023-02-20]

Features

✳	Client/Server:	Reports->Introducing	Reports	-	advanced	inside	reports	(VC-2910)

✳	Client:	Flow	chart->Added	new	flow	chart	(VC-2645)

✳	Client/Server:	Tasks->New	TCP	Task	was	added	(VCP-44)

✳	Client/Server:	Triggers->New	TCP	Trigger	was	added	(VCP-44)

✳	Server:	Directory	created	variable	for	MFT	(VCP-82)

✳	Client/Server:	Execute	Task->Added	process	queue	functionality	(VCP-159)

✳	Client/Server:	File	Trigger->Added	consolidate	changes	option	(VCP-162)

✳	Client/Server:	Variables->Added	number	format	Variables	(VCP-170)

✳	Client/Server:	RefreshToken	stored	encrypted	(VCP-22)

Bug	Fixes

✅	Server:	Triggers->Fixed	possible	thread	issue	causing	crash	at	high	loads	(VCP-73)	✅	Server:	Web	client	not	updating/saving
credentials	(VCP-58)

✅	Server:	WebDAV	download	files	task	w/Variable	in	Path	(VCP-27)

✅	Server:	HTTP	Delete	Method	Issue	(VCP-19)

✅	Server:	SqlConnection	using	service	account	works	in	SQL	Trigger	(VCP-23)

✅	Server:	Web	client	fix	for	crash	when	creating	a	job	(VCP-72)

✅	Server:	Exchange	EWS	Certificate	issue	(VCP-52)

✅	Server:	Mail	trigger	for	EWS:	improved	token	expiry	handlers	(VCP-120,VCP-76)

✅	Server:	Mail	trigger	for	EWS:	custom	folder	setup	minor	bugfix	(VCP-77)

✅	Server:	Mail	trigger	for	EWS:	minor	bugfix	when	forwarding	enabled	(VCP-77)

✅	Server:	Mail	trigger	for	EWS:	AD	users	and	groups	permission	check	minor	improvement	(VCP-99)



✅	Server:	SSRS	issue	with	Excel	formatting	(VCP-98)

✅	Client:	AddCredentials	NRE	fix	(VCP-126)

✅	Server:	AD	group	integration/cache	issue	(VCP-99)

✅	Server:	Scan	Document	Task->Fixed	potential	crash	(VCP-26)

✅	Server:	Bug	with	HTTPs	webapi	port	(VCP-96)

✅	Server:	Slack	Trigger	bugfix	(VCP-47)

✅	Server:	Server	events->Fixed	potential	memory	leak	(VCP-155)

✅	Client:	SFTP	connection	editor	for	PublicKey	authentication	fix	(VCP-161)

✅	Server:	JSON	Decode	Task	empty	value	fix	(VCP-49)

✅	Server:	WebAPI	parameters	fix	(VCP-66)

✅	Server:	Web	macro	/	Robot	Edit	Task	exception	fix	(VCP-94)

✅	Server:	VCCommand	missing	file	fix	(VCP-136)

✅	Server:	SFTP	list	folders	fix	(VCP-32)

✅	Server:	List	folder	Task->Fixed	wild	card	issue	(VCP-148)

✅	Server:	Jobs	definitions	file	grow	issue	(VCP-83)

✅	Client:	Main	grid->Fixed	filter	re-sort	issue	after	reconnecting	(VCP-164)

✅	Client:	Execute/Kill	Task	(and	more)->Fixed	process	selection	issue	(VCP-169)

✅	Server:	File	Trigger->Fixed	potential	impersonation	context	leak	to	Job	from	Trigger	(VCP-173)

✅	Server:	Triggers->Fixed	potential	Trigger	result	loss	during	execution	(VCP-174)

✅	Client:	Script	Execute	Task->Fixed	validation	error	that	prevent	save	of	option	"Script	text"	(VCP-178)

✅	Client:	Local	documentation	updated	(VCP-36,VCP-42)
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Get	VisualCron
You	can	get	your	copy	of	VisualCron	from	several	sites	on	the	Internet.	To	be	sure	to	get	the	latest	version,	we	encourage	you	to
download	VisualCron	from	this	web	page.
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System	Requirements
VisualCron	is	designed	for	Windows	based	computers	and	runs	on	the	following	operating	systems:

Windows	2008
Windows	2012	R2
Windows	2016
Windows	2019
Windows	7
Windows	8
Windows	10

Other	requirements:

.NET	Framework,	version	4.8	or	above

Requirements	for	other	software:

PDF	reader	(e.g.	Adobe	Reader),	required	for	reading	of	some	documents
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Download,	Install,	Upgrade,	and	Uninstall
Download

VisualCron	9	utilizes	functions	and	features	in	the	.NET	Framework	4.8.	The	.NET	runtime,	typically	Version	4.8	Redistributable
Package,	can	be	downloaded	from	Microsoft.

Download	the	latest	VisualCron	version	from	VisualCron.	Download	older	versions	here.

To	create	"silent	package"	(non	exe	package)	follow	these	steps:

1.	 download	old	version	here
2.	 install	7-Zip	File	Manager
3.	 right	click	on	exe	and	choose	extract	to	folder

Backup

Always	make	a	backup	of	existing	settings	to	a	safe	location	before	upgrading.	This	way	you	can	rollback	to	any	previous	version	if
needed.	You	backup	existing	settings	by	connecting	with	Client	to	Server.	Choose	File	>	Import/Export	>	Export	settings	tab.

Install/Upgrade

The	below	steps	cover	how	to	install	VisualCron.	Please	note	that	the	installer	uninstalls	the	current	installation.	No	manual
uninstall	needed	first.

1.Double	click	on	the	VisualCron.exe	install	executable	and	the	below	window	will	appear.	This	is	the	pre-installer	that	is	preparing
installation	files	for	the	msi	package	-	for	example,	stopping	existing	applications	and	uninstalling	VisualCron.

2.	 When	the	pre-installer	is	complete	it	starts	the	msi-package
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3.	 Select	I	Agree	in	the	License	Agreement	page	and	click	Next

4.	 The	VisualCron	installation	executable	contains	installation	files	both	for	the	VisualCron	Client	and	the	Server.	You	may
choose	to	install	both	by	selecting	the	first	item	or	just	the	Client	by	selecting	the	second	item.	When	installing	just	the	client
the	service	for	the	Server	will	still	be	installed	but	"Disabled".	If	you	later	need	to	run	the	Server	on	this	computer,	you	can



change	the	service	to	"Automatic"	in	Control	Panel	>	Administrative	tools	>	Services	>	VisualCron	and	then	mark	and	"Start"
the	service.	Click	Next	to	continue.

5.	 Now	it	is	time	to	choose	the	installation	folder.	If	you	have	no	objections	of	the	suggested	choice	just	leave	it	as	it	is.	Click
Next	to	continue.



6.	 This	window	shows	that	VisualCron	is	ready	to	copy	the	files	and	perform	the	installation.	Click	Next	to	continue.

7.	 The	installation	has	been	started	and	the	progress	bar	shows	the	current	status.	Please	be	patient.	The	installation	may	take
some	minutes	depending	on	the	speed	of	your	computer.



8.	 The	below	window	will	only	appear	if	you	have	a	previous	VisualCron	installation.	VisualCron	5	will	be	installed	in	the	new
%PROGRAMFILES%\VisualCron\	folder	and	the	VisualCron	service	will	be	started	with	the	"VisualCron"	name.	Click	Start
to	proceed	with	the	listed	upgrade	steps.

9.	 The	install	is	now	finished.	If	you	have	a	previous	VisualCron	installation,	it	will	be	uninstalled	in	the	background.	Click
Close	to	continue.



10.	 When	you	have	closed	the	msi-installtion	the	pre-installer	asks	you	if	you	want	to	start	the	VisualCron	Client.	Click	Yes	to
start	it.

11.	 The	Client	is	starting.	If	you	get	a	connection	error	at	startup	then	wait	60	seconds	and	click	Yes	to	reconnect.	There	is	a	lot
of	configuration	and	loading	during	startup	which	might	affect	first	time	startup	time	for	the	Server.



Firewall

If	you	have	some	kind	of	firewall	activated,	this	application	might	require	user	interaction	during	installation	and	the	initial	start	of
VisualCron.	A	firewall	should	detect	both	that	VisualCron	is	trying	to	act	as	a	server	and	that	VisualCron	is	trying	to	access	internet.
Normally,	you	shall	respond	with	something	like	"allow	all	connections	on	all	ports"	for	VisualCron	initiated	requests.

Upgrade

If	you	already	have	VisualCron	installed,	you	will	get	an	upgrade	message	when	trying	to	install.	This	message	informs	about	the
current	version	and	what	version	you	are	about	to	install.	Click	OK	to	this	message	to	upgrade.

Uninstall/Remove

VisualCron	can	be	uninstalled	by	opening	the	Control	Panel	->	Add/Remove	programs.	Browse	down	to	"VisualCron	x.x.x",	select
and	click	on	the	Remove	button.	If	you	can't	find	the	"VisualCron	5.x.x"	entry	in	Add/Remove	programs	list,	you	may	have	to	run
the	VisualCron	installation	program	again	which	will	open	a	window	with	a	remove	option.

Installation	troubleshooting

MSI	errors

1.	 Download	the	silent	package	from	the	VisualCron	download	page.
2.	 Extract	it
3.	 Open	command	prompt
4.	 Write	something	like	to	log	the	installation	file:	msiexec	/i	"C:\MyPackage\Example.msi"	/L*V	"C:\log\example.log"
5.	 Send	the	log	file	to	support@visualcron.com

Antivirus	and	problems	with	psexec.exe

Your	antivirus	may	block	installation	of	a	file	called	psexec.exe	included	in	our	package:

mailto:support@visualcron.com


PsExec	is	a	tool	from	Microsoft	used	for	remote	execution

https://docs.microsoft.com/en-us/sysinternals/downloads/psexec.

We	use	it	for	optional	remote	VisualCron	installation	(from	the	Client).	You	can	safely	allow	this	file	for	installation.

Windows	Defender	SmartScreen

Sometimes	our	application	need	to	validate	and	gain	reputation	(when	new	version).	Then	you	might	get	a	popup	like	below	when
trying	to	install.	As	long	as	you	see	publisher	"NetCart	AB"	the	file	is	safe.
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Assembly	Resolver	-	Runtime	Download	of	Components
Some	assemblies	are	not	included	in	installation	package	because	the	increase	the	general	installation	size	a	lot.	If	these	assemblies
are	required	they	are	downloaded	on	demand	from	our	website.	Currently,	those	assemblies	are	related	to	language	files	for	the
Scan	document	Task.
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Remote,	Silent,	and	Customized	Installation
Perhaps	you	have	the	need	for	an	automated	installation	of	VisualCron	on	different	servers.	Since	the	VisualCron	installation	is
based	on	MSI	you	can	use	already	existing	Windows	tools	to	perform	the	installation	silently	and	remotely.	You	are	also	able	to
control	where	you	want	to	install	(installation	folder)	and	if	you	want	to	install	both	the	Client	and	the	Server	package	or	just	the
Client.

In	the	download	page	there	is	a	link	for	"silent"	installation.	This	means	an	installation	with	no	user	interaction	and	something	you
can	run	across	the	network	if	you	have	the	right	permissions.

Custom	installation

1.	 Download	the	"Custom	installation	package"	from	the	download	page.
2.	 Unzip	the	content	to	an	empty	folder
3.	 Open	the	command	window	(cmd.exe)
4.	 In	the	command	window,	go	to	the	folder	where	the	installation	is	unzipped

To	install	the	Client	&	Server	package,	write:

msiexec	/i	VisualCron.msi	/q	INSTALLMODE="1"

To	install	the	Client	only,	write:

msiexec	/i	VisualCron.msi	/q	INSTALLMODE="2"

To	use	other	than	the	default	installation	folder,	write:

msiexec	/i	VisualCron.msi	/q	INSTALLMODE="1"	TARGETDIR="C:\Program	Files\your	folder\"

Remote	installation

It	is	possible	to	install	VisualCron	remotely	-	on	a	domain	or	private	network.

1.	 To	do	this	you	need	to	use	a	tool	called	"PsExec"	which	is	downloadable	from	Microsoft	PsExec.	Once	downloaded,	unzip
the	content	of	the	PSTools.zip	file	into	the	"C:\WINDOWS\system	32\"	folder.

2.	 Download	the	"Custom	installation	package"	from	the	download	page.
3.	 Unzip	the	package	on	a	shared	drive	on	your	network.
4.	 Open	the	command	window	(cmd.exe)
5.	 Combine	the	row	below	with	the	command	string	above	in	the	Custom	installation	section	like	this:

psexec	\\remoteservername	-u	adminusername	-p	adminpassword	msiexec	/i

\\remoteservername\locationofyourmsi\VisualCron.msi

In	the	zip	file	of	the	silent	installation	you	have	two	bat	files:	install_clientSILENT.bat	-	installs	the	Client	only
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install_serverANDclientSILENT.bat	-	installs	both	Client	and	Server
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REM
REM	path_to_remote_install_folder\psexec	\\remote_server_name	-u	username	-p	password	path_to_remote_install_folder\install_serverANDclientSILENT.bat	path_to_local_install_folder
REM
	
REM	Set	working	folder	from	parameter	"path_to_local_install_folder"
cd	%1
	
REM	Stop	running	processes
taskkill	/F	/IM	VCtray.exe
taskkill	/F	/IM	VisualCronClient.exe
	
REM	Stop	the	VisualCron	service
net	stop	VisualCron4
	
REM	Uninstall	the	old	version
msiexec	/x	VisualCron.msi	/q
	
REM	Install	new	version
msiexec	/i	VisualCron.msi	/q	INSTALLMODE="2"	REINSTALLMODE=dmus

REM
REM	path_to_remote_install_folder\psexec	\\remote_server_name	-u	username	-p	password	path_to_remote_install_folder\install_serverANDclientSILENT.bat	path_to_local_install_folder
REM
	
REM	Set	working	folder	from	parameter	"path_to_local_install_folder"
cd	%1
	
REM	Stop	running	processes
taskkill	/F	/IM	VCtray.exe
taskkill	/F	/IM	VisualCronClient.exe
	
REM	Stop	the	VisualCron	service
net	stop	VisualCron4
	
REM	Uninstall	the	old	version
msiexec	/x	VisualCron.msi	/q
	
REM	Install	new	version
msiexec	/i	VisualCron.msi	/q	INSTALLMODE="1"	REINSTALLMODE=dmus
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Multiple	Clients	on	the	Same	Machine
Normally,	Clients	work	best	if	the	corresponding	Server	version	is	the	same	as	the	Client	version.	This	is	because	new	features
might	be	introduced	in	either	Client	or	Server.	If	version	is	not	the	same	there	might	be	misunderstandings	in	the	communication
between	Client	and	Server.	This	can	result	in	unwanted	settings	or	behavior.

VisualCron	is	built	to	support	one	version	of	Client	installed	on	a	server.	If	you	install	both	the	Client	and	the	Server	it	is	guaranteed
that	that	version	is	the	same.

If	you	want	to	install	multiple	versions	of	Client	on	one	machine	(to	be	able	to	Connect	to	multiple	versions	of	Server)	there	is	one
workaround	for	that;

1.	 find	the	corresponding	Client	version	for	download	here	and	download	it	to	the	Client	computer
2.	 extract	the	exe	file	with	tool	like	7zip	into	a	folder
3.	 copy	that	folder	to	a	location	where	you	would	like	it	to	be	installed
4.	 right	click	on	the	VisualCronClient.exe	file	and	create	a	shortcut
5.	 copy	that	shortcut	to	desktop	and	then	we	recommend	that	you	rename	it	with	the	version	number	like	"VisualCron	-	Client
(8.5.2)"	or	similar
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Upgrading	From	VisualCron	2.x	to	4.x
The	VisualCron	4	(VC4)	release	is	the	most	reworked	version	since	the	introduction	of	VisualCron.	Fundamental	changes	have	been
made	in	most	parts	of	the	application	in	order	to	increase	functionality,	quality	and	performance.	It	is	the	result	of	the	large	amount
of	requests	that	have	been	received	from	our	customers.

VC4	is	by	default	stored	in	C:\Program	Files\VisualCron	4\.	The	reason	for	a	different	folder	than	VC2,	is	the	difference	in	file
structure	and	formats.

Also,	the	installation	utility	is	changed	in	VC4	which	means	that	if	you	install	VC4,	it	will	not	uninstall	the	present	VC2	version.	An
existing	VC2	installation	will	remain	until	you	uninstall	it	via	the	Windows	Control	panel.

The	VC4	Job	file	(jobs.xml)	is	not	compatible	with	VC2	even	though	the	file	name	not	is	changed.	The	VC4	version	of	jobs.xml	is
now	stored	in	the	settings	folder	(not	in	the	installation	root	folder	as	for	VC2).

Furthermore,	Import	and	Export	between	VC4	and	VC2	does	not	work.	One	reason	is	that	the	VC4	Job	type	is	more	complex	than
VC2.

UPDATE	2008-05-20

We	have	created	a	simple	upgrade	tool	that	may	help	you	but	not	all	the	way.	Please	download	it	here	and	follow	the	instructions	on
the	screen.	http://www.visualcron.com/files/VisualCron2-4.zip
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Upgrading	From	VisualCron	3.x	to	4.x
The	below	window	will	only	appear	as	a	part	of	the	installation	if	you	have	VisualCron	3	and	upgrade	to	VisualCron	4.

This	window	informs	you	that	VisualCron	4	now	will	exist	in	the	VisualCron	4	folder	and	all	settings	will	be	copied	from	the
VisualCron	3	folder.	Click	Proceed	to	continue.
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Upgrading	From	VisualCron	4.x	to	5.x
In	version	VisualCron	version	5	we	have	optimized	a	lot	of	the	code	structure	in	earlier	version	of	VisualCron.	However,	this	it	was
not	possible	to	be	completely	compatible	with	version	4,	which	means	that	you	will	lose	some	information	when	upgrading	from
version	4	to	5.	Also,	other	changes	exist	that	may	or	not	affect	you.	Below	is	a	list	of	changes	for	version	5	and	how	they	might
affect	you	and	your	Jobs.

Install	and	location

VisualCron	5	will	now	install	by	default	in	%PROGRAMFILES%\VisualCron\.	Previously,	VisualCron	was	installed	in
%PROGRAMFILES%\VisualCron	4\.	The	installation	of	VisualCron	5	will	not	uninstall	version	4.	Both	versions	can	co-exist.

Service	name

The	service	name	for	VisualCron	5	is	VisualCron.	For	version	4,	the	service	name	is	VisualCron	4.	If	you	previously	used	a	specific
user	for	version	4	you	need	to	set	that	user	to	run	the	VisualCron	service	for	version	5.	That	information	is	not	transferred
automatically.

API

If	you	are	using	the	API	you	have	to	upgrade	to	the	latest	version	of	the	API	for	version	5	in	order	to	connect	to	version	5.	Old
version	can	still	connect	to	VisualCron	4.

Desktop	short	cut

The	desktop	shortcut	is	named	VisualCron	5.

Task	changes

SQL	Task

The	connection	string	is	no	longer	stored	in	the	Task.	We	wanted	to	make	the	actual	Connection	global	and	we	are	now	storing	the
connection	in	Connections.	This	means	that	your	old	connection	string	will	be	missing	and	that	you	have	to	create	a	Connection	and
select	it	in	the	Task.

FTP/S	Task

We	have	removed	the	direct	link	to	the	certificate	file	and	are	now	storing	Client	certificates	in	Certificates.	You	need	to	import	any
existing	certificate	in	Certificates	and	the	select	the	actual	Certificate	in	the	Task.

SFTP	Task

We	have	removed	the	direct	link	to	the	certificate	file	and	are	now	storing	Client	certificates	in	Certificates.	You	need	to	import	any
existing	certificate	in	Certificates	and	the	select	the	actual	Certificate	in	the	Task.

Notification	changes

SQL	Notification

The	connection	string	is	no	longer	stored	in	the	Notification.	We	wanted	to	make	the	actual	Connection	global	and	we	are	now
storing	the	connection	in	Connections.	This	means	that	your	old	connection	string	will	be	missing	and	that	you	have	to	create	a
Connection	and	select	it	in	the	Notification.

Installation	notes

If	VisualCron	4	is	already	installed	and	VisualCron	5	is	installed,	the	following	notes	are	applicable:

The	complete	VisualCron	4	installation	is	kept
A	start	guide	performs	VisualCron	5	installation	which	copies	the	log,	settings	and	backup	sub	folders	from	the
%PROGRAMFILES%\VisualCron	4\	folder	to	the	%PROGRAMFILES%\VisualCron\	folder.	Normally	this	is	done	in	interactive
mode	meaning	that	dialogs	are	showing	the	result,	but	it	is	also	possible	to	use	quiet	install	(Custom)	which	performs	the
same	action	without	dialogs
A	start	guide	shows	a	few	windows	with	some	basic	client/server	settings.	This	guide	may	be	issued	later	using	the	client
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main	menu	File->	Start	Guide	option
The	VisualCron	4	Tray	client	is	removed
The	VisualCron	4	service	is	shut	down	and	disabled.	If	VisualCron	4	shall	be	run,	the	VisualCron	(5)	service	has	to	be	stopped
manually	and	the	VisualCron	4	service	has	to	be	started	manually
Some	settings	cannot	be	copied	to	VisualCron	5	automatically,	see	the	above	notes.	These	have	to	be	updated	manually	using
the	VisualCron	5	client
When	VisualCron	5	is	running	with	all	settings	verified,	you	manually	uninstall	VisualCron	4	by	using	the	Control	Panel	->
Add/Remove	programs	option
When	uninstalling	VisualCron	4,	the	Tray	Client	may	be	stopped/killed.	If	that	happens	you	just	start	it	again	from	the	 Start
menu	->	Program	->	VisualCron	5	->	VisualCron	Tray	Client
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Upgrading	From	VisualCron	5.x	to	6.x
A	full	list	of	changes	between	version	5	and	6	can	be	found	here:	Change	Log

API

If	you	are	using	the	API	you	have	to	upgrade	to	the	latest	version	of	the	API	for	version	6	in	order	to	connect	to	version	6.

Desktop	short	cut

The	desktop	shortcut	is	named	VisualCron	6.

Installation	notes

Always	make	a	backup	before	upgrading	to	another	version.	You	can	do	a	backup	in	Client	File	>	Import/Export	>	Export
settings	-	export	to	another	location	than	default.

Version	6	version	requires	.NET	3.5	(previous	version	required	2.0).	.NET	redistributable	can	be	downloaded	here:
http://www.microsoft.com/download/en/details.aspx?id=21

VisualCron	installer	will	uninstall	the	current	version	and	install	the	new	version.	Old	settings	will	remain	and	if	needed	properties
will	be	upgraded.

You	may	need	to	verify	these	Task	types	because	of	changes	from	version	5.x:

PGP	Encrypt/Decrypt
Rename	Task
Archive	compress/decompress

Especially	check	source	and	destination	folder	properties.

Credentials	The	way	we	handle	Credentials	have	changed	to	provide	more	control	of	the	actual	Credential.	Please	read	more	about
Credentials
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Upgrading	From	VisualCron	6.x	to	7.x

General	changes

A	lot	of	things	concerning	Notifications,	On	error	and	exit	code	handling	has	been	changed	from	version	6	to	7.

Notifications

Notifications	has	been	upgraded	to	use	existing	Tasks.	This	affects	the	Email	Notification	for	example	which	previously	couldn’t
send	secure	emails	–	you	were	bound	to	use	the	Email	Task.	Also,	the	Popup	Notification	was	obsolete	in	many	ways.

The	way	to	use	Notifications	has	been	changed.	The	Notifications	tab	is	gone	and	you	are	now	adding	Notifications	through	the
Flow	Tab.	This	new	approach	adds	possibilities	to	notify	you	in	other	situations	than	the	previous.	Previously	you	could	just	send
“On	start”,	“On	complete”,	“On	error”.	There	was	never	a	“On	success”	or	send	a	Notification	based	on	output	or	based	on	a
specific	exit	code.	This	has	been	added	now.

If	you	use	Variables	like	{TASK(Active,StdOut)}	in	Notifications	you	need	to	change	them	to	{TASK(PrevTask,StdOut)}.	The
reason	is	that	the	new	Notifications	now	inherit	from	Tasks	which	means	that	Active	refers	to	the	current	Task	(in	this	case
Notification).	By	using	PrevTask	you	step	back	on	step	to	the	last	Task	that	was	ran	in	the	Job.

Exit	codes	and	collection

Exit	code	handling	works	differently.	Previously,	an	error	could	be	ignored	and	was	then	reset	to	0.	Now,	we	keep	the	original	exit
code	and	focus	on	another	property	–	the	result	of	the	actual	Exit	code	collection	that	is	used	for	the	Task.

Backwards	compatibility	and	import

Notifications

Notifications	should	be	automatically	moved	to	the	“Flow”	tab	with	some	exceptions:

Email	Notification	–	we	are	able	to	move	most	settings	but	as	we	are	using	Connections	instead	of	settings	from	Server	settings	to
configure	email	settings	we	have	tried	to	create	a	new	Connection	based	on	previous	settings.

Popup	Notification	–	the	new	Popup	Notification	is	simply	too	advanced	and	different.	You	need	to	look	over	settings	in	that
Notification	in	order	for	it	to	work	fully.

Conditions

If	you	are	using	Conditions	that	look	at	exit	code	in	combination	with	ignoring	certain	errors	you	might	want	to	adjust	the	Condition
as	the	actual	exit	code	is	no	longer	reset	to	0	when	a	Task	error	is	ignored.

Edit	this	page

Previous
«	Upgrading	From	VisualCron	5.x	to	6.x

Next
Upgrading	From	VisualCron	7.x	to	8.x	»

Copyright	©	2024	SMA	Technologies.

https://help.visualcron.com
http://localhost:3001/client-user-interface/server/job-flow
https://github.com/smatechnologies/visualcron-docs/blob/main/docs/get-visualcron/upgrade-6to7.md
http://localhost:3001/get-visualcron/upgrade-5to6
http://localhost:3001/get-visualcron/upgrade-7to8


Help

On	this	page

Upgrading	From	VisualCron	7.x	to	8.x
Version	7	messages	and	protocol	is	similar	to	version	8.	We	have	found	the	following	that	might	cause	undesired	effects:

FTP	Download	Task

The	feature	Create	FTP	folder	structure	has	never	worked	in	version	7	but	was	fixed	in	version.	As	this	was	enabled	by	default	in
version	7	it	might	cause	undesired	effects.
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Upgrading	From	VisualCron	8.x	to	9.x
There	some	breaking	changes	in	VisualCron	related	to	how	we	store	encrypted	values.	We	have	increased	encryption	from	3DES	to
AES256.	This	means	old	version	cannot	read	AES256	values	but	new	version	can	convert	from	old.

This	means	that	you	cannot	do	this:

Export	from	version	9.x	to	8.x
Connect	from	version	9.x	Client	to	8.x	Server
Connection	from	version	8.x	Client	to	9.x	Server.

You	can:

Import	from	version	8.x	to	9.x	(this	will	happen	automatically	on	upgrade.

From	version	9.0.0	you	need	.NET	4.8.	.NET	4.8	is	not	supported	in	XP,	Windows	Vista,	2003,	2008	(only	2008	R2).
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Language	Management
When	the	VisualCron	client	is	started	after	an	initial	installation,	it	is	possible	to	select	a	preferred	language.	However,	this	language
selection	only	affects	the	language	in	the	client	user	interface.

In	VisualCron	system	related	functions,	it	is	not	possible	to	change	language	from	English.	Examples	of	such	areas	are	states	(e.g.
Server	On/Off)	and	logging.

The	information	in	the	VisualCron	web	site	and	all	documentation/demos	etc.	are	only	available	in	English.	The	user	definable	texts
in	demo	Jobs/Tasks	available	after	an	initial	installation	are	also	in	English.
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Custom	Branding
It	is	possible	to	change	some	parts	of	the	VisualCron	including	name	and	images.	The	customization	is	done	by	placing	a	specific
xml	file	in	the	installation	folder.	This	feature	was	presented	in	version	6.1.7.

Customization	file

The	latest	customization	file	can	be	downloaded	here:	https://www.visualcron.com/files/custom.xml

Place	this	file	in	the	root	of	the	installation	folder	of	VisualCron.	Normally	c:/program	files/VisualCron

Customization

Customization	is	done	by	changing	the	xml	file	that	can	be	downloaded	and	then	place	it	in	installation	folder.

Customization	options

ClientAppName

This	is	the	long	name	displayed	in	some	places	(default	"VisualCron	-	Client")

ServerAppName

This	is	the	long	name	displayed	in	some	places	(default	"VisualCron	-	Server")

ProductName

This	is	the	short	name	of	the	product	(default	"VisualCron")

SupportEmail

This	is	the	support	email	displayed	in	some	places	(default	"support@visualcron.com")

SalesEmail

This	is	the	sales	email	displayed	in	some	places	(default	"sales@visualcron.com")

SplashRelativePath

This	is	the	relative	path	(from	VisualCron	installation	folder)	to	the	splash	image	displayed	at	startup	(default	" img\400x250.bmp")

ShowLinks

This	property	controls	if	links	to	the	VisualCron	web	site	should	be	shown	(default	"true")
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Overview
Using	VisualCron	is	simple,	just	start	the	VisualCron	client.	With	the	ordinary	Windows	graphical	interface,	all	Jobs,	Tasks	and
settings	are	managed.	Unless	otherwise	stated,	all	user	actions	refer	to	VisualCron	client	application.

Please	note	that	VisualCron	is	initially	started	with	server	status	On.	Read	here	for	more	information.

For	some	actions	like	log,	debug	and	email	notification,	you	need	to	have	knowledge	in	computer	file	handling	and	email	account
settings.
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How	Does	VisualCron	Work?
In	one	aspect,	VisualCron	works	similarly	to	the	Unix/Linux	Cron	utility.	Down	to	details	of	seconds,	VisualCron	can	run	any
executable	file	periodically,	within	a	time	interval	or	once.	However,	in	VisualCron	also	an	event	can	be	set	to	trig	a	Job.

It	is	important	to	understand	the	structure	of	all	VisualCron	objects	in	order	to	utilize	the	new	features.	The	flow	is:	Trigger	>
Condition	>	Task	>	Notification.	One	trigger	(type	time	or	event)	fires	a	Job	to	run.	A	condition	is	a	"check"	which	is	evaluated
before	a	Job	or	a	Task	is	launched.	A	Job	can	include	one	or	more	Tasks	of	different	types.	When	the	Job	and/or	its	Tasks	are
completed,	one	or	more	notifications	(of	different	types)	may	be	performed.

NOTE

In	the	above	figure,	the	lists	of	Conditions,	Tasks	and	Notifications	are	just	illustrations	and	not	complete.	The	actual	features	in
VisualCron	is	constantly	expanding.

One	way	for	VisualCron	to	trig	a	Job	is	to	keep	track	of	time	and	match	the	current	time	with	the	time	settings	in	the	list	of	Jobs	in
order	to	perform	the	defined	actions.	Also,	the	more	simple	time	interval	can	be	used	to	trig	a	Job.	The	second	way	of	initiating	a
Job	is	via	an	event	trigger.

When	you	add	or	edit	a	Job,	the	list	of	Jobs	and	and	Tasks	are	updated.	This	list	defines	how	the	Job	will	be	managed	by	the
VisualCron	server.

Each	Task	will	run	as	a	separate	process.	When	a	Task	is	run,	VisualCron	will	save	some	statistical	values	like	how	long	time	it	took
to	run	the	current	process.

It's	possible	to	set	a	Job	to	be	run	only	once.	After	this	run,	the	Job	stays	in	the	Job	list	but	will	be	ignored	when	the	Job	list	is
checked	at	later	occasions.
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VisualCron	Server
The	VisualCron	server	runs	as	a	Windows	service	in	the	background.	The	server	service	status	is	Started	when	the	server	computer
is	started.

The	VisualCron	server	application	status	can	be	On	or	Off.	If	the	server	is	On,	it	will	be	looking	for	Jobs	to	run.	If	Off,	no	Jobs	will
be	run	unless	a	user	forces	it	manually	in	a	client.	The	server	application	is	running,	even	if	no	one	is	logged	on	to	the	computer
where	the	server	is	running	or	if	no	client	application	is	connected	to	the	server.

In	the	VisualCron	client,	the	currently	selected	server	name	is	displayed	in	the	main	menu	Server	[<server	name>]	tab	and	in	the
Username/Server	entry	in	the	the	Server/Groups/Jobs/Tasks	grid	and	in	status	bar.	Server	connections	are	global,	thus	if	you	change
a	connection	definition,	this	will	affect	all	commands	associated	with	this	connection.

The	default	port	number	between	the	VisualCron	Server	and	the	Client	is	16444.	This	means,	that	if	you	are	connecting	remotely
from	the	outside	you	may	have	to	open	port	16444	in	your	firewall,	software	and/or	hardware.

Edit	this	page

Previous
«	How	Does	VisualCron	Work?

Next
Login	»

Copyright	©	2024	SMA	Technologies.

https://help.visualcron.com
https://github.com/smatechnologies/visualcron-docs/blob/main/docs/using-visualcron/visualcron-server.md
http://localhost:3001/using-visualcron/how-does-visualcron-work
http://localhost:3001/using-visualcron/login


Help

On	this	page

Login
When	the	VisualCron	client	is	started,	an	initial	login	(to	server)	window	is	opened.	You	need	to	login	because	the	server	may	be
accessed	also	from	other	computers.	If	you	haven't	defined	any	connection,	VisualCron	will	use	the	default	server	login	parameters.

For	security	reasons,	you	should	change	user	name	and	password	after	the	initial	login	in	the	main	menu	Server	>	Main	settings	>
User	permissions	dialog.

If	you	want	to	add	new	connections,	for	example	to	other	computers,	you	select	the	main	menu	File	>	Servers	>	Manage	servers
option.	See	manage	servers	for	more	information.
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Limitations
There	are	some	limitations	in	VisualCron	which	are	listed	below:

VisualCron	is	designed	for	a	set	of	System	Requirements
The	function	"run	missed	Jobs"	doesn't	take	time	exceptions	into	account.	A	missed	Job	will	run	even	if	there	was	a	time
exception	during	that	time
Calculation	of	next	run	doesn't	take	time	exceptions	into	account
In	Windows	2000	the	Credentials	are	not	fully	supported.	They	work	in	the	execute	Task	but	not	in	other	places	like	Archive,
FTP	and	Notifications.	To	come	around	this	you	can	run	the	VisualCron	service	as	a	certain	user	and	map	network	drives	for
that	account.
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Overview
VisualCron	uses	a	per	Server	licensing	model.	You	only	need	a	license	for	the	Server,	the	Client	does	not	require	a	license.

Requires	license:

Server	installation

Do	not	require	license:

Using	the	VisualCron	Client
Using	the	VisualCron	.NET	API
Using	the	VisualCron	Web	API
Using	the	VisualCron	Web	Client
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Trial	Time
Trial

You	are	able	to	use	all	VisualCron	functions	for	free	for	a	limited	period	(30	days).	Check	the	remaining	trial	days	in	the	main	menu
About	->	About	VisualCron	dialog.	After	the	trial	period	is	over,	you	can't	control	the	server	with	the	client.	However,	the	server
will	still	run	all	Jobs	in	the	background	even	though	your	trial	period	is	over.	To	be	able	to	manage	your	Jobs	again	you	must	obtain
a	license.

If	you	want	to	extend	you	trial	period	you	can	contact	support@visualcron.com	and	you	will	get	a	trial	extension	code.	Enter	the
trial	extension	code	in	Client->Server	tab->License->Activate	and	Trial	extension	tab.
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Choosing	the	Right	License

Test	the	license	guide

Our	license	guide	estimates	number	and	type	of	licenses	needed.

We	have	created	a	quiz	to	help	you	estimate	the	license	type	that	fits	best	according	to	your	needs.	It	is	an	approximation	based	on
basic	requirements.	The	final	result	might	differ	from	your	full	needs.	You	can	test	our	new	license	guide	here.

Which	license	type	/	quantity	is	right	for	me?

When	do	I	need	more	than	one	VisualCron	Server	license?

Often,	we	get	the	question	"When	do	I	need	more	than	one	VisualCron	Server	license?".	The	answer	depends	on	your	infrastructure
and	what	you	want	to	accomplish.	Below	is	a	list	of	common	reasons	for	our	customers	purchasing	more	than	one	server	license:

1.	 Server	bottlenecks

The	CPU	footprint	of	the	VisualCron	engine	is	very	small	but	the	processes	you	launch	might	consume	a	lot	of	CPU	power.

To	balance	the	load,	some	users	purchase	multiple	or	unlimited	licenses	to	spread	the	load	over	several	servers.

2.	 Local	execution

We	have	two	types	of	Execute	Tasks;	Local	and	Remote.	The	Remote	Execute	Task	is	limited	by	Windows	in	many	ways.	For
example,	you	cannot	retrieve	output	from	a	Remote	Execute	Task	or	run	it	with	the	same	privileges	as	the	Local	Task.	The	normal,
Local	Execute	Task	has	many	more	features	and	because	of	this,	users	choose	to	install	a	VisualCron	Server	on	each	Windows
machine	they	want	to	perform	local	execution	on.

You	will	face	similar	issues	with	the	PowerShell	Task	-	while	this	Task	can	perform	remote	execute	you	cannot	control	the	user	it
runs	as	and	get	100%	control	of	that	remote	execution	(with	output	etc.).	These	are	limitations	in	Windows.

For	these	reasons	users	choose	to	purchase	multiple	or	unlimited	licenses.

3.	Machine	roles	development/test

The	acronym	DTAP	is	short	for	Development,	Testing,	Acceptance	and	Production	and	the	DR	is	short	for	Disaster	Recovery.	For
various	reasons	you	have	or	may	want	to	have	an	environment	like	the	production	environment	to	test	and	configure	Jobs	before
they	go	into	production.

For	these	reasons	users	choose	to	purchase	multiple	or	unlimited	licenses.

Choosing	between	Basic	and	Pro	license

Two	different	editions	of	VisualCron	with	different	features

VisualCron	is	released	in	two	editions	with	different	features
A	full	comparison	of	features	can	be	found	here
It	is	possible	to	later	upgrade	from	Basic	to	Pro	-	however	that	may	cost	more	than	purchasing	the	Pro	version	from	the
beginning
You	can	see	if	you	have	a	Basic	or	Pro	license	on	the	My	licenses	page	and	also	upgrade	from	Basic	to	Pro	there.

Choosing	between	Site	license,	Country	license	and	World	license

Different	licensing	for	unlimited	Server	installations

Choose	a	Site	license	if	you	have	all	Servers	within	one	physical	location	i.e.	a	data	center.
Choose	a	Country	license	if	you	have	more	than	one	data	center,	one	cloud	service	with	more	than	2	regions	or	more	than	one
cloud	service.
Chose	a	World	license	if	you	operate	with	installations	in	more	than	one	country.

https://help.visualcron.com
https://www.visualcron.com/licenseguide.aspx


The	need	for	limitless	storage	space,	high	availability,	low	latency	and	scalable	infrastructures	has	increased	the	number	of	available
cloud	services	for	file	storage.	Data	backup,	synchronization	of	files,	redundancy	and	cross	platform	support	are	some	reasons	for
using	cloud	services.

FAQ

Frequently	asked	questions

Is	a	license	required	for	Development/Test/Backup/Production	machines?

A	Server	license	is	required	for	each	machine	independent	of	the	role	of	the	machine	and	independent	of	if	the	machine	state	is	on
or	off.

Is	a	license	required	for	Disaster	Recovery	machine	even	though	it	is	not	active?

A	Server	license	is	required	for	each	machine	independent	of	the	role	of	the	machine	and	independent	of	if	the	machine	state	is	on
or	off.

Can	we	upgrade	our	license	to	x	type	of	license	later?

We	do	not	offer	upgrade	from	single	server	license	to	5-server	license	pack	but	we	offer	upgrade	from	5-server	license	pack	to
greater.	Please	contact	Sales	for	a	personal	offer	based	on	your	situation.

May	I	resell	VisualCron	licenses	of	type	Site,	Cloud,	Country	and	World?

No,	but	if	you	want	to	act	as	reseller	we	can	give	you	discount	on	all	purchases.

How	does	renewal	work?

For	more	information	of	the	Subscription	/	Maintenance	&	Support	Pack	please	check	here.

How	much	are	the	different	licenses	and	renewals?

You	can	find	the	current	pricing	here.

Is	the	Client	application	free	/	not	requiring	a	license?

The	Web	Client	and	the	Windows	Client,	which	you	use	for	configuring	the	Server,	is	free.	You	can	install	as	many	Clients	as	you
want	for	free.	The	licensing/fees	are	related	to	number	of	VisualCron	Server	installations	you	have.	However,	if	you	own	the	Basic
version	you	are	limited	to	3	simultaneous	connections.
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Basic	vs	Pro	Edition
We	recommend	looking	at	this	online	topic	for	choosing	the	edition	for	you.

Basic/Pro	was	introduced	21st	of	April	2019.	Any	license	purchased	before	that	is	considered	a	Pro	license.
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License	and	Activation
License

You	need	an	activation	code	to	activate	VisualCron.	An	activation	code	is	included	in	the	license.	A	license	can	be	obtained	at	the
VisualCron	web	site.	The	license	is	per	server.	When	you	activate	VisualCron,	you	activate	the	current	server	you	are	connected	to.
You	can	use	several	clients	to	connect	to	one	server	with	one	license.

Activation

Once	you	have	an	activation	code	you	can	activate	VisualCron.	To	activate	VisualCron	you	must	login	to	the	server	that	you	want	to
activate.	If	you	have	trial	time	left	you	can	go	to	main	menu	Client->Server	tab->License->Activate,	which	opens	the	activation
form.	If	you	don't	have	any	trial	time	left,	the	activation	form	will	open	automatically	when	logging	in.	Enter	the	activation	code	in
the	fields.

Online	activation

To	be	able	to	validate	your	activation	code	you	have	to	connect	to	the	VisualCron	web	site,	this	is	done	automatically	when	you
click	on	the	Activate	button.	However,	you	need	to:

1.	 Be	connected	to	the	Internet
2.	 Let	VisualCron	access	Internet.	If	your	firewall	asks	you	what	to	do,	you	must	permit	VisualCron	to	access	Internet

Offline	activation

This	feature	is	available	if	you	have	a	server	without	Internet	access.	Note	that	you	still	can	use	online	activation	if	your	desktop
computer	has	access	to	Internet	and	if	your	desktop	computer	can	be	internally	connected	(within	your	network)	to	the	server.	If	that
is	not	possible	you	can	use	offlien	activation.	Offline	activation	can	be	done	with	the	following	steps:

1.	 Start	the	Client	locally	on	your	server
2.	 Choose	Activate	in	the	About	menu
3.	 Choose	Offline	activation	tab
4.	 Enter	your	activation	code
5.	 After	entering	you	will	get	an	URL.	Copy	that	url	in	some	way	to	USB	stick	or	paper.	Enter	the	URL	in	a	browser	on	a
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computer	that	has	Internet	access.	You	will	then	get	an	offline	ID.
6.	 Enter	the	Offline	ID	in	the	Client

Deactivation	/	Move	a	licenses

Go	to	Server	tab->License->Deactivate	to	Move	a	license.	Please	note	that	Deactivation	/	Move	a	license	requires	that	you	have	an
active	Maintenance.
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Overview
See	general	information	about	Maintenance	and	priority	support	at:	https://www.visualcron.com/maintenance.aspx.

VisualCron	licenses	are	perpetual,	but	in	order	to	get	the	latest	version	and	receive	support	you	need	an	active	Maintenance.	Each
license	has	a	Maintenance	expiration	date.	Usually,	this	is	one	year	after	purchase	and	can	be	renewed	here.	The	Maintenance
expiration	date	is	covering	any	version	released	within	that	time	period,	minor	or	major	version.

This	is	what	you	get	with	an	active	Maintenance:

Support
Upgrades	(minor	or	major)
Ability	to	deactivate	/	move	a	license

Online/Offline	validation

From	time	to	time	we	validate	the	license.	Both	that	the	actual	activation	code	is	valid	and	the	Maintenance	is	covering	the	current
version.	If	our	servers	cannot	be	reached	you	need	to	do	a	manual	validation	from	time	to	time.We	strongly	recommend	that	you
open	firewall	to	host	visualcron.com	on	port	443	so	this	can	be	validated	and	updated	without	you	having	to	do	a	manual	validation.

If	you	fail	to	validate	VisualCron	will	either	stop	working	or	you	will	not	be	able	to	connect	to	the	Server	with	the	Client.

Troubleshooting

Maintenance	expiration	date	is	not	refreshing

Normally,	VisualCron	refreshes	the	Maintenance	expiration	date	that	you	see	on	the	Server	row	in	the	main	grid	of	the	Client.	You
can	also	force	this	refresh	by	right	clicking	on	Server	row	and	select	Refresh	license	data.	Make	sure	that	VisualCron	can	connect	to
Internet	against	hostname	visualcron.com	on	port	443.	If	you	still	have	problems	with	refreshing	the	maintenance	expiration	date
please	follow	these	steps:

1.	 Close	the	VisualCron	Client
2.	 Right	click	on	the	VisualCron	Tray	Client	and	choose	Client->Open	log	folder
3.	 Move	up	one	folder	to	the	VisualCron	folder.	Enter	the	settings	folder.
4.	 Exit	the	VisualCron	Tray	Client	application
5.	 Delete	the	file	servers.xml
6.	 Start	the	VisualCron	Tray	Client
7.	 Start	the	VisualCron	Client.
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Maintenance	Expiration
In	the	Client	you	can	see	the	expiration	date	for	the	Maintenance	in	the	Server	row.	This	date	is	refreshed	from	time	to	time	and
may	not	be	directly	synced	in	Client	when	you	purchase	a	renewal	of	the	Maintenance.	To	force	a	sync	you	can	right	click	on	the
Server	row	and	choose	Refresh	license	data.	If	the	date	is	not	refreshed	please	make	sure	you	have	associated	the	Maintenance	code
online	that	you	purchased	with	the	license	you	wanted	to	renew.	After	doing	that	you	can	choose	to	Refresh	license	data	again.
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License	Validation
From	time	to	time	we	need	to	validate	your	licenses	and	keep	you	and	VisualCron	updated	about	Maintenance	expiration.	Please
follow	the	steps	below	to	validate	on	a	computer	that	has	Internet	access.	To	avoid	having	to	do	this,	please	enable	access	to
www.visualcron.com	on	port	443.

The	below	screen	is	shown	when	the	computer	where	the	VisualCron	Client	runs	has	been	offline	for	a	while.	The	screen	is	also
shown	when	the	Server	>	Information	>	License	>	Refresh	license	data	is	issued	when	the	VisualCron	Client	is	offline.
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Move	a	License
1.	 Download	and	install	VisualCron	on	your	new	server	(if	this	is	the	first	time	you	install	VisualCron	you	will	have	30	days	of

trial	with	full	functionality)
2.	 Validate	on	the	My	licenses	page	that	you	have	a	Maintenance	contract	that	supports	the	installed	new	version	for	the	latest

version	so	you	do	not	run	into	license	problems	when	trying	to	activate	it	later
3.	 Go	to	the	old	server	and	backup	your	settings	using	Export	from	the	menu	File	>	Export	settings
4.	 Transfer	the	file	to	the	new	server	and	import	it	clearing	existing	settings	(unless	you	already	created	new	Jobs	on	Server)
5.	 If	the	import	was	successful	you	can	choose	Server	>	Information	>	License	>	Deactivate	in	the	old	Server
6.	 Go	to	the	new	Server	and	Activate	it	with	the	old	activation	code

If	you	have	any	Deactivation/Activation	problems	contact	us	here.

If	the	Server	is	decommissioned	and	no	longer	available	please	go	to	My	licenses	page	and	click	on	the	Move	button	next	to	the
activation	code.

Deactivation	/	Move	a	license	requires	that	you	have	an	active	Maintenance.
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Overview

Failover	Clustering

It	is	possible	to	use	VisualCron	in	a	failover	clustered	environment.	We	recommend	using	the	built	in	Windows	Server	Feature
Failover	Clustering	for	this.

A	failover	cluster	is	a	group	of	independent	computers	that	work	together	to	increase	the	availability	and	scalability	of	clustered
roles	(formerly	called	clustered	applications	and	services).	The	clustered	servers	(called	nodes)	are	connected	by	physical	cables	and
by	software.	If	one	or	more	of	the	cluster	nodes	fail,	other	nodes	begin	to	provide	service	(a	process	known	as	failover).	In	addition,
the	clustered	roles	are	proactively	monitored	to	verify	that	they	are	working	properly.	If	they	are	not	working,	they	are	restarted	or
moved	to	another	node.

Failover	clusters	also	provide	Cluster	Shared	Volume	(CSV)	functionality	that	provides	a	consistent,	distributed	namespace	that
clustered	roles	can	use	to	access	shared	storage	from	all	nodes.	With	the	Failover	Clustering	feature,	users	experience	a	minimum	of
disruptions	in	service.

Failover	Clustering	has	many	practical	applications,	including:

Highly	available	or	continuously	available	file	share	storage	for	applications	such	as	Microsoft	SQL	Server	and	Hyper-V	virtual
machines	Highly	available	clustered	roles	that	run	on	physical	servers	or	on	virtual	machines	that	are	installed	on	servers	running
Hyper-V

You	can	read	more	about	Windows	Failover	Cluster	here.

Licensing

A	unique	license	(or	unlimited	license)	needs	to	be	activated	on	each	node	in	the	cluster.

However,	VisualCron	must	be	manually	activated	for	each	cluster.

Installation	and	preparation

There	are	two	major	steps:

1.	 Installing	the	Windows	Failover	Cluster
2.	 Install	and	Setup	VisualCron	on	Failover	Cluster
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Overview
Below	is	a	guide	for	installing	the	feature	Failover	Cluster	on	Windows	2016.

Installing	the	Failover	Cluster	Feature	in	Windows	Server	2016

Requirements

To	use	Failover	Cluster	Feature	we	need:

1.	 Server	that	will	be	a	“Failover	cluster	access	point”	(FCAP)	with	Active	Directory
2.	 At	least	2	servers	that	will	be	an	“Cluster	nodes”

Steps

1.	 Configure	roles	/	features	on	Failover	Cluster	access	point	-	FCAP
2.	 Configure	roles	/	features	on	Nodes
3.	 Create	a	iSCI	network	drive
4.	 Connecting	to	iSCSI	network	drives
5.	 Create	the	failover	cluster
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Configure	Roles	/	Features	on	Failover	Cluster	Access	Point	(FCAP)
In	the	Server	Manager	>	Dashboard,	click	Add	roles	and	features.

The	Before	you	begin	window	is	displayed.	Click	Next.
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The	select	Installation	Type	window	is	displayed.	Select	Role-based	or	feature-based	installation.	Click	Next.

The	Select	destination	server	window	is	displayed.	Select	the	server	that	you	are	logged	in	on.	Click	Next.

The	Select	server	roles	window	is	displayed.	In	the	Roles	list,	select	File	Server,	iSCI	Target	Server,	iSCI	Target	Storage	Provider.



Click	Next.

The	Select	features	window	is	displayed.	In	the	Features	list,	select	Failover	Clustering,	Failover	Clustering	Tools.	If	it	wasn’t
installed	before,	the	Add	features	that	are	required	for	Failover	Clustering	window	will	pop	up.	This	window	shows	the
dependencies	that	will	be	installed	with	this	feature.

Click	Add	Features.	Click	Next.	The	Confirm	installation	selections	window	is	displayed.	Check	the	setting	to	ensure	all	selected
items	to	be	installed.

Click	Install.	The	chosen	Role	and	Feature	will	be	installed	on	your	machine.

When	the	installation	is	complete,	restart	the	machine	to	finalize	the	installation.
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Configure	Roles	/	Features	on	Nodes
Add	All	Nodes	to	AD.	Change	DNS	server	addresses	to	your	Active	Directory	Server	ip	address.

Add	Node	to	Domain	by	changing	“Member	of”	in	Computer	name	tab	of	System	Properties	window.

In	the	Server	Manager	>	Dashboard,	click	Add	roles	and	features.

The	Before	you	begin	window	is	displayed.	Click	Next.

The	Select	installation	type	window	is	displayed.	Select	Role-based	or	feature-based	installation.	Click	Next.

The	Select	destination	server	window	is	displayed.	Select	the	server	that	you	are	logged	in	on.	Click	Next.

The	Select	server	roles	window	is	displayed.	Click	Next.

The	Select	features	window	is	displayed.	In	the	Features	list,	select	Failover	Clustering,	Failover	Clustering	Tools.	If	it	wasn’t
installed	before,	the	Add	features	that	are	required	for	Failover	Clustering	window	will	pop	up.	This	window	shows	the
dependencies	that	will	be	installed	with	this	feature.

Click	Add	Features.	Click	Next.	The	Confirm	installation	selections	window	is	displayed.	Check	the	setting	to	ensure	all	selected
items	to	be	installed.

Click	Install.

The	chosen	Role	and	Feature	will	be	installed	on	your	machine.

When	the	installation	is	complete,	restart	the	machine	to	finalize	the	installation.
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Create	a	iSCSI	Network	Drive
In	the	Server	Manager	>	File	and	Storage	Services	>	iSCSI,	click	“to	create	an	iSCSI	virtual	disk”.

The	New	iSCSI	Virtual	Disk	Wizard	window	is	displayed.	Select	Disk	that	you	want	yo	use	as	location	for	iSCSI	Virtual	Disk.

Click	Next.	The	Specify	iSCI	virtual	disk	name	will	be	displayed.

Choose	disk	name,	add	description	if	it’s	needed	and	click	Next.	The	Specify	iSCSI	virtual	disk	size	window	will	be	displayed.

Type	size	of	a	disk.	Click	Next.	The	Assign	iSCSI	target	window	is	displayed.

Choose	New	iSCSI	target	,	click	Next.	The	Specify	target	name	window	is	displayed.

Choose	new	target	name,	description	if	needed	and	click	Next.	The	specify	Access	servers	window	is	displayed.

Click	Add	to	specify	the	iSCSI	initiators	of	added	to	AD	nodes.	The	Add	initiator	ID	pop	up	will	be	displayed.

At	this	popup	you	can	select	new	Computer	IDs	by	selection	Query	initiator	computer	for	ID	and	clicking	Browse	button.	The
Select	Computer	popup	will	be	shown.

In	this	popup	you	can	type	Computer	names,	or	click	to	advanced	button,	and	find	them	at	AD	network.

Add	One-by-One	all	nodes	to	accessed	servers.

Another	way	is	to	select	already	known	initiators	from	the	initiator	cache	on	the	target	server.

Add	One-by-One	all	nodes	to	accessed	servers.

After	All	nodes	added,	click	Next.

The	Enable	Authentication	window	is	displayed.	Setup	CHAP	protocol	settings	if	it’s	needed	and	click	Next.

The	Confirm	selections	windows	is	displayed.	You	can	check	all	iSCSI	settings	that	you	selected	before.	After	that	click	Create.

The	Results	windows	will	be	displayed.	After	Creation	will	be	succeed	click	Close.

Now	you	can	see	new	iSCSI	virtual	drive	and	targets.
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Connecting	to	iSCSI	Network	Drives
Start	the	iSCSI	initiator	then	connect	to	your	SAN	drives:

Click	Start	>	Windows	Administrative	Tools	>	iSCSI	Initiator.
Ensure	the	drives	are	set	to	allow	simultaneous	connections.	This	is	configured	on	your	SAN.	Make	sure	you	have	granted
access	to	your	cluster	servers.
Open	iSCSI	initiator.
Click	the	Targets	tab.
In	Target,	enter	the	IP	address	for	the	SAN.
Click	Quick	Connect.	Or	you	can	click	to	Refresh	to	auto	discover	targets.
Your	advertised	drives	are	displayed.
Highlight	a	drive;	then	click	connect	to	connect	to	drive.

When	a	drive	is	connected,	click	Done.	Click	the	Volumes	and	Devices	tab.

Click	Auto	Configure.
Click	OK.
When	you	are	connected	on	the	first	machine,	click	Start	>	WIndows	Administrative	tools	>	Computer	Management	>
Disk	Management.

Your	disks	appear	as	Unknown	and	Offline.	They	also	display	the	size	you	configured	on	the	SAN	(eg:	16GB).	You	need	to	bring
the	disks	online	by	Right-clicking	the	disk	number	and	selecting	Online.

Initialize	the	disks:

Right-click	the	disk	number	next	to	one	of	the	new	drives.	Select	Initialize	disk.
In	the	box	that	appears,	ensure	that	your	new	disk	have	a	tick	mark	next	to	them.

Set	as	MBR.

Click	OK.
Configure	the	new	drive.	Right-click	on	the	drive.

Select	Create	New	Simple	Volume.	Leave	the	defaults	in	place.	Choose	a	drive	letter	to	assign.	Label	your	drive	f.ex.	as
ClusterStorage

Once	this	is	done	for	your	first	node	(Server),	repeat	these	steps	on	your	additional	nodes	(Servers).	For	example,	from	the	two
listed	servers	above	(Server1	and	Server2),	you	must	connect	the	iSCSI	drives	on	both	systems	before	they	will	be	available	for
your	cluster.

As	the	simple	volume	is	now	configured,	you	only	need	to	initialize	the	disks	on	the	other	Nodes,	not	recreate	the	Volume.
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Create	the	Failover	Cluster
Create	the	failover	cluster

Click	Start	>	Windows	Administrative	tools	>	Failover	Cluster	Manager 	to	launch	the	Failover	Cluster	Manager.

Click	Create	Cluster.	The	Before	you	Begin	window	is	displayed.

Click	Next.	The	Select	Servers	window	is	displayed.

Enter	the	server	names	that	you	want	to	add	to	the	cluster.	Alternatively,	you	can	locate	them	via	Browse.

Click	OK.	The	Servers	will	be	verified.

Click	Next.
The	Validation	Warning	window	is	displayed.
Select	Yes	to	allow	verification	of	the	cluster	services.
Click	Next.
The	Validate	a	Configuration	Wizard	is	displayed.	This	wizard	validates	the	server	configuration.

Click	Next.	The	Testing	Options	window	is	displayed.

Select	Run	all	tests	(recommended).
Click	Next.
The	Confirmation	window	is	displayed.	This	window	lists	all	of	the	tests	that	will	be	run.
Click	Next.
The	Validating	window	is	displayed	while	all	of	the	clustering	tests	are	being	run.	This	process	may	take	several	minutes
depending	on	your	network	infrastructure	and	the	number	of	nodes	you	have	chosen	to	add	to	your	cluster.

When	the	tests	have	completed,	check	the	report	then	fix	any	configuration	errors.	The	cluster	setup	will	fail	if	any	errors	exist.

The	Access	Point	for	Administering	the	Cluster 	window	in	the	Create	Cluster	wizard	is	displayed.

In	Cluster	Name,	enter	a	name	for	your	cluster.
If	one	or	more	DHCP	IPv4	addresses	wasn’t	configured	automatically	you	can	provide	an	IP	address	for	the	cluster.	This
name	and	IP	address	will	be	registered	in	your	DNS
Click	Next.
The	Confirmation	window	is	displayed.	This	window	lists	the	settings	to	be	applied	to	your	new	cluster.
Select	the	Add	all	eligible	storage	to	the	cluster	check	box.
The	system	will	now	try	to	assign	any	storage	it	can	find.
Click	Next.
The	system	attempts	to	create	the	new	cluster	in	your	domain.	This	may	take	a	while	as	there	are	several	checks	that	must
take	place	and	tests	that	are	conducted	while	the	system	is	configured.

When	the	process	is	complete,	the	Summary	window	is	displayed	stating	that	the	cluster	wizard	completed	successfully.

Click	Finish.
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Overview

Requirements

1.2	Pre-install	nodes

2.2	Unique	VisualCron	licenses	(or	1	unlimited	license)

Steps

1.	 Create	iSCSI	drive	with	the	already	existing	target
2.	 Add	new	drive	as	shared	drive	to	cluster	nodes
3.	 Install	VisualCron	on	both	nodes	in	the	same	share	directory
4.	 Add	Shared	Drive	to	Cluster
5.	 Add	Generic	Service
6.	 Manually	changing	current	node	for	Generic	Service
7.	 Setup	Failover	Generic	Service	properties
8.	 Individual	node	activation

Edit	this	page

Previous
«	Create	the	Failover	Cluster

Next
Create	iSCSI	Drive	with	the	Already	Existing	Target	»

Copyright	©	2024	SMA	Technologies.

https://help.visualcron.com
http://localhost:3001/using-visualcron/create-iscsi-drive-with-existing-target
http://localhost:3001/using-visualcron/add-new-shared-drive-to-cluster
http://localhost:3001/using-visualcron/install-visualcron-on-both-nodes
http://localhost:3001/using-visualcron/add-shared-drive-to-cluster
http://localhost:3001/using-visualcron/add-generic-service
http://localhost:3001/using-visualcron/manually-changing-current-node
http://localhost:3001/using-visualcron/setup-failover-generic-service-properties
http://localhost:3001/using-visualcron/individual-node-activation
https://github.com/smatechnologies/visualcron-docs/blob/main/docs/using-visualcron/install-and-setup-visualcron-on-failover-cluster.md
http://localhost:3001/using-visualcron/create-the-failover-cluster
http://localhost:3001/using-visualcron/create-iscsi-drive-with-existing-target


Help

On	this	page

Create	iSCSI	Drive	with	the	Already	Existing	Target
In	the	Server	Manager	>	File	and	Storage	Services	>	iSCSI,	make	a	right	click	and	inside	context	menu	press	to	the	“New	iSCSI
Virtual	Disk”.

The	New	iSCSI	Virtual	Disk	Wizard	window	is	displayed.

Selec	Disk	that	you	want	yo	use	as	location	for	iSCSI	Virtual	Disk	Click	Next.

The	Specify	iSCI	virtual	disk	name	will	be	displayed.

Choose	disk	name,	add	description	if	it’s	needed	and	click	Next.

The	Specify	iSCSI	virtual	disk	size	window	will	be	displayed.

Type	size	of	a	disk.	Click	Next.

The	Assign	iSCSI	target	window	is	displayed.

You	need	to	select	already	existed	target	that	use	access	rights	for	your	nodes.

Choose	Already	existed	iSCSI	target,	click	Next.

The	Confirm	selections	windows	is	displayed.

You	can	check	all	iSCSI	settings	that	you	selected	before.	After	that	click	Create.

The	Results	windows	will	be	displayed.	After	Creation	will	be	succeed	click	Close.

Now	you	can	see	new	iSCSI	virtual	drive.
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Add	New	Drive	as	Shared	Drive	to	Cluster	Nodes
At	now	on	both	nodes	new	iSCSI	shared	drive	is	unallocated	and	offline

On	both	nodes	you	need	to	go	to	iSCSI	Initiator	Properties,	to	the	Volumes	and	Drives	tab.

And	click	to	Auto	Configure	button.	Current	node	will	update	information	about	shared	drive.

After	that	you	need	to	close	this	window	by	pressing	OK	button.

When	you	are	connected	on	the	first	machine,	click	Start	>	WIndows	Administrative	tools	>	Computer	Management	>	Disk
Management.

Your	disks	appear	as	Unknown	and	Offline.	They	also	display	the	size	you	configured	on	the	SAN	(eg:	10GB).	You	need	to	bring
the	disks	online	by	Right-clicking	the	disk	number	and	selecting	Online.

Initialize	the	disks:

Right-click	the	disk	number	next	to	one	of	the	new	drives.	Select	Initialize	disk.

In	the	box	that	appears,	ensure	that	your	new	disk	have	a	tick	mark	next	to	them.

Set	as	MBR.

Click	OK.	Configure	the	new	drive.	Right-click	on	the	drive.

Select	Create	New	Simple	Volume.	Leave	the	defaults	in	place.	Choose	a	drive	letter	to	assign.

Label	your	drive	f.ex.	as	VisualCronStorage

Click	Next.

Once	this	is	done	for	your	first	node,	repeat	these	steps	on	your	additional	nodes.	you	must	connect	the	iSCSI	drives	on	both
systems	before	they	will	be	available	for	your	cluster.

As	the	simple	volume	is	now	configured,	you	only	need	to	initialise	the	disks	on	the	other	Nodes,	not	recreate	the	Volume.	Shared
drive	should	have	the	same	disk	letters	on	both	nodes.
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Install	VisualCron	on	Both	Nodes	in	the	Same	Shared	Directory
Run	the	VisualCron	installation	file.

And	install	it	on	Shared	Drive.

After	it	successfully	installed	you	need	allow	firewall.

Click	to	Firewall	denies	and	apply	settings.	Close	VisualCron	client.	Stop	VisualCron	service	from	task	manager.

And	Install	it	to	the	same	folder	at	next	node.

Before	shared	drive	connected	to	cluster	it	will	be	visible	at	all	nodes.
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Add	Shared	Drive	to	Cluster
Click	Start	>	Windows	Administrative	tools	>	Failover	Cluster	Manager 	to	launch	the	Failover	Cluster	Manager.

Click	to	Storage	->	Disks.

Click	to	Add	Disk.

The	Add	Disks	to	a	Cluster	window	will	be	displayed.

Select	cluster	disk	and	click	Ok	button.	Shared	disk	will	be	added	to	our	cluster.

One	of	the	drives	(Cluster	Drive	1)	is	configured	for	your	Quorum	and	the	other	is	configured	for	the	virtual	machines	(Cluster
Drive	2).	Cluster	Drive	2	will	shown	to	us	like	Available	Storage	and	this	disk	can	be	used	with	Cluster	Roles.
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Add	Generic	Service
Generic	Service	resource	type	allows	us	to	handle	failover	based	on	a	Windows	Service	status	-	in	this	case	we	track	the	VisualCron
service.

At	Failover	Cluster	Manager	go	to	Roles.	You	will	see	current	roles	list.

Click	to	Configure	Role	to	create	a	new	role.

The	Before	you	begin	window	is	displayed.	Click	Next.

The	Select	Role	window	is	displayed.	Select	Generic	Service	item	at	the	role	list	and	click	Next.

The	Select	Service	window	is	displayed/	Select	VisualCron	service	in	current	list	and	click	Next.

The	Client	Access	Point	window	is	displayed.	Choose	NetBIOS	name	for	cluster	role.	This	name	can	be	used	to	connect	to
VisualCron	server.	Click	Next.

The	Select	Storage	window	will	be	displayed.	Select	shared	drive	with	installed	VisualCron	on	it.	This	storage	will	be	used	on	active
node	to	run	VisualCron	service.	Click	Next.

The	Replicate	Registry	Settings	window	is	displayed.	Here	you	can	add	additional	registry	settings	if	it’s	needed.	When	it’s	done,
click	Next.

The	Confirmation	window	will	be	displayed.	Check	all	settings	and	click	Next.

After	creation	of	Generic	Role	was	successfully	completed	close	window	by	clicking	Finish.
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Manually	Changing	Current	Node	for	Generic	Service
At	Failover	Cluster	Manager	go	to	Roles.	You	will	see	current	roles	list.

To	move	Generic	Service	to	another	node	you	can	right	click	at	selected	role	to	open	context	menu,	and	go	to	Move	->	Select	Node.

Or	select	role	and	click	to	Move	->Select	Node.

The	Move	Cluster	Role	popup	will	be	shown.

Choose	node	for	generic	service	and	click	Ok.

Service	will	be	switched	to	selected	node.
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Setup	Failover	Generic	Service	Properties
At	Failover	Cluster	Manager	go	to	Roles.	You	will	see	current	roles	list.

Select	role	and	click	on	Properties	(or	use	context	menu	by	right	click	on	selected	role).

The	Generic	Service	Properties	popup	will	be	displayed.Click	on	Failover	tab,	to	change	Failover	settings.

At	this	tab	you	can	change	Cluster	service	Failover	settings.
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Individual	Node	Activation
After	nodes	are	created	you	can	activate	your	nodes.	You	need	either	a	unique	activation	or	an	unlimited	one	(like	Site	license)	for
each	node.

1.	 Go	to	active	node	and	use	activation	code	and	use	activation	code	there	(unique	or	unlimited)

2.	 Switch	to	second	node	and	check	activation	status.	If	it	is	already	activated	the	deactivate	this	node	and	activate	with	the
second	activation	code	(if	you	are	not	using	an	unlimited	one).
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VisualCron	Client
The	VisualCron	Client	is	a	separate	application	that	constitutes	the	main	type	of	user	interface	for	VisualCron.	With	the	client	you
configure	VisualCron	and	manage	the	Jobs	and	Tasks	that	are	run	by	the	server.

Several	VisualCron	clients	can	be	connected	to	the	same	VisualCron	server,	typically	a	user	have	both	the	VisualCron	client
application	and	the	VisualCron	tray	client	connected	to	the	same	server.	See	main	menu	Server	>	Main	settings	>	Client
connections	for	a	list	of	clients	that	are	connected	to	the	currently	selected	server.

The	VisualCron	client	application	can	also	switch	its	server	connection	in	the	server	selection	drop-down	list	in	the	leftmost	part	of
the	toolbar.
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Starting	VisualCron	Client
The	client	application	is	started	from	the	Windows	desktop	icon	(VisualCron	X)	or	the	Start	menu	 Program	>	VisualCron	X	>
VisualCron	Client.	You	can	also	double	click	on	or	open	the	VisualCron	Tray	Client	to	start	the	VisualCron	Client.

As	the	VisualCron	server	handles	the	defined	Jobs,	the	VisualCron	client	can	only	connect	to	the	VisualCron	server	when	the	server
is	running.

As	the	VisualCron	server	runs	as	a	service,	the	client	application	can	be	closed	without	affecting	the	core	server	activities.
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VisualCron	Tray	Client
The	VisualCron	Tray	Client	is	an	application	that	is	part	of	the	VisualCron	system.	It	is	shown	with	a	VisualCron	icon	in	the
notification	area	normally	located	in	the	bottom	right	of	the	Windows	screen.

The	Tray	Client	is	located	to	the	right	in	the	below	image.	Right	click	to	interact.

Tray	Client	Startup

The	VisualCron	Tray	Client	starts	when	a	user	logs	in	to	the	Windows	server.	When	the	Tray	Client	starts,	it	attempts	to	connect	to
the	VisualCron	Server	in	order	to	provide	control,	allow	foreground	execution	and	be	able	to	notify	the	currently	logged	in	user.
When	the	Tray	Client	is	connected	it	shows	the	normal	VisualCron	icon	in	the	System	Tray.

If	the	Tray	Client	icon	includes	a	red	cross,	it	is	not	connected	to	a	server	service.	One	of	the	reasons	may	be	a	stopped	service.	The
change	of	the	icon	between	having	and	not	having	a	cross,	is	based	on	repeated	"ping"	from	the	client	and	thus	it	is	somewhat
delayed	related	to	the	actual	state	of	the	connection.

Tray	Client	Features

When	the	VisualCron	Tray	Client	is	connected	to	the	VisualCron	Server	your	are	able	to	control	the	Client	and	the	Server.

By	double	clicking	on	the	Tray	Client	icon	you	start	the	VisualCron	Client.	The	Client	can	also	be	started	by	right-click	on	the	Tray
Client	icon	and	select	Client	>	Start.

By	right-click	on	the	Tray	Client	icon	you	can	choose	Server	>	Stop/Start.	You	can	also	Stop	and	Start	the	Server	service.

Foreground	execution

One	of	the	main	purposes	of	the	VisualCron	Tray	Client	is	to	provide	 foreground	execution.

VisualCron	Tray	Client	>	Right-click	>	Settings	>	Main	tab

Start	Tray	Client	on	startup

Controls	if	the	tray	client	should	be	loaded	when	each	user	logs	on	to	the	server	machine.

VisualCron	Tray	Client	>	Right-click	>	Settings	>	Notifications	tab
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VisualCron	Web	Client
The	VisualCron	Web	Client	was	introduced	in	version	7.6.5.	It	lets	you	connect	from	any	device	(phone/browser)	to	the	VisualCron
Server.	The	web	client	has	a	real	time	interface	for	viewing	Job	and	Task	information.	It	is	still	very	limited	compared	to	the	normal
Client	but	good	for	getting	an	overview	and	do	basic	things	like	running,	activating	and	stopping	Jobs	and	Tasks.

Trouble	connecting?

If	the	Web	client	gets	stuck	connecting	you	can	open	the	Client->Events->Logs	and	send	a	screenshot	to	Support
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Installation	of	Web	Client
Requirements

IIS	7	or	later.

Installation

The	web	client	runs	inside	Microsoft	IIS	-	a	web	server.	It	is	possible	to	install	the	web	client	in	an	existing	IIS	or	install	in	the	free
IIS	Express	version.	Installation	and	configuration	of	ports	are	done	in	Server	settings->Web	client.

Server	>	Settings	>	Web	Client	tab

The	two	group	boxes	display	installation	status	of	either	IIS	or	IIS	Express.	You	can	see:

Which	version	of	IIS	is	installed
If	the	Web	client	is	installed
The	local	link	to	the	web	client
The	local	path	where	the	web	Client	is	installed
Which	port	is	used

Install

Click	on	Install	to	install	the	web	Client.	We	recommend	that	you	use	the	normal	IIS	if	it	is	already	installed.	If	you	click	Install	on
IIS	Express	then	IIS	Express	will	be	installed	first	(if	not	installed	already).

If	you	need	to	change	port	you	can	do	that	in	IIS	or	by	uninstalling	and	installing	again	with	a	new	port.

Windows	authentication

https://help.visualcron.com


If	you	are	using	Active	Directory	as	authentication	method	in	VisualCron	>	Permissions	then	you	probably	want	to	enable	Windows
Authentication	in	the	Web	Client.	Click	the	Enable	button	to	enable.

Troubleshooting	Web	Client	and	installation

Preparations

Make	sure	that	you	have	installed	the	selected	roles	and	features	in	the	Windows	server.

Windows	2016	Server	>	Server	Manager	>	Dashboard	>	Add	roles	and	features

Installation	errors	when	clicking	install	from	the	Client

Make	sure	that	you	have	started	the	application	as	Administrator	by	right	clicking	on	VisualCronClient.exe	and	select	"Run	as
Administrator".	Alternatively,	turn	off	UAC	and	reboot.

HTTP	Error	403.14	error	-	Forbidden

Please	install	ASP.NET	3.5	and	4.5	and	other	features	in	list	mentioned	above.	Reboot	if	needed.

Web	interface	does	not	display	correctly	or	not	working

We	recommend	using	Chrome	or	Firefox.	If	using	IE	make	sure	that	Emulation	mode	is	set	to	10.	See	image	below.



AD	logon	is	not	working

Open	the	website	in	IIS	manager	and	make	sure	that	Windows	Authentication	is	enabled	and	all	other	authentication	mechanisms
are	disabled.	When	creating	a	new	Server	connection	in	server	connection	manager;

1.	 check	Use	AD
2.	 leave	username	and	password	empty

Installing	the	Web	Client	on	other	location	than	Server

Easiest	way	is	to	install	the	VisualCron	Server	on	the	IIS	Server.	Start	the	Client	and	connect	locally	and	go	to	Server	settings->Web
client	and	install	the	web	client	as	usual.	Then	stop	and	disable	the	VC	service.	For	a	custom	installation	package	please	contact
support.

Web	Client	settings	and	logon

You	logon	into	the	web	Client	the	same	way	you	logon	to	the	Windows	Client.	But,	if	you	want	to	store	settings	you	can	click	on
the	Login	link	to	the	upper	right.	It	is	possible	to	link	settings	and	logon	information	to	different	open	authentication	systems	like:

The	advantage	is	that	you	can	store	settings	like:

Server	connections
Column	settings

Facebook	setup

1.	 create	an	App	in	Facebook
2.	 set	facebookAppID	and	facebookAppSecret	in	web.config

Windows	Live	Id	setup

1.	 You	need	to	create	your	own	app	on	https://account.live.com/developers/applications/index
2.	 In	API	parameters	add	an	URL	for	redirection,	which	finished	with:	~/Home/WindowsLiveIdLogIn	(	any	domain	can

be	used,	like	"http://example.localhost.com:54257/Home/WindowsLiveIdLogIn"	)	on	the	"Application	settings"	tab
need	to	find	an	application	Id	and	secret	key.

3.	 In	order	to	use	redirection	to	local	IP	adrress	(127.0.0.1)	two	approaches	can	be	used:	a.	Create	a	DNS	record	like
"localhost.yourcompany.com"	which	points	to	127.0.0.1	b.	Or	add	a	record	to	local	"host"	file	(
%windir%/system32/drivers/etc/host,	need	to	have	administrative	rights	to	edit	that):	127.0.0.1	example.localhost.com

4.	 Setup	IIS	4.1	*	For	IIS	EXPRESS	in	C:\Users%username%\Documents\IISExpress\config\applicationhost.config
Change

<binding	protocol="http"	bindingInformation="*:54257:localhost"	/>

to

https://account.live.com/developers/applications/index
http://example.localhost.com:54257/Home/WindowsLiveIdLogIn


<binding	protocol="http"	bindingInformation="*:54257:example.localhost.com"	/>

4.2	*	For	IIS	Open	Internet	Information	Services	(IIS)	Manager:	In	the	Connections	pane,	expand	the	server	name,	expand	Sites,
and	then	click	the	Web	site	on	which	you	want	to	configure	the	bindings.	In	the	Actions	pane,	click	Bindings.	In	the	Site	Bindings
dialog	box,	click	Add.	In	the	Add	Site	Binding	dialog	box,	add	the	binding	information(example.localhost.com),	and	then	click	OK.

5.	 in	web.config	update	these	entries	with	app	Id	and	secret	from	liveId	application	:

<add	key="wll_appid"	value="appid"	/>

<add	key="wll_secret"	value="secret"	/>

Manual	Web	Client	installation

It	is	possible	to	manually	install	the	web	client.	The	current	requirements	are:

the	Web	Client	needs	to	be	installed	on	the	same	machine	as	VisualCron
IIS	7	or	later	is	required	on	that	machine
a	specific	folder	needs	to	be	referenced	from	IIS

Steps	for	installing	the	Web	Client	are:

1.	 install	the	VisualCron	Server	on	the	machine
2.	 open	IIS	and	add	an	application	pool	called	"VisualCronWebClientAppPool".	Setings	are	.NET	4.0	and	Integrated	mode

3.	 Right	click	on	Sites	>	Add	Website.

4.	 Select	the	VisualCronWebClientAppPool	as	Application	pool.
5.	 Set	the	site	name	to	"VisualCronWebClient".
6.	 Set	the	physical	path	to	the	"WebClient"	folder	in	the	VisualCron	installation	folder	(normally	in	program	files
(x86)/VisualCron/WebClient).

7.	 Set	any	port	(default	9000).
8.	 Click	OK	to	save	the	web	site
9.	 If	you	want	to	us	AD	for	authentication	you	need	to	disable	Anonymous	Authentication	and	enable	Windows	Authentication



10.	 Enter	url	localhost:9000	in	your	browser	to	access	the	Web	Client
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Enable	Windows	Authentication	/	Active	Directory	Logon
To	enable	AD	authentication	you	need	to:

1.	 enable	Windows	Auth	in	IIS	and	disable	other	methods

2.	 click	on	the	Manage	Servers	button	in	the	Web	Client.	Add	new	User	and	check	"Use	AD"
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Mobile	App
Mobile	app	exists	for	Android	and	iOS.
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VisualCron	API
The	VisualCron	API	is	an	easy	way	to	control	the	VisualCron	Server.	The	.NET	API	is	as	powerful	as	the	VisualCron	Client.	The
Client	itself	uses	the	API	to	perform	all	actions.

You	can	find	the	API	quick	start	manual	and	the	API	reference	documentation	by	the	main	menu	 Help	>	API 	selection.

Basically,	you	can	use	these	languages:

.NET	-	c#	or	VB.NET
PowerShell

Visual	Basic	6

We	do	no	longer	support	Visual	Basic	6.
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.NET	(C#/VB.NET)

.NET

A	c#	project	sample	with	a	lot	of	functionality	exists	in	the	API	folder	of	the	installation	folder.

We	recommend	looking	at	the	basic	tutorial	for	the	API	 here	-	then	look	at	the	API	sample	project.

Below	is	a	quick	sample	in	c#:

https://help.visualcron.com
http://localhost:3001/videotutorials
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//	create	Server	object	that	holds	all	VisualCron	objects	like	Jobs,	Credentials,	Connections	etc.
Server	s;
//	create	Client	object	that	is	used	to	connect	to	the	Server
Client	c	=	new	Client();
	
//	create	a	Connection	object	which	tells	how	VisualCron	should	connect
Connection	conn	=	new	Connection();
//	use	remote	connection	method	to	connect	to	a	Server	instance	on	another	computer	(default	local	connection)
conn.ConnectionType	=	Connection.ConnectionT.Remote;
//	specify	the	DNS	name	or	IP	of	remote	server
conn.Address	=	"192.168.0.73";
//	optionally	specify	the	port	(default	value	is	16444)
conn.Port	=	16444;
	
//	these	variables	are	defined	for	demonstration	purposes:	connect	with	username	and	password,	or	connect	with	AD	credentials
bool	connectWithUsernameAndPassword	=	false;
bool	specifyUpnIdentity	=	true;
bool	specifySpnIdentity	=	false;
	
if	(connectWithUsernameAndPassword)
{
//	specify	username	you	want	connect	as	(default	"admin")	-	user	must	exist	in	the	Manage	user	Permissions	window	at	Server
	conn.UserName	=	"admin";
//	specify	password	you	want	to	connect	with	(default	empty)
	conn.PassWord	=	"";
}
else
{
//	set	below	to	true	to	connect	with	your	AD	credentials	(must	be	setup	on	Server	to	support)
	conn.UseADLogon	=	true;
	
if	(conn.ConnectionType	==	Connection.ConnectionT.Remote)
	{
		//	for	the	remote	connection	with	AD	credentials	we	can	optionally	specify	Server	identity:	either	UPN	or	SPN
		if	(specifyUpnIdentity)
			{
					conn.EndpointIdentityType	=	EndpointIdentityT.UpnIdentity;
				//	specify	the	UPN	of	the	service	account.	The	UPN	is	in	the	form	username@domain.	For	example,	when	the	service	is	running	in	a	user	account,	it	may	be	username@contoso.com
					conn.PrincipalName	=	"username@domain.com";
			}
		else	if	(specifySpnIdentity)
			{
					conn.EndpointIdentityType	=	EndpointIdentityT.SpnIdentity;
				//	specify	the	explicit	service	SPN	as	the	hostname	part	of	the	service	endpoint	address	prefixed	with	the	"host/"	literal
					conn.PrincipalName	=	"HOST/hostname.domain.com";
			}
	}
}
	
//	connect	to	Server,	set	sync	to	true	to	get	all	Server	objects
s	=	c.Connect(conn,	true);
	
//	loop	through	existing	Jobs
foreach	(JobClass	j	in	s.Jobs.GetAll())
{
//	write	Job	name	to	console
	Console.WriteLine(j.Name);
}
	
//	finally	disconnect
s.Disconnect();

https://github.com/smatechnologies/visualcron-docs/blob/main/docs/using-visualcron/dot-net-csharp-vbnet.md
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Powershell
Some	of	our	users	have	started	to	use	PowerShell	to	interact	with	VisualCron.	Below	are	some	basic	code	snippets:

Snippet	#1

https://help.visualcron.com


Snippet	#2

#	Load	the	VisualCron	API	Dlls
$VC																=	[Reflection.Assembly]::LoadFrom("C:\Program	Files	(x86)\VisualCron\VisualCron.dll");
$VCAPI								=	[Reflection.Assembly]::LoadFrom("C:\Program	Files	(x86)\VisualCron\VisualCronAPI.dll");
	
#	Define	Client	&	Server	Objects
#	Globals	to	allow	sharing	of	connections
$Global:Client								=	New-Object	-TypeName	VisualCronAPI.Client
$Global:Server								=	New-Object	-TypeName	VisualCronAPI.Server
	
#	Read	Only	VisualCron	User	for	API	Access
#	VisualCron	UserName	and	Password	from	your	Site
$Conn_UserName																								=								'username'
$Conn_PassWord																								=								'password'
$Conn_Address																								=								'localhost'
	
#	Standard	Settings
$Conn_Port																																=								16444
$Conn_ConnectionType								=								'Remote'
	
#	Function	to	Connect	to	a	VisualCron	Server	using	the	API
function	VCAPI-ConnectServer	([string]$Conn_Address)	{
	
#	Define	Connection	Object
$Conn	=	New-Object	-TypeName	VisualCronAPI.Connection
	
#	Set	Connection	Values
$Conn.Address																								=								$Conn_Address
$Conn.UserName																=								$Conn_UserName
$Conn.PassWord																								=								$Conn_PassWord
$Conn.Port																																=								$Conn_Port
$Conn.ConnectionType								=								$Conn_ConnectionType
	
#	Try	to	Connect	to	the	VisualCron	Server
try
	{
									$Global:Server	=	$Client.Connect($conn,	$true);
	
	}
catch	[$ClientLoginFailedException	ex]
	{
		MessageBox.Show(ex.Message);
	
	}
	
}
	
#	Function	to	retrieve	a	User	Variable	Value	using	the	API
#	wrapper	for	generic	get	variable	API	call	below
function	VCAPI-Get-User-Variable	([string]$Variable_Name)	{
	
$Variable_Value	=	VCAPI-Get-Variable("USERVAR("	+	$Variable_Name	+	")")
	
Return	$Variable_Value
	
}
	
#	wrapper	for	the	get-variable	API	call
#	Returns	Varian;e	Value
function	VCAPI-Get-Variable	([string]$Variable_Name)	{
	
$Variable_Name								=	"{"	+	$Variable_Name	+	"}"
	
$Variable_Value	=	$Global:Server.Variables.GetGenericVariable($Variable_Name)
	
Return	$Variable_Value
}



Snippet	#3

https://gist.github.com/atifaziz/9400489
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#	Determine	Script	Path
$Path	=	Split-Path	$MyInvocation.MyCommand.Path
	
#	Determine	Script	Drive
$Drive	=	(Get-Item	$Path).Root.Name
	
Remove-Variable	-Force	HOME
Set-Variable	HOME	$Path
	
#	include	the	VisualCron	API
.	"$HOME\VisualCron_API.ps1"
	
#	API	Information	-	Example	-	Direct	API	Call
$OSVersion	=	[VisualCronAPI.ComputerInfoAPI]::GetOSVersion()
Write-Host	'$OSVersion	:	'	$OSVersion
	
#	API	Information	-	Example	-	Direct	API	Call
$LocalAdmins	=	[VisualCronAPI.ComputerInfoAPI]::GetLocalAdministrators()
Write-Host	'$LocalAdmins	:	'	$LocalAdmins
	
#	Set	Client	Values	-	Example	using	$Client	Object
$Client.LogToFile	=	$False
	
################################################################################
#	Server	Connection	and	API	Calls
#
################################################################################
	
#	Connect	using	Server	Name	(Fully	Qualified)
#VCAPI-ConnectServer('washington.somewhere.com.au')
#	or
#	IP	Address
VCAPI-ConnectServer("123.145.167.89")
	
#	Various	Variable	Calls	-	Replace	First	2	With	UserVariable	Names	from	Your	Site
$VCUserVariable	=	VCAPI-Get-User-Variable("SERVER01")
Write-Host	'$VCUserVariable	:	'	$VCUserVariable
	
$VCServerName	=	VCAPI-Get-Variable("USERVAR(SERVER02)")
Write-Host	'$VCServerName	:	'	$VCServerName
	
$VCServerIP	=	VCAPI-Get-Variable("SERVER(IP)")
Write-Host	'$VCServerIP	:	'	$VCServerIP
	
$VCServerPort	=	VCAPI-Get-Variable("SERVER(Port)")
Write-Host	'$VCServerPort	:	'	$VCServerPort
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VisualCron	Web	API
The	VisualCron	Web	API	is	an	alternative	way	to	interact	with	VisualCron	and	extract	information.

Server	>	Settings	>	Web	API 	tab

Allow	Web	API

When	checked	VisualCron	open	ports	for	Web	API.

Unencrypted/Encrypted	ports

The	Web	API	uses	two	ports	for	communication.	The	encrypted	one	uses	a	certificate	created	by	VisualCron	to	enable	a	secure
communication	channel.

Permissions

The	Web	API	uses	the	same	permission	system	as	in	VisualCron	which	means	that	you	need	to	add	a	user	in	Manage	user
permissions	window	first.

Available	methods

Once	the	WebAPI	is	allowed	you	can	see	available	methods	here:	http://localhost:8001/VisualCron/text/Docs

Calling	the	Web	API	There	are	two	ways	of	requesting	information:

1.	 REST	The	VisualCron	REST	service	communicate	through	the	HTTP	protocol.	By	making	simple	HTTP	calls	against	the
VisualCron	service	you	can	easily	extract	information	and	interact	with	VisualCron.	The	REST	service	is	able	to	return	3
different	result	outputs:	Text	-	plain	text	output	XML	-	XML	output	JSON	-	JSON	output

The	output	method	is	controlled	through	the	url:	https://localhost:8002/visualcron/text/job/list?token=[token]
[https://localhost:8002/visualcron/xml/job/list?token=token]	https://localhost:8002/visualcron/json/job/list?token=[token]

Output	result

By	default,	if	you	use	text	as	output	headers	are	added	(property	names).	If	you	want	to	exclude	these	you	can	set
&includeheaders=false	in	the	query.	By	default	available	properties	will	be	listed	but	you	can	also	set	which	properties	(columns)	to
include	like	this:	http://localhost:8001/visualcron/text/job/List?id=1&token=[token]&columns=id,name,runmissed,tasks

It	is	possible	to	control	the	field	separator,	text	qualifier	and	line	break	like	this:	http://localhost:8001/visualcron/text/job/List?
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id=1&token=[token]=59&textQualifier=34&lineBreak=10

Tokens	and	authentication

It	is	possible	to	authenticate	once	and	use	a	token	that	will	work	for	24	hours	(and	will	be	renewed	for	each	call).	The	token	is	then
used	in	each	call.	You	can	also	authenticate	each	time	you	call	a	method.	Using	token	and	a	method	requires	at	least	2	calls	instead
of	supplying	user	name	and	password	in	each	call.	However,	using	tokens	is	faster	in	the	long	run	and	generally	more	secure.

Get	token

To	get	a	token	you	authenticate	against	the	the	logon	method:	http://localhost:8001/visualcron/text/logon?
username=admin&password=qwerty123

This	call	returns	a	token	that	you	can	used	in	following	calls	like:	http://localhost:8001/visualcron/text/job/List?token=[token]

Authenticate	in	call	By	adding	user	name	and	password	parameters	you	can	work	directly	with	the	method	without	using	tokens:
http://localhost:8001/visualcron/text/job/List?username=admin&password=qwerty123

2.	Web	service/SOAP

It	is	also	possible	to	communicate	with	VisualCron	through	the	web	service	API.	The	wsdl	URL	can	be	found	in	the	Web	API	tab	in
Server	settings.

There	is	the	following	example	in	the	API	folder	(sample	TestClient	project):

Troubleshooting

Can't	connect	securely	to	this	page	(outdated	TLS	security	settings)

																	var	binding	=	new	BasicHttpBinding()
																	{
																									MaxBufferPoolSize	=	int.MaxValue,
																									MaxReceivedMessageSize	=	int.MaxValue,
																									ReaderQuotas	=
																																	new	XmlDictionaryReaderQuotas()
																																	{
																																									MaxArrayLength	=	int.MaxValue,
																																									MaxStringContentLength	=	int.MaxValue,
																																									MaxNameTableCharCount	=	int.MaxValue
																																	},
																									Security	=	new	BasicHttpSecurity()
																									{
																																	Mode	=	BasicHttpSecurityMode.TransportCredentialOnly,
																																	Transport	=	new	HttpTransportSecurity()
																																	{
																																									ClientCredentialType	=	HttpClientCredentialType.Basic
																																	}
																									}
																	};
	
																	var	client	=	new	WebServiceClient(binding,	new	EndpointAddress("http://localhost:8001/VisualCron"));
																	//or	just:
																	//
																	//var	client	=	new	WebServiceClient();
																	//
																	//but	better	setup	binding
	
																	if	(client.ChannelFactory.Credentials	!=	null)
																	{
																									//set	Credentials
																									client.ChannelFactory.Credentials.UserName.UserName	=	txtUserName.Text;
																									client.ChannelFactory.Credentials.UserName.Password	=	txtPassWord.Text;
																	}
																	try
																	{
																									//just	call	methods
																									var	jobs	=	client.Job_List();
	
																									foreach	(var	job	in	jobs)
																									{
																																	Console.WriteLine(job.Name);
																									}
																	}
																	catch
																	{
	
																	}

http://localhost:8001/visualcron/text/job/List?id=1&token=%255Btoken%255D=59&textQualifier=34&lineBreak=10
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Install	.NET	4.7.1	and	reboot.
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VCCommand
VCCommand.exe	is	a	command	line	tool	residing	in	the	install	folder\VCommand	folder.	The	VCCommand	is	an	alternate	way,	just
like	the	API	to	interact	with	a	local	or	remote	server.	This	command	line	tool	is	based	on	command	line	switches	that	can	perform
the	following	actions	at	the	moment:

Run	a	Job
Activate	a	Job
Deactivate	a	Job
Stop	a	Job
Run	a	Task
List	Jobs
Activate	license
Deactivate	license

You	can	see	existing	command	switches	and	examples	by	running	VCCommand.exe	without	any	parameters:

Example:	VCCommand	--action	runjob	--connectionmode	local	--username	admin	--password	xyz	--name	"Job	Id	or	Name"

Example:	VCCommand	--action	activatejob	--connectionmode	local	--username	admin	--password	xyz	--name	"Job	Id	or	Name"

Example:	VCCommand	--action	deactivatejob	--connectionmode	local	--username	admin	--password	xyz	--name	"Job	Id	or	Name"

Example:	VCCommand	--action	stopjob	--connectionmode	local	--username	admin	--password	xyz	--name	"Job	Id	or	Name"

Example:	VCCommand	--action	runtask	--ip	127.0.0.1	--connectionmode	remote	--username	admin	--password	xyz	--name	"Job	Id
or	Name"

Example:	VCCommand	--action	runjob	--ip	127.0.0.1	--connectionmode	remote	--username	admin	--password	xyz	--name	"Job	Id	or
Name"

Example:	VCCommand	--action	listjobs	--connectionmode	local	--username	admin	--password	xyz

Example:	VCCommand	--logontype	ad	--action	listtasks	--connectionmode	local

Example:	VCCommand	--logontype	ad	--upn	username@domain.com	--action	listtasks	--ip	127.0.0.1	--connectionmode	remote	--
port	16444

Example:	VCCommand	--logontype	ad	--spn	HOST/hostname.domain.com	--action	listtasks	--ip	127.0.0.1	--connectionmode	remote
--port	16444

Example:	VCCommand	--action	activate	--r	xxxxx-xxx-xxxx-xxxx	--connectionmode	local	--username	admin	--password	xyz

Example:	VCCommand	--action	deactivate	--connectionmode	local	--username	admin	--password	xyz
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File
The	File	tab	is	a	part	of	the	main	menu.
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Import/Export	-	Import	Settings
The	main	menu	File	>	Import/Export	>	Import	settings	option	lets	you	import	settings	to	the	currently	connected	VisualCron
server	from	a	previous	backup/export.	You	may	import	a	settings	file	across	the	Internet.

VisualCron	settings	consists	of	many	files.	By	using	Export	settings	you	can	regularly	create	backups	of	your	settings.	The	Export
settings	create	one	zip	file	with	all	settings	which	you	later	can	import	here.	Select	the	exported	zip	file	here	and	click	start.

File	>	Import/Export	>	Import	settings

File	to	import

Enter	full	file	path	or	click	the	File	icon	to	browse	and	select	a	previously	exported	settings	file.	The	default	file	for	Export	settings
is	C:\Program	Files	(x86)\VisualCron\backup\VC-Settings.zip

Password

If	the	exported	zip	file	was	protected	with	password	then	enter	the	password	here.

Clear	existing
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Clears	all	previous	settings,	then	adds	the	new	settings.	A	setting	is	only	cleared	if	that	setting	exists	in	the	exported	file.	For
example,	if	only	Jobs	were	exported,	only	the	Jobs	will	be	cleared	when	importing.

Update	existing

Updates	existing	settings.	For	example,	all	previous	Jobs	will	remain	and	updated,	if	a	Job	with	the	same	id	exists	in	the	file.

Import	all	server	settings

Imports	all	settings	that	exist	in	the	file	you	import.

Import	the	following	settings

Select	the	settings	that	you	want	to	import.	Note	that	the	setting	must	exist	in	the	file	(must	have	been	previously	exported).

Start	Click	on	the	Start	button	to	begin	the	import.

Troubleshooting

Access	denied

This	error	is	coming	if	the	Client	is	not	running	as	administrator.	Close	the	Client	and	go	to	the	installation	folder.	Then	right	click
on	"VisualCronClient.exe"	and	choose	"Run	as	administrator".

Workaround

If	you	have	problems	importing	settings	and	if	you	want	to	overwrite	all	settings	on	destination	server	you	can	perform	the
following	steps:

1.	 stop	the	VisualCron	service	in	the	destination	server
2.	 delete	all	files	in	the	settings	folder	of	installation	except	license.xml	and	server_settings.xml
3.	 copy	all	settings	from	source	settings	folder	(except	the	files	above)	to	destination	settings	folder
4.	 start	the	service
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Import/Export	-	Export	Settings
The	main	menu	File	>	Import/Export	>	Export	settings	option	makes	a	backup	of	the	the	currently	connected	VisualCron	server
settings.	The	backup/export	may	also	be	used	to	import	these	settings	to	another	VisualCron	server	or	to	be	used	as	a	part	of	a
problem	report	or	a	in	fault	tracing	activity.	You	may	Export/Import	across	the	Internet.

It	is	recommended	to	perform	regular	backups	using	the	Export	settings	function.	If	a	setting	error	occurs	and	a	backup	file	exists	in
the	default	backup	file	path,	VisualCron	will	use	the	backup	file	and	automatically	restore	settings.	It	is	a	recommendation	that	you
keep	a	backup	file	both	in	the	default	folder	and	in	another	place.

The	exported	settings	consists	of	many	files,	but	the	Export	settings	function	creates	one	VC-Settings.zip	file.

File	>	Import/Export	>	Export	settings

Select	settings

Select	the	Server	settings	in	the	list	which	you	want	to	export.	If	there	are	no	specific	reason	for	the	export,	it	is	strongly	advised
that	you	export	all	settings,	you	may	later	choose	to	import	just	some	settings.	Note	that	when	importing	settings	again	and	using
"Clear	existing	settings"	only	existing	object	types	will	be	cleared.	For	example,	if	you	only	export	your	Jobs	the	Jobs	will	only	be
cleared	when	importing.
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Default	file	path

The	default	file	for	Export	is	C:\Program	Files	(x86)\VisualCron\backup\VC-Settings.zip.

Custom	file	path

If	you	want	to	use	another	destination	for	the	exported	file	than	the	default	file	path	then	specify	another	file	path.

Password

If	you	want	to	password	protect	and	encrypt	the	backup	you	enter	a	password	here.

Start

Click	on	the	Start	button	to	begin	the	export.
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Import/Export	-	Task	Scheduler
With	the	main	menu	File	>	Import/Export	>	Task	scheduler	option	it	is	possible	to	import	tasks	from	the	built	in	Task	scheduler.
There	are	some	limitations	as	VisualCron	uses	different	Trigger	types	and	different	Tasks.	Also,	you	might	need	to	update
information	after	importing.	See	more	information	below	in	sections	Limitations	and	Manual	update.

Connecting

To	connect	to	an	existing	Task	scheduler	instance	you	enter	information	below	and	the	click	Connect.

Host	name

This	is	the	IP/host	name	of	the	local	or	remote	server.

User	name

This	is	the	username	-	used	for	authenticating	against	the	remote	server.

Password

This	is	the	password	-	used	for	authenticating	against	the	remote	server.

Domain

This	is	the	domain	name	-	used	for	authenticating	against	the	remote	server.
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Grid	information

The	grid	displays	all	Tasks,	if	they	are	active	or	not,	the	folder	they	reside	in,	the	name,	description	and	any	warnings	during	the
import.

Actual	Actions	or	Triggers	within	the	Task	are	not	visible	in	the	grid	but	they	will	be	imported.

Task	selection

Select	the	Task	you	want	to	import	into	VisualCron.	You	can	choose	to	select	each	one	by	one,	select	all	or	deselect	all.

Importing

Click	Import	selected	to	start	the	import.	Usually,	this	goes	very	fast	as	tasks	are	already	converted	and	just	needs	to	be	sent	to
VisualCron	Server.	Jobs	that	are	created	will	get	the	Folder	property	of	the	task	as	group	name.

Limitations

Task/Action	limitations

One	difference	is	that	currently	VisualCron	does	not	fall	back	to	background	execution	when	foreground	execution	fails.
Trigger	limitations
There	are	properties	that	cannot	be	directly	transferred	into	VisualCron	like	the	repetition	property.
There	are	some	Trigger	types	that	is	not	supported	like	"Registration","Idle"

Warnings

Any	warnings,	mostly	related	to	limitations,	will	be	displayed	in	the	Warnings	column	next	to	each	task	and	also	in	the	log	textbox.

Manual	update



Manual	updates	of	imported	tasks	might	be	required.	Some	manual	changes	are	stated	in	the	log.	These	type	of	changes	concern	two
things:

Credentials	-	update	of	password.	After	import	go	to	Manage	Credentials	and	update	the	password	of	any	new,	imported
Credentials.	Connections	-	update	of	SMTP	server	information.	After	import	go	to	Manage	Connections	and	update	SMTP	server
details.

Other	types	of	changes	might	be	to	update	existing	Execute	Task.	VisualCron	does	not	execute	the	same	way	as	the	Task	Scheduler
and	manual	alterations	might	be	needed.	For	example,	if	you	use	cmd.exe	you	should	instead	call	the	full	path	to	the
executable/script	in	the	command	line	instead.	This	is	because	VisualCron	needs	that	to	be	able	to	capture	exit	code	and	output.
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Updates	-	Check	for	Updates
The	main	menu	File	>	Updates	>	Check	for	updates	option	connects	to	the	VisualCron	web	site	i	order	to	find	if	there	is	a	later
version	available.

In	case	of	this	response,	you	should	repeat	the	updates	function	at	a	later	date	until	the	official	version	is	available.

If	the	VisualCron	Client	is	off,	the	computer	where	the	VisualCron	Client	runs	is	offline	and	the	VisualCron	Client	is	started,	the
below	message	is	displayed.	It	is	also	shown	when	the	computer	where	the	VisualCron	Client	runs	is	offline	and	the	File	>	Updates
>	Check	for	updates	is	clicked.

In	File	>	Settings	>	Client	settings	>	Main	settings	tab,	uncheck	Check	for	updates	at	startup	if	desired.

In	this	case	you	are	encouraged	to	download	the	latest	official	version.
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Settings	-	Client	Settings
Some	general	settings	are	available	for	the	Client.	These	are	located	in	the	main	menu	File	>	Settings	>	Client	settings.

File	>	Settings	>	Client	settings	>	Main	settings	tab

Show	tooltips

If	this	option	is	selected,	an	"Info"	window	is	opened	when	the	mouse	points	to	some	settings.	The	displayed	text	provides
additional	information	related	to	the	specific	setting.

Check	for	updates	at	startup

If	this	option	is	selected,	a	connection	to	visualcron.com	is	performed	at	VisualCron	client	startup	in	order	to	check	for	and	notify
the	user	of	possible	later	VisualCron	versions.

Auto	translate	to	UNC	path

When	this	is	checked	all	logical	drives	(i.e.	Z)	is	translated	to	the	UNC	path	(\servername\folder\file)

Show	Server	message	boxes

If	alerts	should	be	displayed.	Otherwise	shown	in	log	window.

File	>	Settings	>	Client	settings	>	Language	tab

Choose	client	language

Select	language	to	be	used	in	VisualCron	client.	In	order	for	the	new	language	to	take	effect,	the	client	have	to	be	restarted.

NOTE

The	documentation,	web,	log	and	debug	entries	are	in	English,	independently	of	the	language	setting.	User	entered	texts,	e.g.	Job
description,	remains	in	the	entered	language.

File	>	Settings	>	Client	settings	>	Proxy	tab	Enter	specific	proxy	server	data	to	be	used	for	connection	to	a	server.	See	description
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of	Server	proxy	settings	for	more	information.

File	>	Settings	>	Client	settings	>	Grid	tab

Auto	sort	on	update

If	VisualCron	should	sort	all	Jobs	when	updates	are	received.	Checking	this	degrades	Client	performance.	Default	off.

Delay/Cache	update

To	improve	performance	you	can	delay	row	updates.	Default	off.
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Settings	-	Start	Guide
The	main	menu	File	>	Settings	>	Start	guide	option	repeats	the	start	screens	you	were	presented	to	when	you	installed	VisualCron
for	the	first	time:
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Servers	-	Manage	Servers
With	the	main	menu	File	>	Servers	>	Manage	servers	option,	the	currently	connected	server	name	is	displayed	in	the	main	menu
Server	[<server	name>]	tab,	as	a	Server/Username	entry	in	the	Server/Jobs/Tasks	grid	and	in	the	status	bar.

By	default,	the	VisualCron	server	is	installed	and	started	on	the	same	computer	as	the	client.	Managing	servers	is	a	way	to
add/edit/delete	connections	to	other	VisualCron	servers.	Thus,	it	is	easy	to	switch	between	different	connections.	It	is	in	the	login
window	you	choose	what	server	connection	to	use	when	you	are	connecting.	All	the	server	connections	are	displayed	in	the	combo
box	at	top	of	the	login	window.

Manager	servers	window

INFO

In	the	Manage	Servers	window	you	can	Add,	Edit	and	Delete	Servers	that	you	want	to	connect	to	from	the	Client.	You	can	add	any
number	of	Servers	that	you	want	the	Client	to	connect	to,	either	manually	or	automatically	when	the	Client	is	starting	up.

Scanning	for	unassigned	servers

In	the	Manage	servers	window	there	is	a	built	in	function	for	scanning	the	network	for	Windows	servers	and	any	VisualCron
servers.	This	way	you	can	let	VisualCron	detect	existing	ones	and	then	add	the	servers	for	connection	based	on	what	is	found.

Switching	between	servers

Also,	when	using	the	VisualCron	client	it	is	possible	to	switch	to	another	server.

The	easiest	way	to	switch	between	servers	is	to	click	on	a	server	in	a	Server/Username	"track"	in	the	Server/Job/Task	grid.	Clicking
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on	another	server	than	the	currently	connected,	immediately	updates	all	parts	of	the	client	window	with	information	related	the	new
server.

Switching	may	also	be	done	by	using	the	toolbar	server	connection	control	(Default:	"admin@localhost:IPC"):

Use	the	drop	down	list	in	the	leftmost	part	of	the	toolbar	to	select	a	new	server.	If	the	icon	to	the	left	of	the	server	connection	is
disconnected,	all	items	in	the	main	menu	is	"greyed	out"	and	not	accessible.	Click	the	Connect	icon	immediately	to	the	right	of	the
drop	down	server	list	to	connect	to	the	new	server.	By	this,	the	server	name	is	updated	in	all	parts	of	the	VisualCron	client	and	also
all	Jobs/Tasks	related	to	the	connected	server	are	shown	in	the	Server/Job/Task	grid.

Edit	and	add	a	server

Choose	a	server	from	the	list	in	the	File	>	Servers	>	Manage	servers	window	if	you	want	to	edit	or	delete	a	server.	If	you	click	on
Edit	the	connection	information	will	be	shown	in	the	text	boxes.	Edit	any	value	and	click	Update.

To	add	a	connection,	click	the	Add	icon	(or	the	Clear	button	if	you	are	in	edit	mode).	Enter	the	values	and	click	on	the	Add	button
to	add	the	connection.



Auto	connect	at	startup

If	you	want	the	Client	to	automatically	connect	to	this	Server	at	startup	you	should	check	this	option.

Is	a	local	server

VisualCron	can	connect	to	local	and	remote	Servers.	Choose	Is	a	local	server	if	you	are	connecting	to	a	computer	on	the	same
machine,	this	will	increase	the	login	speed	to	the	server	significantly.

Server



This	can	be	a	server	name,	or	IP	number.	VisualCron	will	try	to	resolve	or	names.	Default:	"localhost"	(your	computer).

Port

Default:	"16444".	You	can	only	change	the	port	number	(which	the	server	is	listening	to)	while	you	are	logged	in.	If	you	change	the
port	here,	remember	to	change	it	in	the	server.	Also,	be	sure	to	check	that,	if	you	use	a	firewall,	that	the	port	is	you	enter	is	opened
on	that	computer	for	incoming	traffic.

Use	Active	Directory	logon/Use	internal	logon

VisualCron	has	two	different	authentication	systems;	one	internal	and	one	that	is	extended	by	Active	Directory.	If	you	want	to	allow
Active	directory	logon	you	need	to	do	that	in	user	logon	settings.

We	have	updated	security	settings	for	AD	authentication,	so	now	negotiation	is	handled	by	native	WCF	service	API.	Update
involves	providing	some	explicit	WCF	endpoint	settings	like	Identity	type	and	Principal	name.	Those	applies	when	VisualCron
Server	starts	on	AD	environment	only.

Identity	type:

DNS	Identity

Left	for	backwards	compatibility,	all	messages	between	client	and	server	are	protected	by	VC	certificate	encryption.	Used	when
internal	authentication	is	being	used.	Windows	default:	Default	option	for	AD	authentication	when	negotionation	attempt	is	made
without	any	explicit	settings.

UPN	Identity

This	identity	type	is	used	when	VisualCron	Service	starts	as	custom	AD	user	account,	so	client	need	to	know	this	information
explicitly.	Please	provide	Principal	Name	value	as	well.

SPN	identity

This	identity	type	is	used	when	VisualCron	Service	starts	as	SystemService\LocalService\NetworkService,	so	client	need	to	know
this	information	explicitly.	Please	provide	Principal	Name	value	as	well.

Principal	Name:

Applies	for	UPN	and	SPN	identity	types	only,	should	contain	explicit	principal	name	when	negotiating	during	AD	authentication.

UPN	identity	type:

Principal	Name	should	look	like	username@FQDN

SPN	identity	type:	Principal	Name	might	look	like	HOST/serverDNSname.FQDN	or	serverDNSname.FQDN.	In	order	to	check	for
possible	SPN	values	please	run	the	following	command	setspn	-l	serverDNSname	in	Windows	CommandLine	utility.

Sample	values	used	to	start	VisualCron	service	could	be	found	at	user	logon	settings.

Username

Default:	"admin".	This	is	the	user	name	the	server	uses.	Be	sure	to	change	this	after	the	initial	login.

Password

By	default	it	is	blank.	This	is	the	password	that	the	server	uses.	Be	sure	to	change	this	after	the	initial	login.

Prompt	for	login

If	you	want	to	enter	Username	and/or	password	at	connection	then	you	should	check	this	box.

Proxy

Proxy	settings	concerns	checking	for	update,	http	Job	type	and	activation.	The	Proxy	setup	does	not	apply	to	the	SSL	connection
between	the	VisualCron	Client	and	the	VisualCron	Server.

If	you	are	using	a	proxy	to	connect	to	the	Internet	and	can't	connect,	uncheck	the	Autodetect	checkbox	and	enter	your	settings	or
contact	the	network	administrator.

Troubleshooting

The	client	and	server	cannot	communicate,	because	they	do	not	process	a	common	algorithm	You	might	have	disabled	TLS	1.2	on
the	machine.	Install	.NET	4.7.x	or	greater	and	reboot.
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Translation	-	Open	Translation	Page
The	main	menu	File	>	Translation	>	Open	translation	page	option	handles	VisualCron	appearing	in	specific	languages.	If	your
language	is	missing	in	VisualCron	or	if	a	specific	VisualCron	caption	is	missing	in	your	language,	and	you	want	to	contribute	with
translation	work,	please	contact	VisualCron	support.
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Translation	-	Update	Translation	Files
The	main	menu	File	>	Translation	>	Update	translation	files 	option	handles	VisualCron	appearing	in	specific	languages.	If	your
language	is	missing	in	VisualCron	or	if	a	specific	VisualCron	caption	is	missing	in	your	language,	and	you	want	to	contribute	with
translation	work,	please	contact	VisualCron	support.
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Server
The	Server	tab	is	a	part	of	the	main	menu.
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Main	-	Server	On/Off
In	the	main	menu	Server	>	Main	settings	>	Server	dialog,	the	VisualCron	server	status	can	be	set	to	"On"	or	"Off".	The	server
status	is	indicated	and/or	managed	by	any	connected	client	by	the	"Server	[On]"	or	"Server	[Off]"	text	in	the	main	menu	Server
option.

The	status	"Server	[Off]"	means	that	the	service	is	running	but	the	server	doesn't	execute	the	defined	Jobs	or	Tasks,	and	the	NextRun
field	for	any	active	Job	will	show	the	"Server	off"	text.	Switching	to	"Server[Off]"	may	be	used	as	an	emergency	stop	for	the
current	Job/Task	execution.

Once	you	have	changed	the	server	status,	the	status	will	be	saved	and	VisualCron	will	use	that	status	the	next	time	the	server
computer	is	started.
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Main	-	Settings
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	See	the	following	sub
chapters	for	information	about	other	tabs	than	Main	settings:

Main	-	Settings	-	Users/Logon
Main	-	Settings	-	Log	settings
Main	-	Settings	-	Email	settings
Main	-	Settings	-	Proxy
Main	-	Settings	-	Folders
Main	-	Settings	-	Web	API
Main	-	Settings	-	Web	Client

Main	>	Settings	>	Main	settings	tab

Installed	in	a	cluster	environment

Check	this	if	you	are	installing	VisualCron	(on	two	nodes)	on	a	shared	drive.

Server	port

VisualCron	sends	encrypted	information	across	the	default	TCP	port	16444.	If	you	want	to	change	this	port	you	enter	a	new	integer
value	here.

Override	HTTP	connection	limit

This	general	setting	controls	number	of	HTTP	connections	that	can	be	done	from	VisualCron.	Increasing	this	might	be	good	if	you
plan	to	run	many	HTTP	requests	at	once	(for	example	through	the	HTTP	Task).

Default	exit	code	collection

This	sets	the	default	exit	code	collection	that	is	pre-selected	in	On	error	tab	of	a	Task.
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Renaming	standard

For	various	Tasks	VisualCron	offers	"rename"	of	various	strings.	Depending	on	your	requirements	there	are	2	different
implementations.	The	REN	command	standard	follows	renaming	conventions	of	REN	command.	As	many	of	these	conventions
were	not	logical	to	us	and	our	customers	we	implemented	our	own	renaming	standard	-	adjusting	some	of	the	standards	of	the	REN
command.

Server	language

This	controls	the	language	used	on	the	Server	(when	writing	to	logs	etc).

UAC	-	set	UAC	status

This	control	the	Local	Security	Policy	settings	"User	Account	Control:	Turn	on	Admin	Approval	Mode"	and	affects	Execute	Task
primarily.	If	you	use	the	Execute	Task	along	with	a	Credential	and	get	error	-1073741502	you	should	disabled	this	property	and
reboot	after	the	change.

This	policy	setting	controls	the	behavior	of	all	User	Account	Control	(UAC)	policy	settings	for	the	computer.	If	you	change	this
policy	setting,	you	must	reboot	your	computer.	The	options	are:

UAC	is	disabled:	(Default)	Admin	Approval	Mode	and	all	related	UAC	policy	settings	are	disabled.	Note:	If	this	policy
setting	is	disabled,	the	Security	Center	notifies	you	that	the	overall	security	of	the	operating	system	has	been	reduced.
UAC	is	enabled:	Admin	Approval	Mode	is	enabled.	This	policy	must	be	enabled	and	related	UAC	policy	settings	must	also
be	set	appropriately	to	allow	the	built-in	Administrator	account	and	all	other	users	who	are	members	of	the	Administrators
group	to	run	in	Admin	Approval	Mode.

Alternatively	you	can	edit	the	registry	and	set:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\NoInteractiveServices	to	0
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In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	you	can	choose	to	add	Flows	that	will	be	added	as	default	for	new	Jobs
OR	Tasks.	Once	you	have	created	a	default	flow	here,	the	flow	will	be	suggested	whenever	you	open	a	Job	or	Task	for
editing/adding.	In	this	way,	Default	flows	has	some	resemblances	to	other	global	objects	but	it	is	not	quite	the	same.

Main	>	Settings	>	Default	flows	tab

Add/Edit/Clone/Delete

Click	the	Default	flows	icons	to	update	the	list	of	default	flows	for	Jobs	and	Tasks.

Main	>	Settings	>	Default	flows	>	Add	>	Job	flow	window

A	created	default	flow	will	add	this	flow	to	all	new	Jobs	or	Tasks	and	will	show	up	in	one	of	the	lists	in	the	Edit	Job	>	Flows	tab	or
the	Edit	Task	>	Flows	tab.	Note	that	Tasks	always	have	two	flows	included	by	default;	On	success	-	Continue	with	next	Task	and
On	error	-	Stop	Job.

If	the	new	default	flow	is	also	desired	for	previously	defined	Jobs/Tasks,	you	need	to	click	the	Get	default	flows	icon	for	each
Job/Task	flow	you	want	the	default	flow	for.
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main
content
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Independently	if	you	right	click	in	the	Default	flows	window	or	in	a	Job	Flow	or	Task	Flow	window,	you	have	the	option	to	add	or
remove	a	flow	for	all	Jobs	OR	Tasks.	This	will	take	some	seconds	and	it	will	run	in	the	background.	Thus,	the	update	will	not
immediately	be	seen	in	the	Job	Flow	or	Task	Flow	window	and	the	Cancel	button	(not	OK)	shall	be	clicked	when	leaving	the
window	in	order	not	to	save	the	screen	contents.	The	Default	Flow	Add/Edit/Clone/Delete	is	based	on	a	hidden	Id	of	the	unique
flow	that	is	created	-	not	the	actual	actions	it	takes	(i.e	Run	Notification,	Retry	etc).	This	means	that	even	if	you	create	a	Flow	that
behaves	exactly	like	another	existing	one	it	is	considered	a	new	Flow	as	it	has	another	Id.	Because	of	this,	if	you	first	create	a
Default	flow	and	then	push	it	out	for	all	Jobs	-	then	modify	the	Flow	to,	let	say	run	other	Notification,	then	push	it	out	again	to
update	all.

Each	single	flow	in	the	Job/Task	flow	lists	can	be	deleted	and	the	list	is	immediately	updated,	in	case	the	Job	Flow	or	Task	Flow
windows	are	closed	by	the	OK	button.
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Settings	-	Users/Logon
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	users
and	logon	settings	are	managed.

Main	>	Settings	>	Users/Logon	tab

Only	allow	local	connections

This	setting	closes	the	remote	port	16444	for	incoming	connections.	Local	login	is	only	possible.

Allow	Active	Directory	logon

VisualCron	has	two	different	authentication	systems;	one	internal	and	one	that	is	extended	by	Active	Directory.	This	box	needs	to	be
checked	in	order	to	allow	AD	logon.

AD	Server

When	using	Active	Directory	logon	you	need	to	specify	server	name	or	IP	address.	This	will	be	used	as	default	when	working	with
user	permissions.	Please	add	:636	to	make	secure	LDAP	connections,	i.e.	adhostname:636.	Otherwise	non-secure	connection	will
be	used.	The	name	of	the	AD	server	can	also	be	specified	in	the	extended	format:	HostName:PortNumber/DistinguishedName.	For
example:	contoso.com:636/DC=contoso,DC=com

Credential

The	AD	Server	Credential	that	will	be	used	as	default	when	working	with	user	permissions.

Test	button
When	the	button	is	pressed,	the	availability	of	access	to	AD	objects	from	the	VisualCron	Server	is	checked.	Access	is	required	for
further	authorization	of	connecting	AD	users,	in	particular	to	verify	the	user's	presence	in	AD	and	to	obtain	a	list	of	AD	groups	to
which	the	user	belongs.	The	resulting	list	of	groups	is	then	used	to	determine	the	user's	permissions	according	to	the
[settings(settings)].

Additional	testing

If	the	Test	button	produces	an	unsuccessful	result,	and	SSL	is	used	(port	636	is	specified),	it	is	possible	to	activate	an	additional
verification	mechanism.	To	do	this,	it	is	first	advisable	to	enable	extended	debug	logging,	apply	the	settings,	then	open	the
Users/Logon	tab	again	and	specify	the	AD	Server	in	the	extended	format:	HostName:PortNumber/DistinguishedName	(for
example:	contoso.com:636/DC=contoso,DC=com).	After	testing,	server	log	messages	(starting	with	"GotADTest")	will	help
determine	the	source	of	the	problem.
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Users/Logon

screen	also	displays	possible	UPN	/	SPN	values	used	to	start	the	VisualCron	Server	and	create	secure	endpoints	for	data	exchange.
You	can	use	those	as	hints	setting	up	new	Client	connections.

UPN

The	User	Principal	Name	of	the	service	account.	The	UPN	is	in	the	form	username@domain.	For	example,	when	the	service	is
running	in	a	user	account,	it	may	be	username@contoso.com

SPN

The	Service	Principal	Name	as	the	hostname	part	of	the	service	endpoint	address	prefixed	with	the	"host/"	literal.	SPN	Principal
Name	might	look	like	HOST/serverDNSname.FQDN	or	serverDNSname.FQDN.	In	order	to	check	for	possible	SPN	values
please	run	the	following	command	setspn	-l	serverDNSname	in	Windows	CommandLine	utility.
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Settings	-	Log	Settings
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	log
settings	are	managed.

Main	>	Settings	>	Log	settings	>	Settings	sub	tab

Extended	debug	logging

If	you	experience	problems	the	VisualCron	support	may	ask	you	to	turn	on	extended	debugging.	When	the	support	process	is	done
you	uncheck	this	option	as	it	leverages	the	system.

Log	to	event	log

Use	Windows	event	log	for	logging.

Log	to	file	-	Client	events

Controls	if	Client	should	write	events	to	a	file	(placed	in	VisualCron	X/log	folder).

Log	to	file	-	Server	events

Controls	if	Server	should	write	events	to	a	file	(placed	in	VisualCron	X/log	folder).

Log	to	file

If	any	option	is	activated,	a	log	file	will	be	created	and	entries	will	be	written	into	the	log	file.	A	new	log	file	is	created	for	each	day.
If	no	Job	has	been	run	during	a	day	(with	logging	on)	-	no	file	will	be	created.	The	server/client	log	file	names	are
"log_serverYYYYMMDD.txt"/"log_remoteYYYYMMDD.txt".	By	default	the	log	files	are	located	in	the	"C:\Program
Files\VisualCron\log\"	folder.

Main	>	Settings	>	Log	settings	>	Error	handling	sub	tab

Send	unhandled	server	errors	to	VisualCron

If	you	check	this	all	errors	are	reported	back	to	VisualCron.	This	way	we	can	get	enough	information	to	detect	and	fix	bugs	as	soon
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as	possible.

Main	>	Settings	>	Log	settings	>	Database	settings	sub	tab

VisualCron	uses	an	internal	database	to	log	server	events	and	Job/Task	result/output	and	audit	logging.	These	are	stored	in	separate
tables	in	an	internal	database.	You	can	control	how	many	and/or	how	long	time	this	data	should	be	stored	in	each	table.	It	is	possible
to	store	these	logs	externally.

Log	to	database

This	controls	if	the	internal	database	should	be	used	or	not.

Log	DB	location

This	controls	if	VisualCron	should	log	to	the	internal	SQL	Compact	database	or	any	external	database.

Location

Only	visible	when	using	Internal	logging.	This	shows	the	location	of	the	internal	database	(for	debugging	purposes).

Connection

Only	visible	when	using	External	logging.	Select	an	existing	Connection.	If	Integrated	Authentication	is	used	you	need	to	select	a
Credential.

Credential

Only	visible	when	using	External	logging.	Select	a	Credential	if	Integrated	Authentication	is	used	(Windows	Auth).

Create	DB	tables

Creates	the	External	DB	tables	in	the	selected	Connection.	The	following	tables	are	created:

AuditLogs	-	stores	the	Audit	logs
DBVersions	-	controls	the	version	of	the	database	(for	upgrades)
GeneralLogs	-	stores	the	General	logs
JobLogs	-	stores	the	Job	logs
TaskLogs	-	stores	the	Task	logs

Size



This	shows	the	current	size	of	the	database.

General/Audit/Job/Task	Rows

The	current	number	of	rows	in	the	current	log	type

General/Audit/Job/Task	Range

The	date	range	of	the	current	stored	objects.

General/Audit/Job/Task	Keep	a	maximum	of	x	rows	in	database

This	option	controls	how	many	rows	to	store.	If	unchecked	then	unlimited	rows	will	be	stored	(or	limited	by	number	of	days	in
setting	below).

General/Audit/Job/Task	Delete	rows	older	than	x	days

This	option	controls	how	many	days	to	store.	If	unchecked	then	unlimited	days	will	be	stored	(or	limited	by	number	of	rows	in
setting	above).

General/Audit/Job/Task	Clear	all

This	option	deletes	all	entries	for	the	current	log	type.

Reset	database	completely

If	the	database	has	exceeded	maximum	size	you	may	have	to	manually	delete	it	to	restore.	Here	are	the	steps:

1.	 Open	the	Main	>	Settings	>	Folders	tab	and	click	on	the	Output	cache	folder	>	Open	button.
2.	 Stop	the	VisualCron	service
3.	 In	the	Explorer	window	enter	the	folder	"log"	and	delete	the	file	"VisualCron4.sdf"
4.	 Start	the	service	again

Main	>	Settings	>	Log	settings	>	Output	settings	sub	tab

Limit	output	size

If	checked,	Task	output	will	be	limited	in	the	Task	log	table	to	the	value	you	set	below.	It	is	recommended	to	have	some	kind	of
limitation	so	that	the	database	file	do	not	grow	to	fast	which	makes	it	hard	to	control	and	connection	slow	between	Client	and
Server.

Max	output	size

This	is	the	max	output	size	we	store	in	real	time.	If	a	Task	has	larger	output	than	specified	we	cap	at	at	this	level.
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Settings	-	Email	Settings
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	email
settings	are	managed.

These	are	the	default	settings	that	will	be	used	for	the	Email	Tasks.	The	SMTP	connection	details	are	managed	in	the	 Connections	-
SMTP	Connection.

Main	>	Settings	>	Email	settings	tab

To	email

By	entering	information	in	this	field,	the	fields	at	Add	Job,	will	be	automatically	entered.	You	can	send	to	several	email	addresses	at
the	same	time	by	separating	these	with	a	semicolon	(";").	The	To	email	address(es)	shall	be	a	valid	email	address(es)	to	where	the
email(s)	will	be	sent.

From	email

By	entering	information	in	this	field,	the	fields	at	Add	Job,	will	be	automatically	entered.	This	is	the	default	email	address	that
VisualCron	uses	to	send	email	from.

From	name

The	origin	of	the	the	email	message.	By	default	it	is	the	server	name.
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Settings	-	Proxy
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	proxy
settings	are	managed.

Main	>	Settings	>	Proxy	tab

Proxy	type

Select	the	proxy	type	to	be	used.

Address

The	host	name	or	IP	address	of	the	proxy	server.

Port

The	port	of	the	proxy	server.

Use	credentials

Text	...

Domain

The	name	of	the	domain	to	be	used.

Username

The	user	name	to	access	the	proxy	server.

Password

The	password	to	access	the	proxy	server.
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In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	folder
settings	are	managed.

Main	>	Settings	>	Folders	tab

In	the	folders	tab	you	view	and	change	the	folders	that	are	used	within	VisualCron.

Log	folder

This	is	where	server	logs	are	stored,	for	example	log_serverDATE.txt.

Settings	folder

This	is	where	settings	are	stored.

Backup	folder

This	is	the	default	backup	folder	for	the	default	Job	"Backup	settings".

Output	cache	folder

This	is	were	temporary	output	and	the	internal	database	files	are	stored	(sub	folder	log).

Temp	folder

This	is	the	temporary	folder	that	VisualCron	uses	for	storing	temporary	files	when	working	with	various	Tasks.	This	folder	is
cleaned	up	from	time	to	time	-	do	not	keep	any	important	files	here.
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Settings	-	Web	API
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	web
API	settings	are	managed.

The	Web	API	consists	of	a	REST	and	web	services	API.	It	is	possible	to	use	encrypted	or	unencrypted	communication	(on	different
ports).

Main	>	Settings	>	Web	API	tab

Allow	Web	API

Enables	the	Web	API.

Unencrypted	port

Set	the	port	you	want	to	use	for	the	web	API	for	unencrypted	communication.

Encrypted	port

Set	the	port	you	want	to	use	for	the	web	API	for	encrypted	communication.
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Settings	-	Web	Client
In	the	main	menu	Server	>	Main	settings	>	Settings	dialog,	there	are	a	set	of	important	setting	groups/tabs.	In	this	tab,	the	web
client	settings	are	managed.

Main	>	Settings	>	Web	Client	tab	See	the	Web	Client	section.
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Main	-	User	Permissions
In	the	main	menu	Server	>	Main	settings	>	User	permissions	dialog,	user	credentials	for	different	items	(Jobs,	Tasks,	Triggers,
Notifications,	Time	exceptions,	Client	and	Server	settings,	User	administration,	Log,	and	other	objects)	are	handled.

VisualCron	uses	an	internal	system	for	authentication	and	granting	permissions	to	different	objects	within	VisualCron.	The	internal
system	can	be	extended	with	users	or	groups	from	Active	directory	to	provide	a	more	seamless	login.

A	user	is	a	set	of	user	name	and	password.	A	user	can	belong	to	one	or	more	groups.	The	actual	permissions	is	located	in	the	group.
By	default,	there	is	a	"Administrators"	group	which	can	do	everything.	You	can	create	your	own	group	in	order	to	manage	detailed
user	permissions	for	this	group.

Active	directory

By	default	the	internal	system	is	used.	To	enable	Active	Directory	support	you	need	to	enter	Users/Logon	settings.

Server	>	Main	settings	>	Settings	>	Users/Logon	tab

When	creating	the	Server	Connection	you	also	need	to	check	"Use	Active	Directory	logon".	This	way	you	tell	the	Client	to	use	AD
user	login	method.

File	>	Servers	>	Manage	Servers	>	Add	>	AD
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The	main	dialog	of	the	User	permissions	window	lists	all	users	and	AD	groups	that	are	allowed	to	connect	to	this	server.	A	user	can
be	active	(green	check	icon)	or	inactive	(red	cross	icon).	When	active,	the	user	is	granted	login	with	the	predefined	permissions.

The	Add,	Edit,	Clone	or	Delete	buttons	are	context	sensitive	to	the	tab	you	are	in.	Clone	makes	a	shallow	copy,	a	new	user	with	the
same	permissions	as	the	original	user/group.	If	you	want	to	add	an	AD	group	you	need	to	select	that	tab	and	then	click	Add.

Server	>	Main	settings	>	User	permissions

When	you	add,	edit	or	clone	a	user	you	are	presented	with	the	Add/Edit	user	window.

Server	>	Main	settings	>	User	permissions	>	Users	>	Add	>	Credentials	tab

Is	AD	user

You	can	select	users	from	the	active	directory	by	clicking	on	the	Search	button	next	to	the	Name.

User	permissions	from	AD	Group

It	is	possible	to	inherit	the	permissions	from	the	Groups	tab	of	the	AD	group.	This	is	enabled	by	default	if	user	is	created	from	a
group.	If	unchecked,	the	Groups	tab,	from	the	Add	user	window	will	be	used	instead	of	the	settings	from	the	AD	group.

Name

This	is	the	name	that	will	be	seen	in	the	Manage	users	list,	logs	and	"created	by"/"modified	by"	in	the	Job	list.

Username

This	is	the	user	name	which	is	used	at	login.

Password

This	is	the	password	which	is	used	at	login.

Email

In	a	future	version	of	VisualCron,	the	email	field	will	be	used	for	an	administrator	to	send	a	reminder	of	the	login	credentials.

Active



If	the	current	user	is	active	or	not	(login	enabled).

Server	>	Main	settings	>	User	permissions	>	AD	groups	>	Add 	tab

Group	name

The	AD	group	name.	This	can	not	be	altered	manually	-	you	need	to	search	and	select	the	group.

Active

If	the	current	group	is	active	or	not	(login	enabled).

Let	users	inherit	(not	clone)	permissions

Whenever	an	AD	user	logs	on	that	belongs	to	an	existing	group	the	AD	user	is	created	in	the	AD	user	section.	By	default,	there	is	a
reference	to	the	VisualCron	group	permissions	from	the	AD	group	in	the	new	AD	user.	But	you	can	also	uncheck	this	to	be	able	to
set	specific	group	permissions	after	(so	that	it	not	references).

A	user	can	belong	to	one	or	more	groups.	The	groups	contains	the	actual	permissions.	If	a	specific	permission	is	requested	and
granted	in	any	of	users	groups	the	user	is	granted	to	the	specific	permission.

Server	>	Main	settings	>	User	permissions	>	Add	>	Groups	tab

Server	>	Main	settings	>	User	permissions	>	Add	>	Groups	>	Edit	tab



Name

Name	of	the	group.

Default	group	for	new	users

If	this	group	should	be	the	default	group	when	a	new	user	is	created.

Permission

A	permission	can	have	the	following	attributes:

"Read"	-	Allows	the	object	to	be	viewed/showed	in	some	way.	This	can	be	a	window	or	a	list
"Add"	-	Allows	the	user	to	add	and	object	to	a	list
"Edit"	-	Allows	the	user	to	edit	an	object	in	a	list	or	window
"Delete"	-	Allows	the	user	to	delete	an	object	from	a	list
"Execute"	-	Allows	the	user	to	run/execute	something

Not	all	permissions	has,	for	obvious	reasons,	all	attributes	available.	For	example,	permission	"Log"	can	only	be	viewable	or	not	and
has,	therefore,	only	the	"Read"	setting	is	available	for	change.	When	a	setting	cannot	be	changed	for	a	permission	it	is	grayed
out/disabled.

For	each	permission,	use	the	select	boxes	to	update	the	valid	attribute	types.	Your	changes	to	a	user	will	be	saved	when	clicking	OK.

See	the	list	of	all	permissions	with	a	description	in	the	Supported	permissions	topic.

Permissions

Manage	Credentials

Read	-	Controls	if	the	user	can	open	the	Manage	Credentials	window
Add	-	Controls	if	the	user	can	Add	new	Credentials
Edit	-	Controls	if	the	user	can	Edit	existing	Credentials
Execute	-	Controls	if	a	user	can	Execute	a	Task	or	similar	with	the	selected	Credential
Delete	-	Controls	if	the	user	can	Delete	Credentials

Overriding	group	permissions

From	VisualCron	version	6.1.2.	permissions	can	be	overridden	on	Job	level	so	you	can	set	specific	permission	for	a	group	on	a
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specific	Job.	From	version	8.4.2	you	can	override	Credential	permissions.
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Supported	Permissions
Below	is	a	list	of	objects	to	which	access	can	be	configured	and	supported	permissions.

Supported	permissions:

Resource Description Read Add Edit Delete Execute List
Jobs View,	Edit,	and	Execute	Jobs editable editable editable editable editable editable
Tasks View,	Edit,	and	Execute	Tasks editable editable editable editable editable fixed
Task	Repository View,	Edit,	and	Execute	Tasks	in	the	Task	Repository editable editable editable editable editable editable
Triggers View	and	Edit	Triggers editable editable editable editable fixed
Conditions View	and	Edit	Conditions fixed editable editable editable fixed
Certificates View	and	Edit	Certificates editable editable editable editable fixed
Notifications View	and	Edit	Notifications fixed editable editable editable fixed
Connections View,	Edit,	and	Open	Connections editable editable editable editable editable editable
SSH	Keys View	and	Edit	SSH	Keys editable editable editable editable fixed
PGP	Key	Rings View	and	Edit	PGP	Key	Rings editable editable editable editable fixed
Exit	Codes View	and	Edit	Exit	Codes editable fixed editable editable fixed
Time	Exceptions:
Collections View	and	Edit	Time	Exception	Collections editable editable editable editable fixed

Time	Exceptions:
Exceptions View	and	Edit	Time	Exceptions editable editable editable editable fixed

Variables View	and	Edit	Variables editable editable editable editable fixed
Client	Connections View	Connections	to	the	Server editable fixed
Client	Settings Reserved	for	Future	Use editable editable
Server	Settings Read	and	Edit	SErver	Settings editable editable
Export	Settings Open	Export	Settings	Dialog;	Perform	an	Export editable editable fixed
Import	Settings Open	Import	Settings	Dialog;	Perform	an	Import editable editable fixed
User	Permissions View	and	Edit	Users	and	User	Groups editable editable editable editable fixed
Log View	Server	Logs editable fixed
Audit	Log Open	Audit	Log	Form editable
License View	Activation	Code;	Activate	or	Deactivate	the	License editable editable
Versions Reserved	For	Future	Use
Manage	Servers Reserved	For	Future	Use editable editable
Network	Drives Manage	Network	Drives editable editable editable editable fixed
Processes Manage	Running	Jobs editable editable fixed

Task	Manager Open	Task	Manager	Form;	Manage	System	Processes	and
Services editable editable editable editable

Object	Finder Open	Object	Finder	Form editable
Remote	File
Explorer Open	the	Open	File,	Save	File,	Browse	Folder	Dialogs editable

SQL	Explorer Open	SQL	Explorer	Form;	Execture	Scripts editable editable
Server	Sync View	and	Edit	Server	Synchronization	Settings editable editable editable editable editable editable
Cloud	Settings Open	VisualCron	Cloud	Form;	Manage	Cloud	Registration editable editable editable editable editable fixed
Health	Levels Edit	Predefined	Server	Health	Levels fixed editable fixed
Execution
Distribution

Open	Execution	Distribution	Menu	Items;	Edit	LB	Flows,
Broker	and	Distrubted	Execution	Settings editable editable fixed
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Main	-	Client	Connections
In	the	main	menu	Server	>	Main	settings	>	Client	connections	dialog,	VisualCron	clients	are	managed.	Several	VisualCron	clients
can	be	connected	to	the	same	VisualCron	server,	typically	one	client	both	has	the	VisualCron	client	application	and	the	VisualCron
tray	client	connected	to	the	same	server.	See	below	for	a	list	of	clients	that	are	connected	to	the	currently	selected	server.

Main	>	Client	connections

The	VisualCron	client	can	also	switch	its	server	connection	in	the	Server/Username	"track"	in	the	top	of	the	Server/Job/Task	grid.
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Health	-	Server	Health
In	the	main	menu	Server	>	Health	>	Server	health	dialog,	a	diagram	of	the	last	changes	in	the	Server	health	level	is	displayed,	as
well	as	the	conditions	of	the	current	health	level	and	a	list	of	previous	levels	from	the	event	log.

Health	>	[current	Server	health	level]

Server	health	levels*

*default	health	settings	for	version	10.0.2

Abbreviations:

OSCPU	-	Total	CPU	consumption	(%)
VCCPU	-	CPU	consumption	by	VisualCron	Server	(%)
OSRAM	-	System	memory	in	use	(%)
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Level Name Conditions
ExcellentOSCPU	<=	25%	and	VCCPU	<=	10%
Good OSCPU	>	25%	or	VCCPU	>	10%
OK OSCPU	>	50%	or	VCCPU	>	20%	or	OSRAM	>	80%
Bad OSCPU	>	80%	or	VCCPU	>	60%	or	OSRAM	>	90%
Very	BadOSCPU	>	90%	or	VCCPU	>	80%	or	OSRAM	>	95%
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SLA	-	Uptime,	Outages,	Latency
There	are	three	interactive	buttons	in	the	main	menu	group	Server	>	SLA:

Uptime	(%)

Server	uptime	in	the	last	24	hours	as	a	percentage.

Outages	(amount)

Server	outages	number	(how	many	times	the	server	was	stopped)	in	the	last	24	hours.

Latency	(ms)

Maximum	Server	ping	response	time	(in	ms)	in	the	last	minute	(if	there	is	no	recent	statistics,	the	last	obtained	value	is	kept).

Clicking	on	any	of	these	buttons	opens	an	interactive	report:	Server	>	SLA	>	Server	SLA	(report	with	realtime	updates)

Usage	in	Load	Balancer

Server	metrics	like	Uptime	and	Latency	are	also	available	as	Load	balancing	Conditions:	"Daily	Server	uptime	(%)"	and
"Maximum	response	time	(ms)".	See	the	Load	balancing	Flows	topic	for	information	on	how	to	use	Load	balancing	Flows	and	how
to	set	up	various	Conditions	for	them.
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Jobs	-	Jobs
A	defined	Job	is	managed	either	from	the	main	toolbar	or	by	mouse	right-click	on	a	specific	Job	in	the	Server/Job/Task	grid.	To
manage	a	Job	you	open	the	Add	Job,	Edit	Job	or	Clone	Job	dialogs.

For	each	Job	type,	some	Main	settings	must	be	defined.	In	order	to	run	something	automatically,	one	or	more	Triggers	and	one	or
more	Tasks	must	be	defined	for	each	Job.	Finally	Time	exceptions,	Conditions,	Timeout	and	Notifications	may	be	defined	for	each
Job.

The	only	mandatory	setting	in	the	Add	Job/Edit	Job/Clone	Job	windows	is	the	Name	information.	When	also	the	Task	settings	has
been	defined,	the	Job	can	be	tested	by	the	Test	Job	button	(in	the	bottom	of	the	Add	Job/Edit	Job/Clone	Job	windows).

NOTE

When	you	Clone	Job,	please	make	sure	that	all	underlying	variables	in	Tasks	or	triggers	are	updated	correctly.	The	Job	settings	are
stored	by	VisualCron	in	the	jobs.xml	file,	by	default	stored	in	the	"C:\Program	Files	(x86)\VisualCron\settings\"	folder.
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Job	-	Main	Settings
In	the	the	Add	Job,	Edit	Job	or	Clone	Job	dialogs,	the	Main	settings	for	a	Job	is	available.

Add	Job

Name

Mandatory	parameter,	unique	name	for	the	Job.

Group

This	is	the	visual	grouping	in	the	main	window	grid.	To	create	a	new	group	you	just	manually	enter	a	value	in	this	field.

Description

Add	information	to	see	the	difference	between	Jobs.

Extended	Job	debug	logging

When	checked,	VisualCron	logs	additional	information	during	the	execution	-	for	example	information	about	Triggers	and	all
internal	operations.	This	is	mainly	used	for	debugging	if	you	experience	a	problem.

Run	once	(can	be	activated	later)

Run	missed	Jobs	once	at	start
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This	function	can	be	used	for	a	specific	Job	to	let	a	Job	automatically	run	if	it	should	have	been	run	during	a	time	when	the
VisualCron	service	was	down/stopped	for	any	reason	(typically	due	to	server	computer	off).	For	example,	a	Job	is	supposed	to	run
once	a	day	at	08:00.	Let's	say	that	the	server	goes	down	at	07:00	because	a	power	failure.	The	problem	is	corrected	and	the	server
goes	up	at	09:00.	If	the	Run	missed	Jobs	once	at	start	box	is	checked,	VisualCron	will	at	startup	check	if	the	Job	was	supposed	to
run	between	the	last	time	VisualCron	was	up	and	the	current	time.	If	so,	that	Job	will	be	run	once.

NOTE	1

Currently,	run	missed	Jobs	doesn't	take	time	exceptions	into	account.	A	missed	Job	will	run	even	if	there	was	a	time	exception
during	that	time.

NOTE	2

The	"run	missed	events"	behavior	is	not	active	when	the	server	has	been	stopped	by	the	user	(i.e.	server	status	"Off").

Remove	Job	after	running

If	you	check	this	box	the	Job	will	be	removed	right	after	running.

Use	run	random	value

To	be	selected	if	you	want	to	run	Jobs	at	irregular	time	intervals.	Check	the	box	and	enter	a	probability	value.	For	example	value	2
means	that	the	Job	will	run	approximately	1	out	of	2	times.	So	if	you	want	your	Job	to	run	approximately	three	times	an	hour,	you
should	specify	value	20	and	in	the	Time	settings	select	to	run	it	every	minute.	1	out	of	20	times,	the	Job	will	run	every	minute
(60/20	=	3	times	in	one	hour).	Note	that	this	is	a	probability	value.	In	this	case,	the	Job	may	run	2	times	one	hour	and	4	times
another	hour.

Do	not	start	if	Job	if	is	already	running

When	a	Job	is	running	it	is	"flagged"	as	running.	If	you	don't	want	to	execute	your	Job	while	it's	running	the	check	this	box.	This
can	be	useful	when	using	the	new	events	which	can	trigger	your	Job	very	often	if	you	set	the	watch	parameters	"loosely".	If	the	Job
is	triggered	when	this	box	is	checked,	a	log	entry	will	inform	that	the	Job	wasn't	run	due	to	this	setting.

Put	Job	in	queue

When	checked:	if	a	Job	is	already	running	the	actual	execution	Job	is	postponed	until	the	current	Job	has	completed.	This	option
should	be	enabled	for	any	Jobs	that	is	using	Event	Triggers	which	allows	unique	processing	of	an	object,	i.e.	a	newly	created	file
when	using	File	Trigger.

Run	Tasks	in	order

One	Job	can	contain	many	Tasks.	If	you	for	some	reason	want	to	run	your	Tasks	in	a	special	order,	check	this	checkbox.	The
specific	Task	order	is	set	up	under	the	Tasks	tab.	If	you	don't	want	to	run	the	Tasks	in	order,	VisualCron	will	try	to	run	them	at	the
same	time.	This	can	shorten	the	actual	run	time	for	the	Job	since	some	Tasks	are	dependant	on	external	factors	like	a	remote	server.

Activate	(when	added)

By	default	a	new	Job	is	activated	(will	be	run	if	the	time	is	right)	when	it's	added.

ROI

These	settings	override	the	main	ROI	settings.

Use	default	Job	time

When	unchecked	it	will	not	use	the	main	ROI	settings	but	a	specific	time	for	this	Job	that	is	saved	for	each	execution.

Use	default	Job	rate



When	unchecked	it	will	not	use	main	ROI	settings	rate	per	hour	but	a	specific	one	for	this	Job.

Only	store	succesful	executions

When	checked	it	will	only	log	ROI	when	the	Job	has	succeeded.

Job	variables

See	Job	variables	for	more	information.

Permissions..

From	VisualCron	version	6.1.2,	permissions	for	a	specific	Job	can	be	set.	It	is	controlled	by	overriding	the	current	existing	groups.
When	a	specific	permission	is	overridden	in	a	positive	way	(granting	access)	it	becomes	green	in	the	grid	and	it	becomes	red	if
overridden	in	a	negative	way	(denying	access).
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Job	Variables
Job	Variables	are	values/parameters	that	is	connected	to	a	specific	Job.	When	comparing	Job	Variables	with	User	Variables	there	are
a	couple	of	differences:

Job	Variables	are	stored	in	the	Job	and	not	global	like	User	Variables	-	still	it	is	possible	to	refer	to	a	Job	Variable	from	another
place	in	VisualCron
It	is	possible	to	override	existing	Job	Variables	with	the	Job/Task	Control	Task
The	Job	Variables	are	edited	from	the	main	settings	of	the	Job	while	the	User	Variables	are	edited	in	the	Variables	browser
In	the	Variables	browser	you	can	see	the	Job	Variables	beneath	each	Job	node	while	the	User	Variables	are	located	under	the
User	Variables	node

Editing	Job	Variables

You	find	the	Job	Variables	for	a	specific	Job	in	the	Job	>	Main	settings	tab	by	clicking	on	the	Job	Variables..	button	in	the	lower
right	corner.

Add	Job	>	Main	settings

Job	Variables

In	the	Job	Variables	window	all	Variables	that	are	connected	to	the	current	Job	are	listed.	You	can	Add	new,	Edit	or	Delete	by
clicking	the	buttons	or	by	double	click	on	row.

Skip	to
main
content
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Add/Edit	Job	Variable

The	add/edit	Job	Variable	window	lets	you	Add	a	new	or	Edit	an	existing	Job	Variable.
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Job	Triggers
A	Trigger	is	a	part	of	a	Job,	the	object	that	starts	a	Job.	One	Job	can	have	one	or	more	Triggers.	A	Trigger	can	either	be	based	on
Time	(for	example	Every	minute)	or	a	system	event	(a	file	has	been	created).	By	default,	Triggers	are	executed	in	an	"OR-matter".
This	means	Triggers	do	not	wait	for	each	other	to	start	the	Job.	You	can	create	dependencies	between	one	or	more	Triggers.

By	invoking	the	Add	Job,	Clone	Job	or	Edit	Job	functions,	the	Triggers	tab	can	be	opened.

Job	>	Triggers	tab

Add

By	pressing	the	Add	button,	the	different	Time	Trigger	and	Event	Trigger	options	are	listed.

Edit

Opens	a	Trigger	for	edit.	Select	a	row	first.

Delete

Deletes	a	Trigger.	Select	a	row	first.

Dependencies

By	default,	Triggers	are	executed	in	an	"OR-matter".	This	means	Triggers	do	not	wait	for	each	other	to	start	the	Job.	You	can	create
dependencies	between	one	or	more	Triggers	by	clicking	on	Dependencies..

Job	>	Tiggers	>	Dependency
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Trigger	selection

In	the	check	list	box	you	can	select	all	Triggers	that	should	be	in	a	dependency.

Wait	type

For	a	Job	to	start	all	Triggers	must	fire	(if	a	dependency	exist)	at	least	once.	The	wait	time	defines	how	long	time	before	the	state	of
firing	should	exist.

Wait	infinite	time	for	other	Triggers

VisualCron	will	never	reset	state.	For	example,	Trigger	1	might	fire	1000	times	and	the	Job	will	still	not	start	because	Trigger	2	has
not	yet	fired.

Wait	specified	time	for	other	Triggers

After	a	specified	time	the	state	will	be	reset	on	all	Triggers	in	the	dependency.	If	you	want	to	use	this	option	then	select	a	time	until
the	state	should	be	reset.

Use	sliding	wait

When	using	specified	time	you	can	use	sliding	wait.	This	means	that	the	state	wait	time	will	be	reset	for	each	Trigger	that	fires.

The	grid	in	the	Job	>	Triggers	tab

The	Trigger	grid	listing	contains	all	Triggers	that	belong	to	the	current	Job.	Each	trigger	is	listed	as	a	row	in	the	Description	table
under	the	Add,	Edit	and	Delete	buttons.	Mouse	double-click	on	any	part	of	the	trigger	row	opens	the	same	window	as	the	Edit
button.

The	grid	has	6	columns:

Active

By	default	Active.	This	checkbox	indicates/controls	if	a	Trigger	should	be	active	or	not	(if	active	it	is	waiting	for	the	time/events).

Trigger	type

This	icon	shows	if	it	is	a	Time	or	Event	Trigger.

Trigger	inner	type	This	icon	shows	what	kind	of	Time	or	Event	Trigger.	For	example	if	the	Event	Trigger	is	of	inner	type	File
Trigger.

Dependency	image

By	default,	Triggers	are	executed	in	an	"OR-matter".	This	means	Triggers	do	not	wait	for	each	other	to	start	the	Job.	You	can	create
dependencies	between	one	or	more	Triggers.	When	a	Trigger	is	not	in	a	dependency	this	column	is	blank	-	otherwise,	it	will	have	a
unique	tag	icon	for	each	dependency	collection.

Fired	times	of	Trigger	in	dependency

How	many	times	a	Trigger	has	fired.	This	is	only	updated	for	Triggers	within	a	dependency.	A	Job	with	dependencies	do	only	fire



when	all	Triggers	have	been	fired	once.	After	that	-	the	fired	times	is	reset.

Description

Name/description	of	the	Trigger.

Reset	Trigger	dependency	state	when	saving	Job

This	resets	the	state	to	zero	on	all	Trigger	that	has	a	dependency.

Next	run

The	Date/time	for	the	next	run	is	shown	in	the	bottom	of	the	Job	window.
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Time	Triggers
For	Time	trigger	select	one	of	Interval	or	Custom	types.

Job	>	Triggers	>	Add	>	Time	trigger	>	Interval/Custom

Settings	tab

Enter	a	description	which	will	distinguish	several	triggers	from	each	other	in	a	trigger	list.	You	can	also	choose	between	the	Interval
Time	Trigger	and	Custom	Time	Trigger	type	triggers.	One	trigger	type	is	always	selected	and	the	other	option	will	be	grayed	out.

Interval	tab

This	time	trigger	is	a	simplified	Custom	time	trigger.	Different	Interval	options	are	available.

Custom	tab

The	Custom	time	trigger	also	allows	setting	of	time	details	when	a	Job	should	be	triggered.

Expire	tab

The	expiration	date/time	for	the	time	trigger	may	be	set.	Also	the	handling	(Deactivate/Delete	trigger)	of	the	expired	trigger	is
selected.
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Interval	Time	Triggers
Set	Time	Trigger	>	Interval	tab

Interval

The	Time	unit	(day,	hour,	minute,	second	or	specific	days	of	week/month)	how	often	the	Job	should	be	triggered

Every

The	occurrence	(	1:st,	2:nd,	etc.)	is	set.

Whatever	interval	time	unit	that	is	selected,	also	the	Start	time	(date	and	time	for	first	run	occurrence)	may	be	selected.
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Custom	Time	Triggers
Time	Trigger	->	Custom	tab

The	Year,	Month,	Day,	Hour,	Minute	and	Second	time	parameters	may	be	defined.

For	each	time	unit,	Every,	Choose	or	Between	can	be	selected.	The	Between	...	option	specifies	a	range	of	values	for	the	specific
time	unit.	For	example,	Between	weekdays	"Friday"	and	"Tuesday"	means	that	the	Job	will	run	on	"Friday",	"Saturday",	"Sunday",
"Monday"	and	"Tuesday".

Examples

Choosing	for	example	day	"31"	results	in	that	the	Job	will	only	execute	on	months	with	31	days
By	default,	Second	=	"0"	is	checked.	In	order	to	be	able	to	set	a	correct	time	on	a	Job,	a	Job	must	have	a	least	one	second
specified.	Second	"0"	is	the	first	second	in	a	minute.

Next	run

Next	run	is	calculated	every	second.	Next	run	is	based	on	the	values	you	enter	in	time	settings	using	the	time	on	the	server.	Note
that	next	run	is	an	indicative	value,	that	is	if	you	are	about	to	add	or	edit	a	Job	and	you	set	that	Job	to	run	every	minute	it	won't	run
every	minute	until	you	have	finished	the	add/edit	window	and	the	Job	has	appeared	in	the	Job	list.

NOTE

Calculation	of	next	run	does	not	take	any	time	exceptions	into	account.
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Time	Trigger	-	Expiration

Set	date	and	time	when	the	time/event	trigger	should	be	removed.

There	are	two	kinds	of	expiration	modes:

Expire	-	the	trigger	will	still	remain	in	the	Job	but	is	inactive	and	cannot	be	triggered	until	it	is	set	to	active	again
Delete	trigger	-	the	trigger	will	be	deleted	from	the	Job	and	will	never	be	seen	again
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Event	Triggers
The	event	trigger	is	a	complex	and	sensitive	but	also	powerful	way	to	monitor	the	system.	Events	in	the	system	can	trig	your	Job	to
run	if	that	is	the	intention.	An	example	is	if	your	web	server	service	dies	and	you	want	to	know	and	act	upon	that.

Most	events	are	based	on	the	WMI	(Windows	Management	Instrumentation)	interface.	WMI	is	a	management	technology	allowing
scripts	to	monitor	and	control	managed	resources	throughout	the	network.	Resources	include	hard	drives,	file	systems,	operating
system	settings,	processes,	services,	shares,	registry	settings,	networking	components,	event	logs,	users,	and	groups.	WMI	is	built
into	clients	with	Windows	2000	or	above,	and	can	be	installed	on	any	other	32-bit	Windows	client.

Using	a	WMI	based	trigger,	requires	some	common	settings	to	control	the	behavior.	These	common	settings	are	located	in	the	Main
Settings	tab	of	the	Event	Trigger	window.

Security:

Some	Triggers	require	higher	privileges	than	the	default	privileges	of	the	LocalSystem	account.	You	need	to	either	change	the	user
that	runs	the	VisualCron	service	to	an	administrator	or	add	LocalSystem	user	to	the	administrators	group	(requires	a	restart	of	the
server).	This	is	especially	true	when	trying	to	monitor	a	remote	event,	like	monitoring	an	event	log	on	another	server.

Warning:

Some	event	based	triggers,	like	the	File	event	type,	can	in	some	cases,	trigger	several	times	a	second.	This	will	run	your	Job	several
times	a	second.

In	the	Triggers	tab,	clicking	on	Add	>	Event	trigger,	a	selection	window	for	the	different	event	trigger	types	is	opened.

Triggers	>	Add	>	Event	Trigger	>	Main	settings	tab
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It	is	possible	to	change	the	event	trigger	type	in	the	top	combo	box,	which	results	in	that	the	current	trigger	type	tab	is	exchanged.

Description

Enter	a	description	which	will	distinguish	several	triggers	from	each	other	in	a	trigger	list.

Auto	description

This	will	general	a	description	automatically	based	on	Trigger	type	and	settings.

Auto	refresh	description

This	forces	update	of	the	description	even	though	it	is	not	empty.

Active

Determines	if	the	current	event	is	active	from	start.	If	not,	it	can	be	reactivated	later.	Default	is	active.

Run	delay

You	can	set	a	delay	which	means	that	the	trigger	will	fire	x	number	of	times	before	executing.	Default	is	1	which	means	that	the	it
will	fire	when	the	first	time	it	has	been	triggered.

Polling	interval

This	value	is	only	used	by	certain	WMI	events,	otherwise	grayed	out.	The	polling	interval	defines	how	often	VisualCron	should
check	for	changes	in	the	system.	Default	is	every	60	second.	Setting	it	to	a	lower	value	than	10	will	increase	the	load	on	the	server.
What's	good	is	that	you	won't	miss	any	events	even	though	you	are	not	checking	it	every	second.	Changes	are	stored	and	if
something	has	happened	you	will	be	notified	at	your	polling	interval.	What	is	important	to	know	is	that	if	you	are	watching	for	state
"stopped"	at	a	service	and	the	service	has	started	then	stopped,	any	change	has	not	occurred	since	the	service	was	stopped	in	the
first	place.	The	service	has	to	be	started	before	monitoring	a	"stopped"	change.	Also,	if	the	the	service	has	started	before	monitoring
and	it	turns	from	started	to	stopped	within	the	polling	interval	no	change	is	observed	and	you	won't	be	notified.

Remote	event



This	value	is	only	used	by	certain	WMI	events,	otherwise	grayed	out.	Can	remotely	monitor	another	computer	in	the	network,
specify	the	name	or	IP	address	of	the	remote	computer.	The	computer	has	to	be	in	the	local	network.	Default	is	"."	which	means	that
VisualCron	is	monitoring	the	the	local	computer.	A	network	credential	must	be	specified	when	connecting	to	a	remote	computer.
Also	you	must	check	so	that	the	remote	computer	let's	this	computer	or	user	access	the	WMI	on	the	remote	computer.

Credentials

To	control	a	remote	computer	you	may	need	to	use	a	Credential.	The	Credential	must	match	the	user	name	and	password	of	the	user
that	you	want	to	login	for.	Select	a	Credential	in	the	combo	box	or	click	the	Settings	icon	to	open	Manage	credentials	in	order	to	add
or	edit	Credentials.

Ignore	Server	Off	(always	run)

If	checked,	the	Trigger	will	always	run	even	though	the	Server	status	is	Off.

Triggers	>	Add	>	Event	Trigger	>	Timeout	tab

If	trigger	has	not	fired	in	x	time

Specify	number	of	hours,	minutes	and	seconds	for	the	timeout.

Timeout	action

When	VisualCron	detects	the	timeout	it	will	fire	the	event.

Triggers	>	Add	>	Event	Trigger	>	Expires	tab



Expiration	enabled

Check	this	option	to	enable	an	expiration	type.	You	are	able	to	set	if	a	Trigger	should	be	deleted	or	deactivated	at	a	certain	time	or
after	a	certain	number	of	triggered	times.	Select	either	date	or	x	time(s)	the	trigger	has	to	fire	before	action.

Expire	action

Select	desired	activity	when	a	Trigger	has	expired.	Choose	between	"Inactivate	trigger"	and	"Delete	trigger".
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Event	Trigger	-	VisualCron
The	VisualCron	event	trigger	watches	internal	processes	of	VisualCron.	This	Trigger	subscribes	on	internal	events,	like	when	a	Job
has	started	or	has	been	completed.	Events	that	are	happening	in	VisualCron	are	immediately	caught	by	this	event	type.	It	is	possible
to	monitor	a	local	or	remote	Server	instance.

Triggers	>	Add	>	Event	Trigger	>	VisualCron	tab

Local/Remote	server
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You	can	choose	to	monitor	the	current	local	Server	or	a	remote	VisualCron	Server.	If	you	want	to	monitor	a	remote	Server	you	need
to	select	Remote	server	and	define	a	VisualCron	Connection.

Job	name

If	you	select	an	internal	Trigger	of	type	Job	you	need	to	specify	a	Job	name.

VisualCron	Events

Jobs

Job	completed

If	the	Job	completes	either	successfully	or	fail.

Job	completed	-	successfully

If	the	Job	completes	with	success.

Job	completed	-	failed

If	the	Job	completes	with	failure.

Job	missed

If	the	Job	missed	a	Trigger	according	to	schedule	because	Server	was	down	or	similar.

Triggers

Trigger	inactivated

Any	user	or	other	activity	that	deactivates	the	Trigger

Trigger	inactivated	by	error

If	a	Trigger	fails	monitoring	something,	i.e.	if	Connection	fails	for	too	many	times.

Trigger	expired	(deleted	or	inactivated)

If	the	Expiration	enabled	is	set	and	the	Expire	action	is	any	reason.

Trigger	expired	(inactivated)

If	the	Expiration	enabled	is	set	and	the	Expire	action	is	Inactivate	Trigger.

Trigger	expired	(deleted)

If	the	Expiration	enabled	is	set	and	the	Expire	action	is	Delete	Trigger.

Trigger	deleted

If	the	Trigger	is	deleted.
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MFT	Server
The	MFT	Server	event	trigger	monitors	the	internal	MFT	server	for	events.	General	creation	and	configuration	of	MFT	server	is
made	in	MFT	Server	Settings.

Triggers	>	Add	>	Event	Trigger	>	MFT	Server	>	MFT	event	type	sub	tab

MFT	Server	name

Select	all	or	a	specific	MFT	endpoint.

Event	type

Select	all	or	specific	MFT	event	type.

User

Select	all	or	a	specific	User.
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Event	Trigger	-	Variable
The	Variable	Trigger	tracks	changes	in	the	values	of	the	specified	Variables.	It	is	possible	to	either	respond	to	Variable	change
events	or	perform	periodic	polling	and	checking	the	current	values.

Triggers	>	Add	>	Event	Trigger	>	Variable	>	Variable	tab	>	Trigger	sub	tab

Automatic	variable	change	tracking

Fire	the	trigger	if	the	configured	condition	(or	a	group	of	conditions)	has	been	met	and	either	the	condition	acts	as	an	event	or	a
mismatched	condition	state	was	previously	detected.	Polling	interval	is	ignored.

Interval	polling

Perform	a	check	of	configured	conditions	at	intervals	specified	in	Main	settings.	Fire	the	trigger	if	conditions	are	met.

Variable	tab	>	Conditions	sub	tab
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One	or	more	conditions	can	be	configured	here.	By	default,	conditions	are	linked	with	the	AND	operator,	but	if	necessary,	the
conditions	can	be	combined	into	groups,	and	the	groups	can	be	linked	with	the	OR	operator.

Conditions	sub	tab	>	Add	condition	>	Main	Settings	tab



There	are	currently	two	types	of	conditions	supported:

Variable	value

A	state-check	condition	that	checks	the	current	value	of	a	Variable	against	a	given	criterion.	Allows	the	duration,	including	the
calculation	of	the	average	value	if	a	numeric	value	type	is	selected.	Can	act	as	an	event,	so	that	the	next	match	of	the	condition	is
possible	only	after	an	unmatched	state	is	detected	or	the	reset	timeout	expires.

Variable	value	changed

An	event-based	condition	that	triggers	every	time	the	value	of	a	Variable	changes	from	its	previous	value.

Conditions	sub	tab	>	Add	condition	>	Variable	value	condition	type	>	Configure	tab

Variable

Variable,	or	a	combination	of	several	Variables,	the	value	of	which	is	checked	in	the	condition.

Condition

Comparison	operator	for	the	current	Variable	value	and	the	"Value	to	compare	with".

Type

Variable	value	type.

Value	to	compare	with

Can	be	a	specific	value,	or	another	Variable.

Duration

All	values	of	the	Variable	obtained	during	the	specified	period	are	checked	against	the	criterion.

Average	value

The	average	value	of	all	values	of	the	Variable	obtained	during	the	specified	period	of	time	is	checked	against	the	criterion.

Act	as	an	event



If	enabled,	the	next	match	of	the	state-check	condition	is	possible	only	after	an	unmatched	state	is	detected	or	the	reset	timeout
expires.

Auto	reset	timeout

If	nonzero,	the	condition	can	trigger	again	after	the	specified	timeout,	even	if	the	state	matched	all	the	time.

Pause	after	triggering

The	period	of	time	after	previous	triggering	when	the	event	generation	is	suppressed.	However,	if	while	waiting	for	the	end	of	the
suppression	period,	the	state	changes	to	non-matching,	and	then	changes	back	to	matching,	then	immediately	after	the	end	of	the
suppression	period,	the	condition	will	be	triggered	again.

Conditions	sub	tab	>	Add	condition	>	Variable	value	changed	condition	type	>	Configure	tab

Variable

Variable,	or	a	combination	of	several	Variables,	the	value	of	which	is	checked	in	the	condition.

Pause	after	triggering

The	period	of	time	after	previous	triggering	when	the	event	generation	is	suppressed.	If	an	event	occurs	in	the	system	before	the
suppression	period	has	ended,	the	event	will	be	ignored.

Force	event	reset	after	each	condition	set	calculation

The	state	will	be	set	to	nonsignaled	when	calculating	the	entire	condition	tree,	regardless	of	whether	the	event	is	checked	directly	or
not.

Keep	signaled	state	until	event	is	checked	directly

The	event	will	remain	in	the	signaled	state	until	it	is	checked	directly	during	condition	calculations.

Variable	Trigger	Result	Variables

EvaluatedExpression

The	general	evaluated	expression	of	all	configured	conditions,	for	example:	"VariableValue({USERVAR(CustomVariable)}):42	=
42	OR	VariableValue({USERVAR(CustomVariable)})	=	2319".

ConditionId|Success



Check	status	of	a	certain	condition.

ConditionId|ActualParameterValue

The	actual	Variable	value	of	a	certain	condition.

ConditionId|EvaluatedExpression

The	evaluated	expression	of	a	certain	condition.

Configuration	examples

Type	1	-	Interval	Polling

Example	1.1

Every	10	minutes,	check	the	value	of	the	Variable	"VarX".	If	the	value	is	"X",	run	the	Job.

set	the	polling	interval	to	600	(seconds)	on	the	Main	settings	tab;
activate	"Interval	polling"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Condition	=	Equal
Value	to	compare	with	=	X

Example	1.2

Every	10	minutes,	check	the	average	value	of	the	numeric	Variable	"VarN"	for	the	last	10	minutes.

If	the	average	is	above	[N],	run	the	Job.

set	the	polling	interval	to	600	(seconds)	on	the	Main	settings	tab;
activate	"Interval	polling"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
Condition	=	Larger
Type	=	Int32
Value	to	compare	with	=	[N]
Duration	=	00:10:00
Average	value	=	Checked

Type	2	-	Variable	Value	Changed	Event

Example	2.1

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	changes.

activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value	changed"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}

Example	2.2

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	changes,	but	no	more	than	once	per	minute.

If	the	value	has	changed	before	1	minute	has	elapsed	since	the	previous	change,	ignore	the	change.

activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value	changed"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Pause	after	triggering	=	00:01:00

Example	2.3

Run	the	Job	every	time	the	value	of	the	numeric	Variable	"VarN"	changes,	provided	that	the	new	value	is	less	than	 [MinN]	or
greater	than	[MaxN]	(i.e.	is	outside	the	tolerance	interval).



activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value	changed"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
add	another	"Variable	value"	condition	by	pressing	"Add	group";
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
Condition	=	Smaller
Type	=	Int32
Value	to	compare	with	=	[MinN]

add	another	"Variable	value"	condition	by	pressing	"Add	nested	group";
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
Condition	=	Larger
Type	=	Int32
Value	to	compare	with	=	[MaxN]

set	AND	operator	between	the	first	two	conditions
set	OR	operator	between	the	last	two	conditions

Type	3	-	Variable	Value	Becomes	Matched	The	Condition

Example	3.1

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	becomes	"X".

activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Condition	=	Equal
Value	to	compare	with	=	X

Example	3.2

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	becomes	"X",	and	also	run	the	Job	every	10	minutes	while	the	value
remains	equal	to	"X";	with	the	limitation	of	starting	the	Job	no	more	than	once	per	minute,	so	that	if	the	value	becomes	"X"	earlier,
the	Job	will	be	executed	with	a	delay	of	1	minute	after	the	previous	run	(if	the	value	is	still	"X").

activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Condition	=	Equal
Value	to	compare	with	=	X
Act	as	an	event	=	Checked
Auto	reset	timeout	=	00:10:00
Pause	after	triggering	=	00:01:00

Example	3.3

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	becomes	"X",	provided	that	the	value	of	the	Variable	"VarN"	is	equal	to
"N"	at	that	moment.

activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Condition	=	Equal
Value	to	compare	with	=	X
Act	as	an	event	=	Checked

add	another	"Variable	value"	condition	by	pressing	"Add	condition";
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
Condition	=	Equal
Value	to	compare	with	=	N

Example	3.4

Run	the	Job	every	time	the	value	of	the	Variable	"VarX"	becomes	"X",	provided	that	the	value	of	the	Variable	"VarN"	has	changed
since	the	previous	successful	run.



activate	"Automatic	variable	change	tracking"	mode	on	the	Variable/Trigger	tab;
add	a	new	"Variable	value"	condition	on	the	Variable/Conditions	tab;
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarX)}
Condition	=	Equal
Value	to	compare	with	=	X
Act	as	an	event	=	Checked

add	another	"Variable	value	changed"	condition	by	pressing	"Add	condition";
set	up	the	condition	parameters	on	the	Configure	tab:

Variable	=	{USERVAR(VarN)}
Keep	signaled	state	until	event	is	checked	directly	=	Checked
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Event	Trigger	-	File
The	File	event	trigger	monitors	changes	in	a	file	system.	The	Trigger	reacts	on	files	that	has	been	changed,	removed	or	created
based	on	special	attributes.	The	Trigger	is	instant	when	file	has	been	created.	It	is	possible	to	retrieve	the	folder,	full	path	or	just	the
name	of	the	created	file	so	you	can	use	it	in	your	Tasks	for	example.

To	monitor	a	change	you	have	to	specify	a	path.	The	file	event	is	not	based	on	WMI	but	can	monitor	a	remote	computer	if	you
specify	the	appropriate	credentials	(username,	password	and	computer	name	for	the	remote	computer).

Triggers	>	Add	>	Event	Trigger	>	File	tab

Folder	path

This	is	the	directory	you	want	to	monitor.

File	mask

The	filter	can	be	a	complete	file	name	or	your	can	use	.	to	monitor	all	files	(default)	or	e.g.	*.txt	to	monitors	all	text	files.	If	you
want	to	check	for	multiple	file	masks	you	can	separate	them	with	semicolon	(;).	For	example:	.txt;	.xml
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Exclude	folder	mask

Use	this	field,	with	our	without	wild	cards,	to	exclude	triggering	files	from	(sub)folder	matching	the	mask.	The	comparison	will	be
done	against	the	sub	folder	name.	If	you	do	want	to	check	against	the	whole	part	of	the	path	then	check	Compare	with	full	path.

Compare	with	full	path

See	above.

Exclude	file	mask

This	field	is	used	the	same	as	File	mask	but	is	used	to	exclude	one	or	more	file	masks.	If	you	want	to	check	for	multiple	file	masks
you	can	separate	them	with	semicolon	(;).	For	example:	.txt;.xml.	To	exclude	special	characters	like	#	you	need	to	wrap	them	like
this:	[#].	For	example:	[#]*.txt

File/Folder	watch	type

There	are	a	set	of	watch	types	which	monitors	changes	that	might	occur	to	a	file	or	directory:

"Created"	-	the	creation	of	a	file	or	folder
"Changed"	-	change	of	a	file	or	folder.	The	types	of	changes	include:	changes	to	size,	attributes,	security	settings,	last	write,
and	last	access	time
"Deleted"	-	the	deletion	of	a	file	or	folder
"Renamed"	-	the	renaming	of	a	file	or	folder

Include	subfolders

This	setting	enables	monitoring	of	all	sub	folders	of	the	Path.

Use	polling	(Samba	compatible)

Only	use	this	option	if	you	are	monitoring	a	Samba	file	share.	Samba	does	not	support	the	normal	file	events	so	we	are	using	our
own	polling	technique	instead.

Trigger	when	file	has	been	released

If	you	are	planning	on	using	the	file	that	was	triggered	directly	you	could	use	this	option	to	ensure	that	the	file	has	been	fully
changed/written	before	it	is	being	triggered	(and	used	by	you	or	a	later	stage	in	VisualCron).

Trailing	Trigger

When	checked	VisualCron	will	watch	for	changes	within	a	file	and	through	Variables	deliver	the	change	(of	text)	between	write	to
the	file.	Use	this	Variable	to	track	changes:	{TRIGGER(Active|LastTrigger|File.Result.NewText)}

Notify	filters

Specifies	changes	to	watch	for	in	a	file	or	folder.	These	are	used	in	conjunction	with	the	watch	types.	Certain	combinations	can	give
different	results.	The	following	notify	filters	can	be	activated:

"File	name"	-	the	name	of	the	file
"Directory	name"	-	the	name	of	the	directory
"Attributes"	-	the	attributes	of	the	file	or	folder
"Size"	-	the	size	of	the	file	or	folder
"Last	write"	-	the	date	the	file	or	folder	last	was	updated
"Last	access"	-	the	date	the	file	or	folder	was	last	opened
"Creation	time"	-	the	creation	time	for	a	file	or	folder
"Security"	-	the	security	settings	of	the	file	or	folder

You	can	combine	the	notify	filters	to	watch	for	more	than	one	kind	of	change.	For	example,	you	can	watch	for	changes	in	the	size	of
a	file	or	folder,	and	for	changes	in	security	settings.	This	raises	an	event	anytime	there	is	a	change	in	size	or	security	settings	of	a
file	or	folder.

On	error	reconnect	attempts

Let	say	the	remote	folder	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
attempts	value	controls	how	many	times	VisualCron	tries	to	reconnect.	Default	value	is	3	times.

On	error	reconnect	interval	(seconds)

Let	say	the	remote	folder	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
interval	which	you	can	specify	is	the	number	of	seconds	it	will	wait	between	each	reconnect	attempt,	in	seconds.	Value	1	to	500	is
available.	Default	is	5	seconds	which	may	be	a	long	time	when	the	network	is	down	and	a	short	time	if	the	remote	computer	is



down.	VisualCron	attempts	to	reconnect	3	times	by	default.

Duplicate	file	delay	(milliseconds)

Some	systems	create	duplicate	Created/Changed	events.	The	duplicate	file	delay	is	a	time	period	where	no	new	events	are	accepted
from	the	same	file	name.	This	setting	sends	the	first	event	and	prevent	later	events	ompared	to	Consolidate	changes	which	waits	and
sends	the	last	event.

Consolidate	changes	(milliseconds)

Some	systems	create	duplicate	Created/Changed	events.	The	consolidate	changes	delay	is	a	time	period	when	events	are	queued
into	one	single	last	event.	For	example,	if	you	are	watching	for	Created	and	Changed	events	this	could	potentially	generate	1
Created	and	2	(or	more)	Changed	events.	By	increasing	this	value	we	wait	for	file	to	be	updated	during	this	time.	If	file	is	updated	it
will	wait	another	round.	Finally,	this	will	generate	one	single	event.	Compared	to	Duplicate	file	delay	which	just	send	the	first	event
-	then	wait	the	Consolidate	changes	will	wait	and	send	the	last	event.

File	watcher	buffer

You	can	set	the	buffer	to	4	KB	or	larger,	but	it	must	not	exceed	64	KB.	Increasing	the	size	of	the	buffer	can	prevent	missing	file
system	change	events.	However,	increasing	buffer	size	is	expensive,	so	keep	the	buffer	as	small	as	possible.

Trigger	on	existing	files

Once	the	File	Trigger	has	been	setup	you	can	click	on	the	Trigger	to	manually	fire	on	existing	files	in	folder.

Task	right-click	>	Triggers

Using	File	Trigger	Variables	in	upcoming	Tasks/Notifications

Whenever	a	file	is	created	unique	Variables	will	be	created	in	VisualCron	so	you	know	exactly	which	file	was	created.	It	is	common
that	users	use	wild	cards	or	hard	coded	fields	when	later	working	with	the	created	files	-	this	will	later	end	up	in	timing	issues	and
working	with	the	wrong	file.	Instead,	whenever	there	is	a	Task	or	Notification	with	Source	folder	and	Include	file	mask	you	should
use	these	Variables:

Source	folder:	{TRIGGER(Active|LastTrigger|File.Result.TriggerFolder)}	-	this	is	the	folder	the	file	was	created	in
Include	file	mask:	{TRIGGER(Active|LastTrigger|File.Result.Name)}	-	this	is	the	name	of	the	file	that	was	created
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Event	Trigger	-	Remote	File
The	Remote	File	event	trigger	is	able	to	monitor	file	events	on	remote	computers	using	the	protocols	FTP,	SFTP	and	SCP.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Main	settings	tab

Connection

This	Trigger	uses	the	centrally	stored	Connections.	Available	protocol	types	are	listed	here.	Click	on	Manage	Connections	to	add	a
new	one.

Watch	for	changes

You	are	able	to	watch	for	new,	modified	and	deleted	files.	Select	what	you	want	the	Trigger	to	fire	for.

Wait	for	file	being	released

The	Trigger	will	monitor	a	new	file	for	modify	date.	If	modify	date	has	not	changed	since	last	check	the	Trigger	will	fire	'Created'
event.

Reset	status	when	updating	Trigger	(use	current	files	as	base)

This	reloads	the	internal	list	of	files.	You	should	check	this	if	you	for	some	reason	change	the	Connection.

On	error	reconnect	attempts

Let	say	the	remote	server	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
attempts	value	controls	how	many	times	VisualCron	tries	to	reconnect.	Default	value	is	3	times.

On	error	reconnect	interval	(seconds)

Let	say	the	remote	server	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
interval	which	you	can	specify	is	the	number	of	seconds	it	will	wait	between	each	reconnect	attempt,	in	seconds.	Value	1	to	500	is
available.	Default	is	5	seconds	which	may	be	a	long	time	when	the	network	is	down	and	a	short	time	if	the	remote	computer	is
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down.	VisualCron	attempts	to	reconnect	3	times	by	default.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Location	tab

This	Task	is	using	the	standard	VisualCron	Folder	filter	to	find	one	or	more	folders.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Date	tab

This	Task	is	using	the	standard	VisualCron	Folder	filter	to	filter	for	created/modified	date.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Size	tab

This	Task	is	using	the	standard	VisualCron	Folder	filter	to	filter	out	files	based	on	size.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Test	tab

This	Task	is	using	the	standard	VisualCron	Folder	filter	to	test	your	current	file	filter	-	if	it	matches	any	existing	files.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Download	tab

Download	file	before	triggering

Optionally,	you	can	set	the	Remote	file	Trigger	to	download	the	file	that	was	just	Triggered.

Credential

Select	a	Credential	if	you	are	going	to	save	to	a	network	drive.	Click	the	Settings	icon	to	populate	the	drop-down	list	with	available
credentials.

Destination	folder

The	local	folder	where	the	file	should	be	saved.

Overwrite	options

If	the	file	exists	you	can	choose	different	overwrite	options.

http://localhost:3001/client-user-interface/server/job-tasks-folder-filter
http://localhost:3001/client-user-interface/server/job-tasks-folder-filter
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Resume	transfer	if	failed

If	an	error	occurs	while	downloading	the	file	you	can	choose	to	retry	X	times	and	wait	Y	seconds	between	each	retry.

Keep	modified/created	date

This	option	will	set	the	same	modified	and	creation	date	as	the	on	the	ftp.

Keep	modified/created	date

Sets	the	modified/created	date	on	locally	downloaded	files	to	the	same	dates	as	the	remote	files.

Create	relative	folder	structure

Creates	relative	folders	if	checked.	If	not	checked	all	files	(in	sub	folders)	will	be	saved	to	destination	folder.

Replace	unsupported	characters	with	character

If	checked,	VisualCron	will	replace	any	character	that	is	not	supported	in	Windows	file	system	with	the	specified	character.

Delete	source	file	after	download

Optionally	delete	the	remote	file	after	download.

Triggers	>	Add	>	Event	Trigger	>	Remote	file	>	Variables

Last	run

When	the	Trigger	was	last	run.

Name

The	name	of	the	file	that	was	created/modified/deleted.



Folder

The	folder	of	the	file	that	was	created/modified/deleted.

Path

The	full	path	to	the	file	that	was	created/modified/deleted.

Size

The	size	of	the	file	that	was	created/modified/deleted.

Last	modified

The	last	modified	date	of	the	file	that	was	created/modified/deleted.
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Event	Trigger-	Cloud	File
The	Cloud	file	event	trigger	is	able	to	monitor	file	events	in	various	online	cloud	services:

Amazon	S3
Box
DropBox
Google	Drive
Microsoft	Azure
OneDrive

Different	Connections	are	used	depending	on	the	wanted	cloud	service	provider.

Triggers	>	Add	>	Event	Trigger	>	Cloud	file	>	Cloud	file	>	Main	settings	tab

Watch	for	changes

You	are	able	to	watch	for	new,	modified	and	deleted	files.	Select	what	you	want	the	Trigger	to	fire	for.

Reset	status	when	updating	Trigger	(use	current	files	as	base)

This	reloads	the	internal	list	of	files.	You	should	check	this	if	you	for	some	reason	change	the	Connection.

On	error	reconnect	attempts

Let	say	the	remote	server	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
attempts	value	controls	how	many	times	VisualCron	tries	to	reconnect.	Default	value	is	3	times.

On	error	reconnect	interval	(seconds)

Let	say	the	remote	server	you	watch	gets	disconnected	for	some	reason,	perhaps	the	network	or	computer	is	down.	The	reconnect
interval	which	you	can	specify	is	the	number	of	seconds	it	will	wait	between	each	reconnect	attempt,	in	seconds.	Value	1	to	500	is
available.	Default	is	5	seconds	which	may	be	a	long	time	when	the	network	is	down	and	a	short	time	if	the	remote	computer	is
down.	VisualCron	attempts	to	reconnect	3	times	by	default.

Triggers	>	Add	>	Event	Trigger	>	Cloud	file	>	Cloud	file	>	Remote	file	filter	tab

This	Trigger	uses	the	Cloud	Remote	file	filter	for	filtering	out	files	to	check	for.

https://help.visualcron.com
http://localhost:3001/client-user-interface/server/connection-amazon
http://localhost:3001/client-user-interface/server/connection-box
http://localhost:3001/client-user-interface/server/connection-dropbox
http://localhost:3001/client-user-interface/server/connection-google-drive
http://localhost:3001/client-user-interface/server/connection-microsoft-azure
http://localhost:3001/client-user-interface/server/connection-onedrive
http://localhost:3001/client-user-interface/server/global-connections
http://localhost:3001/client-user-interface/server/job-tasks-cloud-remote-file-filter


Triggers	>	Add	>	Event	Trigger	>	Cloud	file	>	Cloud	file	>	Download	tab

Download	file	before	triggering

Optionally,	you	can	set	the	Remote	file	Trigger	to	download	the	file	that	was	just	Triggered.

Credential

Select	a	Credential	if	you	are	going	to	save	to	a	network	drive.	Click	the	Settings	icon	to	populate	the	drop-down	list	with	available
credentials.

Destination	folder

The	local	folder	where	the	file	should	be	saved.	Click	the	Folder	icon	in	order	to	browse	the	folder	tree.

Overwrite	options

If	the	file	exists	you	can	choose	different	overwrite	options.

Keep	modified/created	date

Sets	the	modified/created	date	on	locally	downloaded	files	to	the	same	dates	as	the	remote	files.

Delete	source	file	after	download

Optionally	delete	the	remote	file	after	download.
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Event	Trigger	-	HTTP	REST
The	HTTP	REST	Trigger	is	able	to	host	a	local	HTTP	server,	on	a	certain	path	and	be	able	to	receive	requests	through	GET	and
POST	through	that	path.	The	Trigger	will	capture	all	details	about	the	request	including	parameters	received.	These	parameter
values,	among	other	information	about	the	request,	can	be	accessed	as	Variables	for	the	Trigger.

Main	settings

Address

Use	this	property	to	set	the	authentication	realm.	All	pages	in	the	same	realm	share	authentication	credentials.Realm	parameter
refers	to	Digest	authorization	and	is	not	a	required	parameter.

Realm

Use	this	property	to	set	the	authentication	realm.	All	pages	in	the	same	realm	share	authentication	credentials.Realm	parameter
refers	to	Digest	authorization	and	is	not	a	required	parameter.

Request	methods	tab

https://help.visualcron.com


In	this	tab	you	specify	the	paths	and	methods	supported.	Above	you	can	access	http://localhost:9991/go2	with	POST	and
[http://localhost:9991/go3?name=John(http://localhost:9991/go3?name=John)	with	GET.	To	get	the	parameter	value	you	can	use
this	Variable	in	follow	up	Tasks:	{TRIGGER(Active|LastTrigger|HTTPREST.Result.QueryParameters.Value|name)}

Save	content	tab

http://localhost:9991/go2


In	this	tab	you	can	control	File	uploads	and	choose	how	to	name	the	files.

Variables

As	other	Triggers,	this	Trigger	produces	Variables	that	contain	various	information	about	the	request.
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Event	Trigger	-	TCP
The	TCP	Trigger	creates	a	TCP	Listener	which	then	listens	persistently	for	connections	from	TCP	network	clients.	For	each
established	connection,	the	server	communicates	with	the	client	based	on	the	logic	configured	using	some	messaging	rules.

TCP	>	Connection	group	and	Interaction	rules	inner	tab

Connection

Before	configuring	any	interaction	rules	you	must	create	a	Connection.	Click	on	Manage	Connections	to	add	a	new	Connection.
Select	TCP	connection	and	alter	connection	settings.

Interaction	rules	tab

The	tab	contains	a	toolbar	with	commands	to	configure	a	tree-like	structure,	which,	in	turn,	is	used	for	setting	up	the	messaging
logic	between	the	TCP	server	(listener)	and	the	TCP	client.

Available	commands:

Append	rule:	append	a	rule	of	some	type	(send	a	message,	receive	a	message,	or	check	the	received	message	body).	Delete:	delete
a	rule	with	all	child	rules.	Demo:	automatically	create	a	set	of	rules	with	an	example	of	a	simple	communication	algorithm	between
a	client	and	a	server.

See	"TCP	messaging	rules"	section	in	the	TCP	Task	topic.
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TCP	>	Test	console 	inner	tab

You	are	able	to	test	the	configured	messaging	rules	without	saving	the	settings.	As	a	remote	TCP	client,	a	similar	test	scenario	can
be	launched	in	the	TCP	Task	UI	form,	or	a	test	application	can	be	compiled	and	launched	(see	sample	TCP	Client	application	code
below).

Setup	maximum	number	of	iterations

All	rules	with	a	large	or	infinite	number	of	repetitions	automatically	terminate	after	the	specified	maximum	number	of	iterations.

TCP	Trigger	Result	Variables

TextBody

The	triggered	message	content	decoded	with	connection's	codepage.

ReceivedTime

The	triggered	message	receipt	time.

FromAddress

The	triggered	message	sender	address	in	the	form	"host:port".

Messages

A	list	of	processed	messages	in	the	form	{	Key,	TextBody	},	so	that	the	text	of	a	particular	message	is	available	by	specifying	Key
in	a	variable	template.

Attention:	when	using	variables	with	the	result	of	TCP	trigger	in	tasks,	for	example	{TRIGGER(...|TCP.Result.TCP.TextBody)},
it	should	be	mentioned	that	in	case	of	simultaneous	connection	of	several	TCP	clients,	the	content	of	a	variable	may	change
unexpectedly.	In	practice,	a	trigger	may	fire	twice	when	receiving	messages	from	two	different	clients,	but	the	value	of
{TRIGGER(...|TCP.Result.TCP.TextBody)}	will	contain	the	message	that	came	last.

Sample	TCP	Client	application	code 	(C#)

using	System.Net.Sockets;
using	System.Text;
	
namespace	TCP_Client
{
		internal	class	Program
			{
						static	void	Main()
							{
										/*
												*	Connecting
												*/
										using	var	tcpclnt	=	new	TcpClient();

http://localhost:3001/client-user-interface/server/job-tasks/net-tasks/tcp
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										using	var	tcpclnt	=	new	TcpClient();
											Console.WriteLine("Connecting	.....");
	
											tcpclnt.Connect("127.0.0.1",	9090);
										using	var	stm	=	tcpclnt.GetStream();
	
										if	(stm.CanWrite)
											{
															Console.WriteLine("Connected");
															Thread.Sleep(1000);
											}
										else
											{
															Console.WriteLine("The	stream	is	unavailable");
														return;
											}
											
										/*
												*	WARNING:
												*			the	encoding	should	be	the	same	as	configured	in	the	TCP	Connection	/	Common	settings	/	Code	page
												*/
										var	enc	=	Encoding.UTF8;
										string	message;
										byte[]	buffer;
	
										/*
												*	Sending	"Handshake"
												*/
											message	=	"Handshake";
											Console.WriteLine();
											Console.WriteLine($"Sending	'{message}'	.....");
											buffer	=	enc.GetBytes(message);
											stm.Write(buffer,	0,	buffer.Length);
	
											Console.WriteLine($"'{message}'	sent");
											Thread.Sleep(1000);
	
										/*
												*	Receiving	a	response
												*/
											Console.WriteLine();
											Console.WriteLine("Receiving	.....");
											buffer	=	new	byte[tcpclnt.ReceiveBufferSize];
										var	cnt	=	stm.Read(buffer,	0,	buffer.Length);
	
											message	=	enc.GetString(buffer,	0,	cnt);
											Console.WriteLine("Message	received	:	"	+	message);
	
										/*
												*	Checking	the	response
												*/
										const	string	heartbeat_response	=	"Heartbeat";
										if	(message	==	heartbeat_response)
											{
															Console.WriteLine("Response	checked.	Ready	to	send	a	command");
															Thread.Sleep(1000);
											}
										else
											{
															Console.WriteLine($"The	response	is	invalid.	Must	be	'{heartbeat_response}'");
														return;
											}
	
										/*
												*	Sending	some	command
												*/
											Console.WriteLine();
											Console.Write("Enter	the	command	to	be	transmitted	:	");
											message	=	Console.ReadLine()	??	string.Empty;
	
											Console.WriteLine($"Sending	'{message}'	.....");
											buffer	=	enc.GetBytes(message);
											stm.Write(buffer,	0,	buffer.Length);
	
											Console.WriteLine("Command	sent.");
											Console.WriteLine("Exit.");
							}
			}
}
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Event	Trigger	-	SQL
The	SQL	event	trigger	is	able	to	monitor	and	Trigger	upon	a	result	value	from	a	text	or	stored	procedure	query.	The	SQL	Trigger
supports	all	kind	of	database	Connections.

Triggers	>	Add	>	Event	Trigger	>	SQL	>	Connection	sub	tab

Database	Connection

Select	an	existing	database	Connection,	if	not	existing	you	need	to	create	one	first.	Click	the	Settings	icon	to	open	the	Manage
Connections	dialog.	Once	a	connection	is	added	you	can	select	it	in	the	combo	box.

Credential	for	integrated	security

If	your	Credential	requires	integrated	security	you	should	select	a	Windows	user	that	has	access	to	database.	Click	the	Settings	icon
to	populate	the	drop-down	list	with	available	Credentials.

Command	timeout

How	long	time	before	the	query	times	out.

Triggers	>	Add	>	Event	Trigger	>	SQL	>	Trigger	>	Text 	sub	tab
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Enter	the	query	in	the	text	field.	If	you	have	a	stored	procedure	-	select	the	stored	procedure	tab.

Triggers	>	Add	>	Event	Trigger	>	SQL	>	Trigger	>	Stored	procedure 	sub	tab

Enter	the	name	of	the	stored	procedure	to	execute.	The	grid	shows	all	parameters.	When	clicking	on	the	Add	button,	a	parameter
window	will	open.	Enter	parameter	values	for	Name,	Value,	Data	type	and	Parameter	direction.



Validate	value

If	this	value	is	checked	VisualCron	will	validate	the	value	against	the	value	type.	Unselect	this	if	you	are	using	a	Variable	as	value
and	this	Variable	is	not	yet	set.

Test	your	SQL	Task	before	closing	the	VisualCron	client.	Errors	will	be	reported	in	the	log	window.

Triggers	>	Add	>	Event	Trigger	>	SQL	>	Trigger	>	Condition	sub	tab

Condition

Select	the	comparison	method.

Data	type

Select	the	result	data	type	and	the	value	to	compare	with.

Value	to	compare	with

Enter	a	value/Variable	to	compare	the	result	with.	Click	the	Variables	icon	to	open	the	the	Variables	list.

If	value	is	the	same	as	last	time

You	can	control	what	happens	if	the	same	value	comes	two	times	in	a	row.	By	default	the	Trigger	fire	each	time	the	Condition	is
met.
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Event	Trigger	-	Powershell
The	PowerShell	Trigger	is	able	to	execute	an	existing	PowerShell	file	or	PowerShell	script	on	the	fly	and	then	monitor	the
resulting	output.

Triggers	>	Add	>	Event	Trigger	>	PowerShell	>	PowerShell	tab	>	Trigger	sub	tab

Inside	the	Trigger	sub	tab	there	are	four	inner	tabs:	Main	settings,	Script,	Parameters	and	Commands.	The	composition	and
purpose	of	all	the	parameters	that	are	available	in	the	inner	tabs	fully	corresponds	to	the	description	of	the	parameters	from	the
topic,	which	describes	the	PowerShell	Task.

PowerShell	tab	>	Condition	sub	tab
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Remove	all	leading	and	trailing	white-space	characters	from	the	result

All	leading	and	trailing	white-space	characters	are	removed	from	the	PowerShell	script	output	before	the	condition	is	checked.

Condition

Select	the	comparison	method.

Data	type

Select	the	result	data	type	and	the	value	to	compare	with.

Value	to	compare	with

Enter	a	value/Variable	to	compare	the	result	with.	Click	the	Variables	icon	to	open	the	the	Variables	list.

If	value	is	the	same	as	last	time

You	can	control	what	happens	if	the	same	value	comes	two	times	in	a	row.	By	default	the	Trigger	fire	each	time	the	Condition	is
met.

PowerShell	Trigger	Result	Variables

MatchedValue

The	string	representation	of	the	matched	value	from	the	PowerShell	script	output.
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Event	Trigger	-	.NET	Code	Execute

The	composition	and	purpose	of	all	the	parameters	that	are	available	inside	the	Trigger	sub	tab	fully	corresponds	to	the	description
of	the	parameters	from	the	topic,	which	describes	the	.NET	code	execute	Task.

.NET	code	execute	tab	>	Condition	sub	tab
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Remove	all	leading	and	trailing	white-space	characters	from	the	result

All	leading	and	trailing	white-space	characters	are	removed	from	the	.NET	code	execution	output	before	the	condition	is	checked.

Condition

Select	the	comparison	method.

Data	type

Select	the	result	data	type	and	the	value	to	compare	with.

Value	to	compare	with

Enter	a	value/Variable	to	compare	the	result	with.	Click	the	Variables	icon	to	open	the	the	Variables	list.

If	value	is	the	same	as	last	time

You	can	control	what	happens	if	the	same	value	comes	two	times	in	a	row.	By	default	the	Trigger	fire	each	time	the	Condition	is
met.

.NET	code	execute	Trigger	Result	Variables

MatchedValue

The	string	representation	of	the	matched	value	from	the	.NET	code	execution	output.
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Event	Trigger	-	Mail
The	Email	event	trigger	is	able	to	monitor	a	mailbox	through	the	POP3	or	the	IMAP4	protocol.	The	actual	connection	properties	are
defined	in	the	Connections	window.	Based	on	subject,	sender	and	content	different	actions	can	be	performed	with	the	email.

Triggers	>	Add	>	Event	Trigger	>	Email	>	Main	settings	tab

Description

Description	or	name	of	your	Trigger.

Active

If	the	Trigger	is	active	(watching)	or	not.

Polling	interval

How	often	the	mailbox	is	to	be	checked.

Credential

To	control	a	remote	computer	you	may	need	to	use	a	Credential.	The	Credential	must	match	the	user	name	and	password	of	the	user
that	you	want	to	login	for.	Select	a	Credential	in	the	combo	box	or	click	the	Settings	icon	to	open	Manage	credentials	in	order	to	add
or	edit	Credentials.

Ignore	Server	Off	(always	run)
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The	Trigger	will	run	even	though	Server	is	set	to	off.

Triggers	>	Add	>	Event	Trigger	>	Email	>	Email	>	Main	settings	tab

Connection

Select	an	existing	POP3/IMAP4	connection,	if	not	existing	you	need	to	create	one	first.	Click	the	Settings	icon	to	open	the	Manage
Connections	dialog.	Once	a	connection	is	added	you	can	select	it	in	the	combo	box.

Mail	folder

When	VisualCron	connects	it	uses	the	default	folder	retrieved	from	the	mail	server.	If	you	want	to	change	the	folder	you	monitor
you	select	"Use	specified	folder"	and	write	the	folder	name	in	the	text	box.

Reset	checked	emails	when	modified

VisualCron	keeps	tracks	on	which	emails	that	have	been	checked	or	not.	When	an	email	has	been	checked	it	is	added	to	an	internal
list.	In	the	next	polling	interval	VisualCron	will	check	if	that	email	has	been	parsed	or	not.	To	keep	this	list	and	efficiency	to	a
minimum	it	is	recommended	that	you	either	delete	or	move	the	email	once	the	email	has	been	parsed.	This	is	controlled	in	the
Actions	tab.	If	you,	for	some	reason,	wants	VisualCron	to	reset	that	list	you	check	this	box	and	VisualCron	will	consider	all	emails
found	in	the	mail	folder	as	new.

Triggers	>	Add	>	Event	Trigger	>	Email	>	Email	>	S/MIME	tab
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VisualCron	is	able	to	decrypt	S/MIME	emails	and	verify	signatures.

Decryption

If	the	email	is	encrypted	you	need	a	Certificate	to	decrypt	it.	A	certificate	is	often	retrieved	from	the	sender	of	the	Certificate	and	is
in	the	X509	certificate	standard.	Once	you	have	created	or	imported	a	certificate	you	need	to	check	it	in	the	list.	If	an	email	is
encrypted	VisualCron	will	try	to	use	that	certificate	for	decryption.

Manage	Certificates

You	can	create/import	your	certificates	defined	in	the	Manage	Certificates	window.

Triggers	>	Add	>	Event	Trigger	>	Email	>	Email	>	Conditions	tab

The	Email	Trigger	has	some	Conditions.	The	Conditions	are	there	to	evaluate	certain	values	from	the	parsed	email.	Each	evaluation
returns	a	result.	The	following	results	exist:	All	match,	Any	match	and	No	match.	If	all	match	the	evaluation	then	it	will	return	All
match.	If	at	least	one	is	matching	it	will	return	Any	match.	If	none	are	matching	it	will	return	No	match.	The	actual	evaluation	of
the	Condition	is	different	depending	on	what	part	of	the	email	is	evaluated.	For	example,	when	evaluating	a	subject	you	can	choose
among	the	following	checks:
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"Equal"	-	the	subject	must	match	the	string	in	the	text	box	exactly
"Not	equal"	-	the	subject	must	not	match	the	string	in	the	text	box
"Contains"	-	if	any	of	the	letters	in	the	text	box	matches	the	subject	it	is	returning	a	match
"Don't	contain"	-	if	not	any	of	the	letters	in	the	text	box	matches	the	subject	it	is	returning	a	match
"Don't	check"	-	this	Condition	is	not	checked	at	all	which	is	returning	a	match

From	address

This	Condition	checks	the	actual	address	part	of	the	message	(not	name	of	sender).

Subject

This	Condition	checks	the	subject	of	the	email

Body

This	Condition	checks	the	body	of	the	email

Received	date

This	Condition	compares	the	date	and	time	the	message	was	received	against	a	Variable.	Please	not	that	you	can	only	use	date
Variables	and	that	it	does	not	matter	what	kind	of	formatting	of	the	Variable	you	use.

Triggers	>	Add	>	Event	Trigger	>	Email	>	Email	>	Actions 	tab

Actions	are	controlling	what	happens	when	the	Conditions	has	been	evaluated	-	depending	on	collective	result.

Trigger

This	action	controls	if	the	Job	should	be	triggered	or	not	depending	on	result.

Message	on	Server



This	controls	what	happens	with	the	message	on	the	mail	server.	It	is	recommended	that	you	delete	or	move	the	mail	or	VisualCron
will	check	that	email	again	in	the	next	polling	interval.	If	you	leave	the	message	on	the	server	you	can	choose	to	mark	it	as	read
(this	option	is	only	available	in	IMAP4	because	it	does	not	exist	in	POP3	protocol).	Note	that	VisualCron	does	not	care	if	it	is	read
or	not	-	VisualCron	has	it's	internal	list	to	check	if	email	has	been	checked	or	not.

Copy	message	to	folder	(not	POP3)

This	option	copies	a	mail	to	another	folder.	It	does	not	delete	it	unless	you	set	Delete	message	on	Server	in	previous	setting.	This
option	is	only	available	when	using	IMAP4	as	protocol	mode.

Save	email

Both	the	actual	mail	and/or	attachment	can	be	saved	to	a	file.	You	can	choose	to	save	the	email	at	a	custom	location	or	at	the	default
location.	By	default	the	content	is	saved	in	"C:\Program	Files\VisualCron\data\triggers\mail\{MailId}\{MailId}.eml".
Attachments	of	an	email	are	by	default	stored	in	the	attachments	folder;	"C:\Program	Files\VisualCron\data\triggers\mail\
{MailId}\attachments".

NOTE

when	forming	the	folder	name	and	file	name,	all	incorrect	characters	in	MailId	are	replaced	with	the	�	symbol.	The	final	folder
and	file	path	are	stored	in	the	trigger	execution	result	variables:	Mail.Result.Mail.MailFolder	and
Mail.Result.Mail.MailPath,	respectively.	Moreover,	this	folder	and/or	file	name	can	also	be	calculated	by	applying	the	built-in
variable	function	"File	variables	/	Encode	FileName"	to	MailID	as	follows:	{PATH(EncodeFileName|
{TRIGGER(Active|LastTrigger|Mail.Result.Mail.MessageId)}|MASK)}.
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Event	Trigger	-	Process
The	Process	event	trigger	monitors	process	changes	like	when	a	process	has	started	or	stopped.	With	this	Trigger	VisualCron
subscribe	to	start	and	stop	notifications	from	the	system.

Triggers	>	Add	>	Event	Trigger	>	Process	tab

Process	name

Enter	a	process	name	which	is	listed	in	the	Task	Manager,	e.g.	"WINWORD.EXE".	A	list	of	processes	from	the	server	can	be
retrieved	by	clicking	on	the	Select	process	button.	In	the	list	window,	double-click	on	the	desired	process	for	selection.	Note	that
the	process	name	is	case	sensitive.

Process	Event	type

"Process	start"	it	means	that	you	are	monitoring	for	new,	created,	processes.	"Process	end"	means	watching	for	termination	of	a
running	process.
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Event	Trigger	-	Service
The	Service	event	trigger	monitors	changes	is	the	status	of	a	specific	Windows	service,	stopped	or	started.	The	trigger	reacts
instantly	on	all	changes.

A	service	is	a	process	that	runs	in	the	background.	List	and	details	about	installed	services	can	be	retrieved	by	going	to	Windows
Control	Panel	->	Administrative	Tools	and	open	"Services".

Often,	services	start	when	the	computer	starts.	Normally,	a	service	stops	when	an	error	has	occurred	in	the	process.	The	Service
Event	Monitor	is	based	on	WMI.	This	means	that	you	set	the	polling	interval	or	use	the	60	seconds	as	default.

Triggers	>	Add	>	Event	Trigger	>	Service	tab

Service	name

To	add	a	service	event	you	must	specify	a	service	name	and	at	least	one	state.	Click	the	Refresh	icon	to	populate	the	drop-down	box
with	service	names.

Service	status

Tick	the	check	boxes	for	the	states	you	want	to	watch.	When	a	service	with	a	specific	name	changes	or	has	changed	to	the	selected
state,	the	event	is	triggered.	The	following	service	states	exist:

"Stopped"	-	The	service	is	not	running
"StartPending"	-	The	service	is	starting
"StopPending"	-	The	service	is	stopping
"Running"	-	The	service	is	running
"ContinuePending"	-	The	service	continue	is	pending
"PausePending"	-	The	service	pause	is	pending
"Paused"	-	The	service	is	paused

NOTE
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All	services	may	not	have	all	states	implemented.	Mostly,	a	service	is	either	started	or	stopped.	Started	("Running")	and	"Stopped"
are	always	implemented	for	all	services.
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Event	Trigger	-	Registry
The	Registry	event	trigger	monitors	a	change	in	a	registry	tree,	registry	key	or	registry	value.	Registry	changes	can	be	monitored
remotely,	reacts	directly	and	changes	are	not	dependent	on	the	polling	interval.	The	event	will	be	fired	directly	when	a	change
occur.

Many	programs	and	Windows	itself	stores	information	and	change	information	during	a	Windows	session.	This	event	trigger	is
based	on	WMI.

You	can	examine	the	registry	settings	by	starting	"regedit.exe"	from	a	Windows	command	window.

Triggers	>	Add	>	Event	Trigger	>	Registry	tab

Registry	event	type

The	registry	can	be	monitored	for	changes	in	the	following	ways:

"RegistryKeyChange"	-	represents	changes	to	a	specific	key.	The	changes	apply	only	to	the	key,	not	its	sub	keys
"RegistryTreeChange"	-	represents	changes	to	a	key	and	its	sub	keys
"RegistryValueChange"	-	represents	changes	to	a	single	value	of	a	specific	key

Hive

Name	of	the	hive	that	contains	the	key	(or	keys)	that	is	changed.

Registry	key	path

Path	to	the	registry	key.	Use	backspaces	to	separate	trees.	Do	not	start	with	a	backspace.	Registry	Key
path	example:	"SOFTWARE\Microsoft\DirectX".	Do	not	include	the	hive.
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Registry	value	name

Name	of	the	value	in	the	registry	key.	Example:	"InstalledVersion"	located	in	RegistryKeyPath:	SOFTWARE\Microsoft\DirectX.
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Event	Trigger	-	Event	Log
The	Event	log	trigger	is	watching	the	Windows	event	log	for	changes.	Many	applications	and	Windows	itself	logs	directly	to	the
event	log.	With	this	trigger	you	can	monitor	the	common	logs	or	specific	logs	for	changes	based	on	event	ID,	source,	message	etc.

Some	applications	create	their	own	log	files	and	it	is	possible	for	you	to	create	one	or	view	events	by	the	Windows	application
"Event	viewer"	which	is	found	in	Windows	Control	Panel	->	Administrative	tools.	This	event	trigger	is	based	on	WMI.

Triggers	>	Add	>	Event	Trigger	>	Event	log	tab

You	can	choose	what	kind	of	conditions	to	use	by	first	enabling	the	setting	and	then	enter	a	value	in	the	text	window	or	select	a
value.	When	enabling	a	condition	you	can	choose	to	use	"AND"	or	"OR".	Think	of	it's	as	a	query.

Log	file

Probably	you	know	what	log	file	to	look	for.	Select	a	specific	log	file	or	you	may	be	flooded	with	Event	log	events	from	other	log
files.

Category	id

Each	application	(event	source)	can	define	its	own	numbered	categories	and	the	text	strings	to	which	they	are	mapped.	The	Event
Viewer	can	use	the	category	to	filter	events	in	the	log.	The	categories	must	be	numbered	consecutively	beginning	with	number	1.

Category

This	is	a	description	of	the	numeric	value,	which	could	be,	for	example:	"Kernel"	or	"Disk".	Each	application	(event	source)	can
define	its	own	numbered	categories	and	the	text	strings	to	which	they	are	mapped.	The	text	strings	associated	with	the	category	are
stored	in	the	computer's	registry.	The	Event	Viewer	can	use	the	category	to	filter	events	in	the	log.

Event	id

Event	code	is	a	numeric	value	to	further	distinguish	an	entry.

Event	type

There	exist	some	predefined	event	types	which	can	be	selected	from	the	combo	box.	The	predefined	event	types	are:
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"Error"	-	An	error	event,	indicates	a	significant	problem	the	user	should	be	aware	of;	usually	a	loss	of	functionality	or	data
"Warning"	-	A	warning	event,	indicates	a	problem	that	must	not	be	taken	care	of	immediately,	but	may	indicate	conditions
that	could	cause	future	problems
"Information"	-	An	information	event,	indicates	a	significant	and	successful	operation
"SuccessAudit"	-	A	success	audit	event,	indicates	a	security	event	that	occurs	when	an	audited	access	attempt	is	successful;
for	example,	logging	on	successfully
"FailureAudit"	-	A	failure	audit	event,	indicates	a	security	event	that	occurs	when	an	audited	access	attempt	fails;	for
example,	a	failed	attempt	to	open	a	file

Description	contains

The	formatted,	localized	text	for	the	message.	This	includes	associated	replacement	strings.	Enter	a	text	that	exists	in	a	part	of	the
description/message.

Source

The	event	source	indicates	what	initiated	the	event.	It	is	often	an	application	name	or	the	name	of	a	subcomponent	of	the
application	if	the	application	is	large.	Applications	and	services	usually	write	to	(and	therefore	are	sources	for)	the	Application	log
or	a	custom	log.	Device	drivers	usually	write	to	the	System	log.

Main	settings	tab

Polling	interval

This	value	is	also	used	for	Event	log	trigger,	in	the	case	where	(usually)	the	remote	host	is	temporarily	unavailable	to	start	Windows
event	log	tracking.	A	number	of	repeated	attempts	to	connect	to	the	remote	host	will	be	made	at	the	specified	time	intervals.
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Event	Trigger	-	MSMQ
The	MSMQ	event	trigger	is	able	to	monitor	a	private	or	public	queue	for	new	messages.	When	a	new	message	arrives	you	can	use
VisualCron	Variables	to	extract	the	information	in	the	new	message.	To	use	this	Trigger	you	need	to	setup	a	MSMQ	Connection.

Triggers	>	Add	>	Event	Trigger	>	MSMQ	tab

Credential

Select	a	Credential	if	you	are	going	to	monitor	a	remote	MSMQ	queue.	Click	the	Settings	icon	to	populate	the	drop-down	list	with
available	credentials.

Local/Remote	MSMQ

You	can	choose	to	monitor	a	local	or	a	remote	MSMQ	Server.	If	you	want	to	monitor	a	remote	MSMQ	Server	you	need	to	define	a
Host	name.

Queue

Select	the	queue	to	be	received.	Click	the	Refresh	icon	to	populate	the	drop-down	list	of	queues.

Troubleshooting:
Error:	Retrieving	the	COM	class	factory	for	component	with	CLSID	{1D9F85C0-9666-11D2-8927-0008C70C0622}	failed	due	to
the	following	error:	80040154	Class	not	registered	(Exception	from	HRESULT:	0x80040154	(REGDB_E_CLASSNOTREG)).

Make	sure	you	have	installed	MSMQ	Triggers	in	Programs	and	Features	dialog:
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Event	Trigger	-	RSS
The	RSS	event	trigger	is	able	to	watch	a	remote	RSS	feed	for	changes.	Based	on	content	on	certain	parts	of	the	feed	item	you	can
Trigger	the	Job.

Triggers	>	Add	>	Event	Trigger	>	RSS	>	Main	settings	tab

Feed	address

Text	...	Click	the	Fetch	button	to

Trigger	for	each	item	-	no	conditions

Check	this	option	if	you	just	want	to	know	when	a	feed	has	been	updated.	This	setting	will	fire	the	Trigger	each	time	a	new	item	has
been	added.

Reset	checked	RSS	items

Text	...

Ignore	parse	and	load	errors

Text	...

Timeout	in	seconds

Text	...

NOTE

As	for	all	event	triggers	we	recommend	that	you	set	"Put	Job	in	queue"	in	the	man	settings	of	the	Job.	This	will	force	VisualCron	to
process	one	item	at	a	time.	For	example,	if	you	let	your	RSS	Trigger	check	every	60	seconds	and	two	new	items	has	been	added
since	last	check	-	then	VisualCron	will	Trigger	twice.	In	order	to	be	able	to	use	Variables	from	the	Trigger	correctly	"Put	Job	in
queue"	needs	to	be	set	otherwise	a	mixup	of	Variables	is	possible.

Triggers	>	Add	>	Event	Trigger	>	RSS	>	Conditions	tab
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Triggers	>	Add	>	Event	Trigger	>	RSS	>	Security	tab

Supported	security	protocols

Text	...

Auth	type

Text	...

Credential

Select	a	Credential	suitable	for	the	selected	authentication	type.	Click	the	Settings	icon	to	populate	the	drop-down	list	with
available	credentials.

RSS	Event	Trigger	Variables

http://localhost:3001/client-user-interface/server/global-credentials


In	the	Variables	window	you	can	find	related	Variables	from	the	Trigger.
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Event	Trigger	-	System	Start/Shutdown
The	System	Start/Shutdown	Trigger	is	able	to	Trigger	a	Job	when	the	computer	has	been	startup	or	just	before	shutdown	of	the
computer.
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Event	Trigger	-	Session	Change
Unknown	event	type.

Event	type

Select	the	session	event	type(s)	you	want	to	monitor.

All/Specified	user

Select	either	All	users	or	a	specified	user	which	these	events	should	concern.
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Event	Trigger	-	Custom
The	Custom	event	trigger	is	a	wrapper	for	the	most	common	WMI	events.	There	are	thousands	of	events	which	opens	up	a	lot	of
options.	Almost	every	installed	hardware	device	in	a	computer	publish	events,	for	example	when	the	CDROM	drive	is	ejected.	This
event	is	somewhat	depreciated	and	replaced	by	the	more	advanced	Performance	Counter	trigger.

Events	that	are	not	considered,	may	be	taken	care	of	by	creation	of	your	own	WQL	(WMI	Query	Language)	query.	VisualCron	do
not	take	any	responsibility	for	customer	created	WQLs,	however	there	is	a	lot	of	documentation	available	on	the	Internet.

When	trying	to	find	the	right	query	for	an	event	it's	good	to	have	a	tool,	e.g.	the	Microsoft	WMI	Code	Creator.	This	tool	let's	you
browse,	test	and	construct	your	queries.	The	tool	can	be	downloaded	from	here.

Path

WMI	supports	namespaces,	allowing	users	to	logically	group	WMI	classes	together.	Each	WMI	provider	normally	registers	its	own
WMI	namespace	and	then	all	its	classes	within	that	namespace.	For	example,	all	Win32	WMI	classes	can	be	found	in	the	namespace
"root\cimv2",	all	IIS	WMI	classes	can	be	found	at	"root\microsoftiisv2",	and	all	LDAP	WMI	classes	can	be	found	at
"root\directory\ldap".	The	root	namespace	is	called	"Root"	and	namespaces	can	have	child	namespaces	and	WMI	classes.	The
default	path	is	\root\CIMV2.

Event	class	name

Some	drivers	require	that	you	specify	their	class	belonging.	If	necessary,	this	information	can	be	retrieved	from	the	WMI	Code
Create.	Normally,	the	Event	class	name	is	the	"table	name"	when	constructing	a	query.

Query

This	is	the	field	where	the	query	is	entered.	If	you	need	to	specify	a	polling	interval	you	do	that	in	the	query	using	the	operator
WITHIN.

EXAMPLE

SELECT	*

FROM	__InstanceOperationEvent

WITHIN	10

WHERE
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TargetInstance	ISA	'Win32_Processor'

AND	TargetInstance.LoadPercentage	>	15

This	query	checks	if	the	CPU	load	is	over	15%.	WITHIN	10	means	that	it	will	check	that	every	10th	second.	Our	recommendation
is	that	you	do	not	use	a	lower	WITHIN	value	than	10,	because	this	may	keep	your	CPU	too	busy.

A	new	query	in	WMI	Code	Creator	have	to	be	tested	before	entering	in	VisualCron.	Entering	an	invalid	query	may	affect	the
VisualCron	stability.

A	few	WMI	links:	Microsoft	WMI	Scripting	Primer	WMI	error	codes

Edit	this	page

Previous
«	Event	Trigger	-	Session	Change

Next
Event	Trigger	-	Printer	»

Copyright	©	2024	SMA	Technologies.

https://www.microsoft.com/technet/scriptcenter/guide/sas_wmi_overview.mspx?mfr=true
https://learn.microsoft.com/en-us/windows/win32/api/wbemdisp/ne-wbemdisp-wbemerrorenum?redirectedfrom=MSDN
https://github.com/smatechnologies/visualcron-docs/blob/main/docs/client-user-interface/server/event-trigger-custom.md
http://localhost:3001/client-user-interface/server/event-trigger-session-change
http://localhost:3001/client-user-interface/server/event-trigger-printer


Help

On	this	page

Event	Trigger	-	Printer
The	Event	Trigger	-	Printer	Trigger	lets	you	monitor	a	printer	for	events	within	the	spooler.

Printer	name

Printer	name	as	specified	in	devices.

Job	name	pattern

Mask	for	the	job	name	from	the	printer	queue.

Checked	job	status

Status	of	the	job	to	which	the	Trigger	will	work.

Job	user	pattern

Mask	for	the	user	who	sent	the	document	for	printing.

Job	machine	pattern

Mask	for	the	name	of	the	computer	from	which	the	document	was	sent	to	print	and	on	which	the	user	is	working	from	the	previous
element.
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Event	Trigger	-	Network	Change
The	Network	change	Trigger	is	able	to	monitor	changes	on	a	network	connection.

Network	adapters

Select	the	network	adapter(s)	you	want	to	monitor.

Type	of	events

Select	the	type	of	event	you	want	to	monitor.

Disconnected

Whenever	the	network	adapter	goes	offline.

Connected

Whenever	the	network	adapter	goes	online.

Media	disconnected

Whenever	a	network	media	is	disconnected.

IP	address	changed
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Whenever	the	IP	address	changes.
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Event	Trigger	-	Slack
The	Slack	Event	Triggers	triggers	on	new	messages	in	the	Slack	cloud.	This	Trigger	is	using	the	 Slack	Connection.

Connection

Select	a	Slack	Connection.

Text	pattern

Select	a	condition	to	match	the	Slack	message	text.

User	name

Select	a	condition	to	match	the	Slack	message	sender.

Channel	name

Select	a	condition	to	match	the	Slack	channel.

Received	date

Select	a	condition	to	match	the	Slack	message	received	date.
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Event	Trigger	-	AMQP
The	Advanced	Message	Queuing	Protocol	(AMQP)	is	an	open	standard	application	layer	protocol	for	message-oriented	middleware.
The	defining	features	of	AMQP	are	message	orientation,	queuing,	routing	(including	point-to-point	and	publish-and-subscribe),
reliability	and	security.	AMQP	defines	a	self-describing	encoding	scheme	allowing	interoperable	representation	of	a	wide	range	of
commonly	used	types.	It	also	allows	typed	data	to	be	annotated	with	additional	meaning,[17]	for	example	a	particular	string	value
might	be	annotated	so	that	it	could	be	understood	as	a	URL.	Likewise	a	map	value	containing	key-value	pairs	for	'name',	'address'
etc.,	might	be	annotated	as	being	a	representation	of	a	'customer'	type.

The	AMQP	Trigger	is	using	the	 AMQP	Connection.

Name

Name	of	the	queue.	Click	refresh	to	get	all	once	you	have	selected	a	Connection.

Durable

Indicates	what	state	of	the	terminus	will	be	retained	durably:	the	state	of	durable	messages,	only	existence	and	configuration	of	the
terminus,	or	no	state	at	all.

Timeout

Timeout	duration	that	an	expiring	source	will	be	retained.	The	source	starts	expiring	as	indicated	by	the	expiry-policy.

Dynamic
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Dynamic	request	dynamic	creation	of	a	remote	node.	When	set	to	true	by	the	receiving	link	endpoint,	this	field	constitutes	a	request
for	the	sending	peer	to	dynamically	create	a	node	at	the	source.	In	this	case	the	address	field	MUST	NOT	be	set.	When	set	to	true
by	the	sending	link	endpoint	this	field	indicates	creation	of	a	dynamically	created	node.	In	this	case	the	address	field	will	contain	the
address	of	the	created	node.	The	generated	address	SHOULD	include	the	link	name	and	other	available	information	on	the	initiator
of	the	request	(such	as	the	remote	container-id)	in	some	recognizable	form	for	ease	of	traceability.
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Event	Trigger	-	SQS
Amazon	Simple	Queue	Service	(SQS)	is	a	fully	managed	message	queuing	service	that	enables	you	to	decouple	and	scale
microservices,	distributed	systems,	and	serverless	applications.	SQS	eliminates	the	complexity	and	overhead	associated	with
managing	and	operating	message	oriented	middleware,	and	empowers	developers	to	focus	on	differentiating	work.	Using	SQS,	you
can	send,	store,	and	receive	messages	between	software	components	at	any	volume,	without	losing	messages	or	requiring	other
services	to	be	available.	Get	started	with	SQS	in	minutes	using	the	AWS	console,	Command	Line	Interface	or	SDK	of	your	choice,
and	three	simple	commands.

The	Amazon	SQS	Trigger	in	VisualCron	is	using	the	Amazon	Connection.

Amazon	SQS	Trigger	settings

Queue

Filter	on	one	or	more	queue	names.	If	not	set	it	will	watch	all.

SenderId
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Filter	on	SenderId.	If	not	set	it	will	watch	for	all.

Message	text

Filter	on	message	text.	If	not	set	it	will	watch	for	all.

Min	created	DateTime

Filter	on	min	created	time.	If	not	set	it	will	watch	for	all.

Max	created	DateTime

Filter	on	max	created	time.	If	not	set	it	will	watch	for	all.

Attribute	name

Filter	on	attribute	name.	If	not	set	it	will	watch	for	all.

On	error	reconnect	attempts

How	many	times	it	will	try	to	reconnect	on	error.

On	error	reconnect	interval	(seconds)

How	often	it	will	try	to	reconnect.
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Event	Trigger	-	Azure	Queue	Storage
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Event	Trigger	-	Desktop
The	Desktop	trigger	monitors	changes	in	a	UI	via	a	locally	or	remotely	runned	VC	tray.	The	Trigger	reacts	on	UI	events	like	as
opened,	closed,	focused,	appeared,	clicked,	checked,	hovered,	changed	and	many	other	UI,	system,	keyboard	events.	The	trigger
listens	to	events	for	a	specific	type	of	controls.	It	is	possible	to	retrieve	the	username,	hostname,	process	name,	window	name,
control	name,	control	content,	pressed	key,	event	type	and	other	results	so	you	can	use	it	in	your	Tasks	for	example.

Events	tab

Events	are	divided	into	categories:	Process,	Application,	Window,	Control,	System,	Keyboard.

Process	category

The	Process	category	contains	2	events:

Process	started
Process	ended

The	Process	started	event	monitors	the	running	of	a	specific	process	that	matches	the	name	of	the	process	that	the	user-specified
when	adding	an	event.

The	Process	ended	event	monitors	the	ending	of	a	specific	process	that	matches	the	name	of	the	process	that	the	user-specified
when	adding	an	event.

Application	category

The	Application	category	contains	4	events:

Application	focused
Application	unfocused
Application	clicked
Application	double	clicked

The	Application	focused	event	monitors	the	focusing	to	a	specific	application	that	matches	the	name	of	the	application	that	the
user-specified	when	adding	an	event.

The	Application	unfocused	event	monitors	the	focus	leaving	from	a	specific	application	that	matches	the	name	of	the	application
that	the	user-specified	when	adding	an	event.

The	Application	clicked	event	monitors	the	clicking	to	a	specific	application	that	matches	the	name	of	the	application	that	the	user-
specified	when	adding	an	event.

The	Application	double	clicked	event	monitors	the	double	clicking	to	a	specific	application	that	matches	the	name	of	the
application	that	the	user-specified	when	adding	an	event.

Window	category

The	Window	category	contains	6	events:

Window	opened
Window	closed
Window	focused
Window	unfocused
Window	clicked
Window	double	clicked

The	Window	opened	event	monitors	the	opening	of	a	specific	window	that	matches	the	name	of	the	application	and	window	that
the	user-specified	when	adding	an	event.

The	Window	closed	event	monitors	the	closing	of	a	specific	window	that	matches	the	name	of	the	application	and	window	that	the
user-specified	when	adding	an	event.
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The	Window	focused	event	monitors	the	focusing	to	a	specific	window	that	matches	the	name	of	the	application	and	window	that
the	user-specified	when	adding	an	event.

The	Window	unfocused	event	monitors	the	focus	leaving	from	a	specific	window	that	matches	the	name	of	the	application	and
window	that	the	user-specified	when	adding	an	event.

The	Window	clicked	event	monitors	the	clicking	to	a	specific	window	that	matches	the	name	of	the	application	and	window	that
the	user-specified	when	adding	an	event.

The	Window	double	clicked	event	monitors	the	double	clicking	to	a	specific	window	that	matches	the	name	of	the	application	and
window	that	the	user-specified	when	adding	an	event.

Control	category

The	Control	category	contains	7	child	categories:

Button
Textbox
Label
Checkbox
Radio	button
Combobox
Document

The	Button,	Label	categories	contains	6	events:

Button	hovered
Button	clicked
Button	enabled
Button	disabled
Button	appeared
Button	disappeared

The	Button	hovered	event	monitors	the	hovering	of	a	specific	button	that	matches	the	name	of	the	application,	window,	button,
content	that	the	user-specified	when	adding	an	event.

The	Button	clicked	event	monitors	the	clicking	of	a	specific	button	that	matches	the	name	of	the	application,	window,	button,
content	that	the	user-specified	when	adding	an	event.

The	Button	enabled	event	monitors	the	enabling	of	a	specific	button	that	matches	the	name	of	the	application,	window,	button,
content	that	the	user-specified	when	adding	an	event.

The	Button	disabled	event	monitors	the	disabling	of	a	specific	button	that	matches	the	name	of	the	application,	window,	button,
content	that	the	user-specified	when	adding	an	event.

The	Button	appeared	event	monitors	the	appearing	of	a	specific	button	that	matches	the	name	of	the	application,	window,	button,
content	that	the	user-specified	when	adding	an	event.

The	Button	disappeared	event	monitors	the	disappearing	of	a	specific	button	that	matches	the	name	of	the	application,	window,
button,	content	that	the	user-specified	when	adding	an	event.

The	Texbox,	Document	category	contains	the	same	events,	but	has	one	more	additional:	Textbox	value	changed.

The	Value	changed	event	monitors	the	value	changing	of	a	specific	textbox,	document	that	matches	the	name	of	the	application,
window,	button,	content	that	the	user-specified	when	adding	an	event.

The	Checkbox,	Radio	button	category	contains	the	same	events,	but	has	two	more	additional:	Checked,	Unchecked

The	Checked	event	monitors	the	checking	of	a	specific	checkbox	or	radio	button	that	matches	the	name	of	the	application,	window,
button,	content	that	the	user-specified	when	adding	an	event.

The	Unchecked	event	monitors	the	unchecking	of	a	specific	checkbox	or	radio	button	that	matches	the	name	of	the	application,
window,	button,	content	that	the	user-specified	when	adding	an	event.

The	Combobox	category	contains	the	same	events,	but	has	three	more	additional:

Combobox	value	changed
Combobox	opened
Combobox	closed

The	Combobox	value	changed	event	monitors	the	value	changing	of	a	specific	combobox	that	matches	the	name	of	the
application,	window,	button,	content	that	the	user-specified	when	adding	an	event.



The	Combobox	opened	event	monitors	the	opening	of	a	specific	combobox	that	matches	the	name	of	the	application,	window,
button,	content	that	the	user-specified	when	adding	an	event.

The	Combobox	closed	event	monitors	the	closing	of	a	specific	combobox	that	matches	the	name	of	the	application,	window,
button,	content	that	the	user-specified	when	adding	an	event.

System	category

The	System	category	contains	4	events:

System	locked
System	unlocked
RDP	connected
RDP	disconnected.

The	System	locked	event	monitors	the	locking	of	the	system.	The	event	fires	when	the	user	locks	the	system	session.

The	System	unlocked	event	monitors	the	unlocking	of	the	system.	The	event	fires	when	the	user	unlocks	the	system	session.

The	RDP	connected	event	monitors	the	RDP	connecting.The	event	fires	on	remote	connecting.

The	RDP	disconnected	event	monitors	the	RDP	disconnecting.The	event	fires	on	remote	disconnecting.

Keyboard	category

The	Keyboard	category	contains	3	events:

Key	pressed
Hotkey	pressed
Key	sequence	pressed

The	Key	pressed	event	monitors	the	pressing	to	a	specific	key.

The	Hotkey	pressed	event	monitors	the	pressing	to	a	specific	hotkey.

The	Key	sequence	pressed	event	monitors	the	pressing	to	a	specific	key	sequence.

Control	selector

All	fields	support	wildcards	such	as:	“?”,	“”	“”	-	any	symbol	and	any	count,	“?”	-	one	any	symbol.

For	example,	if	we	enter	‘notep*’	to	Process	name	field,	trigger	will	listen	for	all	processes	whose	name	begins	with	‘notep’.

If	you	don't	know	the	details	of	the	control,	you	can	click	on	the	search	button.

Then	select	the	control	you	need.	To	select	hold	down	the	Ctrl	button	and	click	on	the	control.

The	fields	will	be	filled	in	automatically.

Connections	tab

In	the	Connections	tab,	configure	a	connection	that	will	listen	for	an	event	on	a	local	or	remote	client.

Before	initializing	the	trigger,	make	sure	that	you	have	a	tray	client	running,	depending	on	which	connection	you	have	selected.

The	event	from	the	Process	category	requires	running	the	tray	client	as	administrator.
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Job	-	Time	Exceptions
Time	exceptions	are	"global",	which	means	that	once	a	time	exception	is	defined	it	can	be	selected	by	one	or	more	Jobs.	The
activated	collections	include	time	definitions	when	the	Job	will	NOT	run,	i.e.	blocking	time(s)	and	interval(s)	set	in	the	other	Time
settings	sub	tabs.

A	time	exception	is	a	complement	to	the	Time	trigger	settings.
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Job	-	Conditions
Condition	sets	are	global	and	the	included	conditions	for	Jobs	and	Tasks	are	managed	in	the	same	way,	see	Global	-	Conditions	for
details.
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Job	-	Tasks
A	Task	for	a	Job	is	managed	either	by	mouse	right-click	on	a	Job	(in	the	Server/Job/Task	grid)	and	select	Add	Task	to	Job	'<Job
name>'	or	by	right-click	on	an	existing	Task	and	select	Edit	Task	'<Task	name>'.

The	above	is	an	example	of	the	Task	>	Main	settings	window.

For	each	Job,	one	or	more	Tasks	must	be	defined.

By	default,	a	defined	Job	or	Task	is	set	to	the	"Active"	state,	but	it	is	possible	to	inactivate	each	Job	or	Task	individually,	see
Activate/Inactivate	Job	for	more	information.
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Loop	Functionality

Summary

“Loops”	are	introduced	in	VisualCron	version	6.0.0.	Loops	let	you	run	several	Tasks	multiple	times	in	three	loop	types:

1.	 For
2.	 For	Each
3.	 While

During	a	loop	you	are	able	to	access	loop	runtime	Variables.	For	example,	where	you	are	in	the	current	iteration	and	all	related
values.

Architecture

Loops	are	objects	that	are	stored	in	a	Job.	On	Job	can	contain	a	maximum	number	of	loops	equal	to	the	maximum	number	of	Tasks.
Loops	are	defined	by	a	start	Task	and	end	Task.	Anything	in	between	will	be	looped	in	Task	order.	Loops	cannot	cross	each	other	-
you	cannot	create	a	loop	in	a	loop.

Task	Conditions	are	checked	each	time	before	a	Task	is	run,	independent	of	if	Task	is	in	loop	or	not.

Loop	types

There	are	three	different	loop	types:

For

A	loop	type	with	and	x	and	y	value	where	x	and	y	are	numeric	values.

While

A	loop	type	that	can	compare	two	values	according	to	a	specific	data	type	(i.e.	string,	integer)	and	comparison	method	(i.e.	larger
than,	contains,	equal).

For	each

A	loop	type	that	iterates	through	an	existing	y	value.	A	list	of	some	sort.

Working	with	loops

Loop	display

If	one	or	more	Tasks	belong	to	a	loop	you	can	see	that	in	the	loop	column.	You	will	see	how	the	loop	stretches	over	itself	or	more
Tasks.

Purple	loop:	For	loop

Green	loop:	While	loop

Blue	loop:	For	Each	loop
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Add/Edit	loop

In	the	Task	list,	in	main	window	or	Task	list	of	add/edit	Job	you	can	double	click	in	the	“Loop”	column	in	each	Task	row.	This	will
open	up	existing	or	new	Loop	settings	window.

Add	loop	option

Add	loop	>	Main	settings

In	the	main	settings	you	enter	the	descriptive	name	of	the	Loop.	You	also	set	which	Task	the	loop	should	start	and	end	with.

Add	loop	>	Loop	settings

In	the	loop	settings	you	control	the	loop	type	by	clicking	on	one	of	the	three	radio	buttons.	You	can	click	on	the	Variable	button	next
to	each	text	field	to	find	and	insert	a	Variable	that	can	be	used	in	the	field.



For	x	to	y

Enter	two	numerical	values	or	Variables	that	contain	numerical	values.

While	x

Depending	on	type	comparison	you	enter	different	kind	of	values/Variables.

For	each	x	in	y

Enter	a	Variable	that	contains	a	list.	You	may	need	to	alter	field	separator,	text	qualifier	or	line	break	depending	on	the	format	of	the
Variable	list.

Sleep/Wait	in	each	iteration

Sets	the	wait	time	between	each	iteration.	This	is	especially	interesting	if	you	are	using	a	While	loop	because	you	might	want	to
save	resources	and	not	check	all	the	time.

Limitations

Set	the	maximum	number	of	iterations.	If	your	y	value	is	less	than	1000	then	lower	or	keep	value	to	prevent	never	ending	loops.

Add	loop	>	Loop	settings	>	Loop	Variables

Any	Variable	can	be	used	in	the	settings	of	the	actual	loop	to	provide	dynamic	x	and	y	values.	Also,	a	set	of	dynamic,	loop	context
sensitive	Variables	exist.	You	find	them	in	the	Variables	browser:



Loop	Id

Each	loop	in	a	Job	has	an	internal	Id.

Loop	name

You	are	able	to	set	a	name	of	a	loop	which	can	be	accessed	through	this	Variable.

Loop	type

If	it	is	a	For,	For	Each	or	While	loop.

Preset	X	value

The	original	left	hand	value	that	you	used	in	a	For	or	While	loop.

Preset	Y	value

The	original	right	hand	value	in	For,	While	or	For	Each	loop.

Current	X	value

The	value	of	the	position	in	the	loop.	This	value	is	interesting	when	using	For	or	For	Each	loop.

Current	Y	value

The	current	value	of	the	right	hand	value.	Should	be	the	same	as	Preset	Y	value	in	most	scenarios.

Current	Y	position	in	list

A	numeric	value	of	the	position	in	the	y	list.	Used	when	using	a	For	Each	loop	type.

Y	value	list

A	list	containing	all	rows	in	y.

Id	of	Task	that	loops	starts	with

Task	Id	for	the	selected	start	Task	in	the	loop.



Id	of	Task	that	loops	ends	with

Task	Id	for	the	selected	end	Task	in	the	loop.

Column	position	that	it	used	in	For	Each	loop

The	numeric	value	of	column	position	where	x	value	is	picked	up.

Field	separator

The	character	that	is	used	to	separate	feilds	in	For	Each	loop.

Text	qualifier

The	surrounding	character	of	each	column.

Line	break

The	line	break	character	that	is	used	in	each	column.

Number	of	loop	iterations	so	far

Number	of	loop	“laps”/iterations	that	has	been	done	so	far.

Maximum	allowed	iterations	before	exiting	a	loop

A	limit	that	prevents	loop	for	going	on	forever.	Default	1000.	This	value	is	showed	here.

Deleting	a	loop

To	delete	a	loop	you	open	the	Add/Edit	Job	window	and	go	to	Tasks	tab.	Right	click/select	a	Task	row	that	contains	a	loop	and	click
on	Delete	loop.	This	will	only	delete	the	related	loop	-	not	the	Tasks	in	it.

Changing	Task	order

A	change	of	Task	order	(clicking	up/down	in	the	numeric	box	in	the	Task	list)	affects	any	existing	loop.

If	a	loop	covers	3	Tasks	and	the	first	Task	is	moved	up	it	will	include	any	Task	that	becomes	number	two	in	the	list.

Deleting	Tasks

If	a	start	or	end	Task	is	deleted	VisualCron	will	attempt	to	shift	start	or	end	Task,	if	loops	covers	more	than	one	Task.	If	all	Tasks
that	a	loop	covers	are	deleted	the	loop	itself	will	be	deleted.
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File	Filter
The	file	filter	is	a	part	of	many	Tasks	and	other	objects	within	VisualCron.	The	purpose	of	the	file	filter	is	to	provide	a	standardized
way	of	filtering	out	files	for	a	given	Task.

Evaluation

The	file	filter	is	evaluated	the	following	way:

Location	AND	Content	AND	Date	AND	Size	AND	Attributes	=	filtered	files
Date	=	Date	older	than	AND/OR	Date	newer	than
Size	=	Size	smaller	than	AND/OR	Size	larger	than

File	filter	>	Location	Contains	the	basic	properties	of	finding	one	or	more	files.

Credentials

To	access	a	remote	computer	you	may	need	to	use	a	Credential.	Normally	that	Credential	is	a	remote	or	AD	user	with	"Local	logon"
unchecked.	The	Credential	must	match	the	user	name	and	password	of	the	user	that	you	want	to	login	for.	Select	a	Credential	in	the
combo	box	or	click	the	Settings	icon	to	open	Manage	credentials	in	order	to	add	or	edit	Credentials.

Folder

The	folder	path	where	the	source	file(s)	reside.	You	can	input	several	folders	by	separating	with	semicolon	";"	like	this:
C:\Temp;C:\test.	Click	the	Folder	icon	to	browse	the	folder	tree.

Include	sub	folders

If	the	file	filter	should	look	for	files	in	sub	folders	then	check	this	option.
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Exclude	folder(s)

If	the	file	filter	should	exclude	folder(s)	to	look	for	files.	Click	the	Folder	icon	to	browse	the	folder	tree.	You	can	exclude	multiple
sub	folders	by	separating	them	with	semicolon.	Please	not	that	the	exclusion	is	exact	to	a	specific	folder.	For	example:

C:\subfolder\main2	-	this	will	exclude	files	in	that	folder	only.	C:\subfolder\main2*	-	this	will	exclude	files	in	this	folder	and
sub	folders	to	this	folder.

Include	file	mask

Define	your	file	mask	for	the	file	name	here.	When	not	using	the	Is	regex	string,	you	can	use	the	normal	wildcard	characters	like	 or
?.	You	can	input	more	than	one	file	mask	by	separating	them	with	semicolon	";"	like	this:	.doc;*.txt.	Click	the	File	icon	to	browse
for	files.

Is	regex

If	the	include	file	mask	is	a	regular	expression.	For	more	information	about	regular	expressions	please	look	here:
http://www.regular-expressions.info/

Case	sensitive

If	the	file	name	search	is	case	sensitive.

Exclude	file	mask

It	is	possible,	the	same	way,	to	use	a	exclusion	filter.	When	not	using	“Is	regex”	string	here	you	can	use	the	normal	wildcard
characters	like	*	or	?.

Is	regex

If	the	exclude	file	mask	is	a	regular	expression.	For	more	information	about	regular	expressions	please	look	here:
http://www.regular-expressions.info/

File	filter	>	Content

Makes	it	possible	to	check	found	files	for	content.

File	filter	>	Content

Makes	it	possible	to	check	found	files	for	content.

The	default	Content	property	is	Don’t	check.	Use	the	drop-down	list	to	select	the	desired	property.

File	filter	>	Date

Makes	it	possible	to	check	the	created/modified	date	against	a	Variable	value.
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There	are	two	types	of	checks	Older	than	and	Newer	than.	These	can	be	combined	with	AND/OR	or	used	separately.	Only	date
variables	can	be	used	here.	Once	you	have	selected	a	Variable	it	can	be	previewed	when	hovering	over	text	box	(tool	tip)	or	in	the
group	caption.

Click	the	Variables	icons	to	view	and	select	available	Date	Variables.

File	filter	>	Size

Makes	it	possible	to	filter	out	files	based	on	size.	Like	the	Date	filter	it	can	be	combined	with	AND/OR	and	check	can	be	done	on
Larger	than	or	Smaller	than.

Check	if	file	is	smaller	than	x	size

Select	this	to	enable	size	checking.	Enter	a	value	in	the	numeric	text	box	and	select	the	size	unit	to	compare	with.	Default	is
kilobyte(s).	If	the	size	on	the	file	is	smaller	than	the	value	you	enter	in	the	numeric	box	it	will	return	true	(=	file	will	be	included).

Check	if	file	is	larger	than	x	size

Select	this	to	enable	size	checking.	Enter	a	value	in	the	numeric	text	box	and	select	the	size	unit	to	compare	with.	Default	is
kilobyte(s).	If	the	size	on	the	file	is	larger	than	the	value	you	enter	in	the	numeric	box	it	will	return	true	(=	file	will	be	included).

File	filter	>	Attributes

All	files	have	different	attributes.	If	you	want	to	check	for	a	specific	attribute	you	can	use	whether	to	include	or	exclude	a	file	based
on	attribute.



Include	all	attributes

The	default	is	checked,	uncheck	if	you	want	to	filter	on	attributes.

Include	attribute(s),	Exclude	attribute(s)

Check	the	attributes	you	want	to	include	or	exclude.

File	filter	>	Result

The	filtered	files	can	be	presented	(in	output)	in	different	ways.	It	is	possible	to	sort	the	result	on	various	values	like	name,	modified
date,	created	date	and	size.	You	can	also	limit	the	number	of	rows	returned	to,	for	example,	only	list	the	top	3	files	according	to	the
current	sorting.

Sort

It	is	possible	to	sort	the	result	on	various	values	like	name,	modified	date,	created	date	and	size.	If	sort	is	unchecked	the	files	will
just	be	presented	in	the	order	they	are	discovered.

Limit

Check	this	if	you	want	to	limit	the	number	of	rows	returned.	It	will	be	limited	according	to	the	number	(which	could	be	a	Variable)
and	the	current	sorting.

File	filter	>	Test

Makes	it	possible	to	test	your	current	file	filter	-	if	it	matches	any	existing	files



Show	filtered	files

The	test	will	use	the	selected	Credential.	Click	to	test	the	filter.
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Remote	File	Filter
The	remote	file	filter	is	a	limited	version	of	the	normal	local	file	filter.	The	difference	is	that	the	remote	file	filter	is	limited	for
remote	Tasks	(like	FTP/SFTP)	and	Triggers	(Remote	file).

Evaluation

The	file	filter	is	evaluated	the	following	way:

Location	AND	Content	AND	Date	AND	Size	AND	Attributes	=	filtered	files
Date	=	Date	older	than	AND/OR	Date	newer	than
Size	=	Size	smaller	than	AND/OR	Size	larger	than

Remote	file	filter	>	Location	sub	tab

This	tab	contains	the	basic	properties	of	finding	one	or	more	files.

Folder

The	folder	path	where	the	source	file(s)	reside.	You	can	input	several	folders	by	separating	with	semicolon	";"	like	this:
C:\Temp;C:\test

Include	sub	folders

If	the	file	filter	should	look	for	files	in	sub	folders	then	check	this	option.

Treat	unknown	types	as	files

Some	servers	to	not	report	the	correct	item	type	(file	or	folder)	when	listing	items	and	instead	reporting	unknown	type.	When
checking	this	property	VisualCron	will	treat	unknown	types	as	files.

Include	file	mask
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Defined	your	file	mask	for	the	file	name	here.	When	not	using	“Is	regex”	string	here	you	can	use	the	normal	wildcard	characters
like	or	?.	You	can	input	more	than	one	file	mask	by	separating	them	with	semicolon	";"	like	this:	```.doc;*.txt```

Is	regex

If	the	include	file	mask	is	a	regular	expression.	For	more	information	about	regular	expressions	please	look	here:
http://www.regular-expressions.info/

Case	sensitive

If	the	file	name	search	is	case	sensitive.

Exclude	file	mask

It	is	possible,	the	same	way,	to	use	a	exclusion	filter.	When	not	using	“Is	regex”	string	here	you	can	use	the	normal	wildcard
characters	like	*	or	?.

Is	regex

If	the	exclude	file	mask	is	a	regular	expression.	For	more	information	about	regular	expressions	please	look	here:
http://www.regular-expressions.info/

Remote	file	filter	>	Date	sub	tab

It	is	possible	to	check	the	created/modified	date	against	a	Variable	value.

Remote	file	filter	>	Size	sub	tab

It	is	possible	to	filter	out	files	based	on	size.	Like	the	Date	filter	it	can	be	combined	with	AND/OR	and	check	can	be	done	on	Larger
than	or	Smaller	than.

Remote	file	filter	>	Result	sub	tab

The	filtered	files	can	be	presented	(in	output)	in	different	ways.	It	is	possible	to	sort	the	result	on	various	values	like	name,	modified
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date,	created	date	and	size.	You	can	also	limit	the	number	of	rows	returned	to,	for	example,	only	list	the	top	3	files	according	to	the
current	sorting.

Sort

It	is	possible	to	sort	the	result	on	various	values	like	name,	modified	date,	created	date	and	size.	If	sort	is	unchecked	the	files	will
just	be	presented	in	the	order	they	are	discovered.

Limit

Check	this	if	you	want	to	limit	the	number	of	rows	returned.	It	will	be	limited	according	to	the	number	(which	could	be	a	Variable)
and	the	current	sorting.

Remote	file	filter	>	Test	sub	tab

In	the	Test	tab	you	can	test	your	current	file	filter	-	if	it	matches	any	existing	files.	The	test	will	use	the	selected	Credential.	Click	on
Show	filtered	files	to	test	filter.
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Cloud	Remote	File	Filter
In	order	to	simplify	and	unify	common	parameters,	the	standard	VisualCron	Cloud	remote	filter	is	used	in	the	below	list	of	Cloud
Tasks:

List	item(s)
Download	file(s)
Delete	item(s)

Location	sub	tab

Connection

To	use	a	specific	cloud	service	you	need	to	create	a	Connection	first.	Click	the	Settings	icon	to	open	the	Manage	Connections
dialog.

Bucket/Container

This	property	is	used	for	Amazon	Cloud	services	to	specify	the	Bucket.

Source	folder

This	is	the	remote	source	folder.	Click	the	Folder	icon	to	select	the	folder.
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Item	mask

The	file/folder	mask.	Use	wild	cards	like	and	?.	Click	the	File*	icon	to	select	the	file.

Filter

Select	whether	you	want	to	get	Files,	Folders	or	All.

Case	sensitive

Check	if	you	want	a	case	sensitive	match.

Include	sub	folders

Check	if	you	want	to	include	sub	folders	and	not	just	the	base	Source	folder.

Date	sub	tab

Modified	date

Use	a	Variable	to,	for	example,	download	files	older	than	a	specific	modified	date.

Created	date

Use	a	Variable	to,	for	example,	download	files	older	than	a	specific	modified	date.

Size	sub	tab



Check	if	file	is	smaller	than	x	size

Filter	files	that	are	smaller	than	a	value/Variable.

Check	if	file	is	larger	than	x	size

Filter	files	that	are	larger	than	a	value/Variable.

Result	sub	tab

Sort

By	checking	sort	you	can	sort	the	found	files	according	to	your	desired	order.	This	is	important	if	you	later	want	to	limit	the	result
to,	for	example,	the	10	newest	files.

Limit

How	many	files	you	want	to	return.

Test	sub	tab



The	Test	tab	lets	you	test	the	result	of	your	set	filters	to	see	what	is	really	returned.
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Folder	Filter
The	folder	filter	is	similar	to	the	file	filter	but	filters	out	folders	only.	It	is	used	in	various	Tasks.

Folder	filter	>	Location	sub	tab

Credentials

To	control	a	remote	computer	you	may	need	to	use	a	Credential.	Normally	that	Credential	is	a	remote	or	AD	user	with	"Local	logon"
unchecked	The	Credential	must	match	the	user	name	and	password	of	the	user	that	you	want	to	login	for.	Select	a	Credential	in	the
combo	box	or	click	the	Settings	icon	to	open	Manage	credentials	in	order	to	add	or	edit	Credentials.

Base	folder

Where	the	search	filter	should	start	finding	folders.	Click	the	Folder	icon	to	browse	the	folder	tree.

Include	base	folder

If	the	base	folder	should	be	included	in	the	result.

Include	sub	folders

If	sub	folders	of	the	base	folder	should	be	included	in	the	result.

Skip	to
main
content

https://help.visualcron.com


Include	folder	mask

Wild	card	for	filtering	out	folder	names.	Separate	multiple	folder	names	with	semicolon	";"	like	this:	C:\Temp;C:\test.	Click	the
Folder	icon	to	browse	for	files.

Is	regex

If	the	include	folder	mask	is	a	regular	expression

Case	sensitive

If	case	sensitive	search	should	be	done	on	the	include	folder	mask.

Folder	filter	>	Date	sub	tab

There	are	two	types	of	checks	Older	than	and	Newer	than.	These	can	be	combined	with	AND/OR	or	used	separately.	Only	date
variables	can	be	used	here.	Once	you	have	selected	a	Variable	it	can	be	previewed	when	hovering	over	text	box	(tool	tip)	or	in	the
group	caption.

Click	on	the	Variables	icons	to	view	and	select	available	Date	Variables.

Folder	filter	>	Size	sub	tab



Check	if	folder	is	smaller	than	x	size

Select	this	to	enable	size	checking.	Enter	a	value	in	the	numeric	text	box	and	select	the	size	unit	to	compare	with.	Default	is
kilobyte(s).	If	the	size	on	the	folder	is	smaller	than	the	value	you	enter	in	the	numeric	box	it	will	return	true	(=folder	will	be
included).

Check	if	folder	is	larger	than	x	size

Select	this	to	enable	size	checking.	Enter	a	value	in	the	numeric	text	box	and	select	the	size	unit	to	compare	with.	Default	is
kilobyte(s).	If	the	size	on	the	folder	is	larger	than	the	value	you	enter	in	the	numeric	box	it	will	return	true	(=file	folder	be	included).

Folder	filter	>	Test	sub	tab

Show	filtered	folders

The	test	will	use	the	selected	Credential	and	lets	you	test	your	folder	filter	-	what	folders	it	returns	based	on	the	filter.
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Task	-	Main	Settings
A	set	of	different	Task	types	can	be	defined	using	the	Add/Edit	Job	>	Tasks	tab,	then	press	the	Add	button	to	display	the	list	of
Tasks.

Add	Job	>	Tasks	>	Add	tab

After	selecting	a	Task,	in	this	case	the	Internal	>	Set	Job	Variable,	the	Set	Job	Variable	>	Main	Settings	tab	is	displayed.	Also,
the	selected	Task	is	preset	as	Task	type	but	this	may	be	changed.
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Set	Job	Variable	>	Main	Settings	tab

NOTE

If	several	Tasks	are	defined	for	a	Job	and	the	Tasks	are	under	execution,	the	Task	information	fields	will	include	just	executed,
present	and	previous	information.	In	the	Add/Edit	Job	>	Tasks	window,	adjust	the	Change	Task	order	in	which	the	Tasks	are
executed.

Encoding

The	encoding	property	sets	which	encoding	to	use.	This	feature	is	not	implemented	in	all	Tasks.	If	you	got	any	encoding	problem
please	contact	support.

Execution	context

Click	the	Change	button	to	set	Execution	context.

Processor	affinity	settings

This	control	if	the	CPU	usage	of	a	Task	should	be	controlled	automatically	(divided	over	processors/cores)	or	if	you	want	to	execute
on	a	specific	processor/core.

Stor	stanard	output/error

By	default,	VisualCron	is	capturing	and	storing	all	output	from	executed	processes.	If	you	don't	want	this	and	want	Windows	to
capture	all	output	you	uncheck	these	options.

Extended	Task	debug	logging

Sometimes	support	of	VisualCron	asks	you	do	check	this	to	provide	additional	debug	information	for	a	problem.	When	checked,
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additional	debug	output	will	be	added	to	standard	output.

Task	order

The	task	order	can	be	changed	by	either	clicking	on	the	up/down	arrows	next	to	each	Task	or	select	a	Task	row	and	edit	the	Change
Task	order	numeric	field.

Edit	Job	>	Tasks	tab

Loop

Loops	can	be	added	to	one	or	more	Tasks,	read	more	about	loops	here.
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